Fantasy Grounds PREP SHOW
Page 1 of 2 12 Last
  1. #1

    Bug that are just lived with or is it just me?

    Hello all,

    I just wanted to know if this is something I hit or is it just so common that it is ignored? I don't think any of these are ruleset specific (at the root).

    I routinely hit these bugs:

    1. Random highlighting of text on the screen.
    2. Insertion of ' ' after a section of bold. So <b>hello<b>: yields <b>hello<b> : This likely is with italic as well but can't remember off hand.
    3. In tables, I will tab between fields and the cursor will go to a random location in the text in the next fields but on typing it will be at the beginning of the field.
    4. Click in a text field at the beginning and sometimes the cursor will be at a random position. However, on typing it is at the start.
    5. (Maybe 5e / pathfinder specific) Sometimes hover over an active area in a text field and the highlight will not highlight the active text correctly. So if you click/dclick it rolls correctly but the highlight is off by several characters at the start.

    Are there other bugs that are common we seem to be ignoring?


  2. #2
    Zacchaeus's Avatar
    Join Date
    Dec 2014
    I've only seen number 2 and that isn't a bug as much as a factor of the way the xml works. The trick is to include the punctuation inside the bold or italic or whatever. So <b>Bold:</b>.
    If you need to contact customer support or if there is something that you would like to see in Fantasy Grounds that isn't currently part of the software or if there is something you think would improve a ruleset then add your idea here

  3. #3
    LordEntrails's Avatar
    Join Date
    May 2015
    -7 UTC
    Blog Entries
    For #1, I assume this is not action text is it? Such as an attack or save or damage string? FG tries to make actions clickable and it indicates this by highlighting it.

    Haven't seen the others, but will try to pay attention and see if I do see them. I do wonder if the offset highlighting is do to scaleui or windows scaling? Though I usually run scaleui 120 or so.

  4. #4
    #5 is action text specific. It highlights the action text but not correctly. Mostly it highlights correctly but will get into a state where it just wont. #1 is just (seemingly random labels) get highlighted from time to time not action text. Cannot unhighlight them. I do run ui 120/125 so maybe I'll try 100% and see if it goes away.

  5. #5
    As @Zacchaeus has mentioned, I'm not seeing these issues either (other than #2, which is not something fix-able with the current data model (I've tried, but it requires full migration of DLC and client to CDATA objects, which is too large a scope). So, I'd need specific steps to recreate the other items.


  6. #6
    I definitely run into #1 from time to time. It seems to only happen during certain sessions. I can have FG open for several hours and not have this happen at all, but another time, it will happen constantly during the time I have FG open.

  7. #7
    I've run into 3 and 4, but only once or twice, and I wasn't sure how to reproduce, so I couldn't really make a test case to bring here. But I have seen it. Actually what I ran into was slightly worse- there was some text that it was impossible for me to delete because I couldn't get the cursor to act around that part of the text no matter what I did. IIRC I had copied the item "Aerisi's Spellbook" from the Princes of the Apocalypse module and was editing it to be a different spellbook, and I couldn't remove the last couple characters of the text, and where the cursor was blinking was not where the cursor was acting.

  8. #8
    Here's something else that I've just been putting up with and haven't reported, but now that there's this thread, I will mention it: Every time I share images from one particular module, namely the 5e Monster Manual, they become un-shared the next time I run Fantasy Grounds, and I have to re-share them. Images shared from all other sources stay shared. It's just the ones from the Monster Manual that have this issue.

  9. #9
    It sounds like the permissions may not be correct on that file. Try deleting the Monster Manual.xml files in your campaigns moduledb subfolder.


  10. #10
    I've seen #1, #3, and #4, and for me they rarely happen, but when they do, all three happen at pretty much the same time.

    Then I'll edit a few more records and suddenly it's back to normal.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
PF2E Playlist

Log in

Log in