5E Product Walkthrough Playlist
Page 1 of 2 12 Last
  1. #1

    Occasionally Unable to Draw (4.1.14)

    I noticed a new bug that is hard to reproduce last night during my session. I知 at the latest version as were the players (4.1.10).

    Prior to the session I was able to erase and write on maps just fine (very happy undo is back btw!)

    Once players joined however I was occasionally unable to draw on the maps. The pen tool stopped working at all. Curiously sometimes to it would start working for me and all but ONE of the other players. Then on another map, the issue went back to me. I知 not sure of exact steps to reproduce, it was definitely a weird bug.

    Updates: I opened this post with 4.1.10. As of 3/6 this is still a bug with 4.1.14
    Last edited by seansps; March 6th, 2022 at 18:26. Reason: Updates 3/6/22

  2. #2
    LordEntrails's Avatar
    Join Date
    May 2015
    Location
    -7 UTC
    Posts
    17,547
    Blog Entries
    9
    Though I'm not sure it would help diagnose, if it happens again, try to capture the logs by type "/console" in the chat window and then hitting the Compile Logs button. That will at least tell the devs the environment that you are in.

    Problems? See; How to Report Issues, Bugs & Problems
    On Licensing & Distributing Community Content
    Community Contributions: Gemstones, 5E Quick Ref Decal, Adventure Module Creation, Dungeon Trinkets, Balance Disturbed, Dungeon Room Descriptions
    Note, I am not a SmiteWorks employee or representative, I'm just a user like you.

  3. #3
    Quote Originally Posted by LordEntrails View Post
    Though I'm not sure it would help diagnose, if it happens again, try to capture the logs by type "/console" in the chat window and then hitting the Compile Logs button. That will at least tell the devs the environment that you are in.
    Will do! I値l post back if I get more info.

  4. #4
    There is probably a specific set of steps that is triggering the blocked behavior; so anything you can discover about the exact steps that trigger the behavior would allow us to address quickly.

    Regards,
    JPG

  5. #5
    So, there's definitely a bug here, but I couldn't figure out what exactly is causing it. I just tried it alone (no players connected) both on a map from the module and a map of my own that I added to the campaign.

    - On some maps in the module I was able to draw and erase on.
    - I tried on another map and then suddenly was not able to draw.
    - I tried on my own map and noticed the following:
    -- I tried to draw on it and nothing showed up.
    -- I then tried to erase on the map, something I wrote before, and suddenly everything I had just attempted to draw showed up
    -- I then noticed that I cannot draw until I then attempt to erase, in which case, what I just tried to draw shows up (and I can continue to erase it at that point if I want to.)
    -- Occasionally, the undo feature gets buggy again and stops working entirely and cannot undo what I erased or drew, or it undos/redos something that happened much much earlier.

    I also went ahead and looked in the console but saw no output at all regarding any errors. I can share my campaign zipped up and tell you which maps I tried, if that helps.

    EDIT: typos, clarity
    Last edited by seansps; October 8th, 2021 at 18:57.

  6. #6
    Okay, I just opened my campaign and tried again. I reproduced the above issues with the following steps;

    1. Open any map. Note that drawing works fine as does undo and erase.
    2. Close the map
    3. Open a different map. Note that drawing does not seem to work.
    4. Start trying to erase anywhere on map.
    5. Note that the drawing just attempted shows up now.

    Attached is my log output if that helps!

    Edit: Curiously, I was unable to recreate the bug when using the same steps in a new campaign, so I wonder if there is something weird about the files in my current one.
    Attached Files Attached Files
    Last edited by seansps; October 9th, 2021 at 22:35.

  7. #7
    I wasn't able to recreate the issue in my test 5E campaign using the steps you followed above.

    Can you provide the campaign folder zipped up that is not working for you, as well as the exact names of the maps you are using in your example steps above?

    Thanks,
    JPG

  8. #8
    Quote Originally Posted by Moon Wizard View Post
    I wasn't able to recreate the issue in my test 5E campaign using the steps you followed above.

    Can you provide the campaign folder zipped up that is not working for you, as well as the exact names of the maps you are using in your example steps above?

    Thanks,
    JPG
    Sure, thanks for looking into it! Well, now I am *very* confused because I just tried to confirm the steps again for this post, and was UNABLE to recreate it, but here is what I did last time:

    - Open "Fane-of-the-Eye-Player" -- write on it, close it
    - Open "Red-Larch-Player" -- write on it, notice the bug

    But, as I said, now it suddenly worked? In either case here is my campaign files zipped. (It was too large to post here so I put it on Google drive.)

    https://drive.google.com/file/d/1BIt...ew?usp=sharing

  9. #9
    A couple quick items on extensions:
    * The two D&D official language fonts extensions will overwrite each other (one contains standard fonts; the other contains FR-specific fonts); so you only need one.
    * The attunement tracker functionality is built into the default 5E ruleset code as of June 2021; so the extension is no longer needed.

    Another quick item on images:
    * You have several of your maps saved as PNG files; which are about 5 times the size of JPG files with almost the same quality. You can save some campaign size and transfer times by converting to using JPG map files.

    On the issue reported:
    I tried downloading the campaign to recreate the drawing issue; but I was not able to do so either. I tried straight after downloading; then again after reverting those two maps and reloading the campaign.

    We'll have to keep an eye on this to see if we can find what might be causing the issue.

    Regards,
    JPG

  10. #10
    Thank you so much!

    I wasn't aware of the font issue so I'll fix that. Also, had no idea the attunement was built in now! I'll take a look at that (that's awesome!)

    The images issue I was aware of... this was the first FG campaign I started, so was still learning some things such as to use JPG instead of PNG for the maps and such. But thanks for pointing that out-- I'll go back and clean those up too.

    Super weird about the bug suddenly getting fixed, I kind of wonder if my campaign was in a weird state and then I accidentally fixed it when testing/trying to recreate. In any case thanks so much for looking into it! I'll report back if I ever figure it out.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
DICE PACKS BUNDLE

Log in

Log in