Starfinder Playlist
Page 1 of 2 12 Last
  1. #1

    Beasts and Barbarians Rulesets not working

    Hello,
    Yesterday I had no problem accessing my copies of Beasts and Barbarians for Savage Worlds through my Fantasy Grounds Unity and now today it will not open either the GM or the Player's guide. Is this possibly related to them originally being for FG Classic? Other rules modules seem to be working fine.

    The Error line reads the same for both modules

    Process Data file (BNB Player Guide):' ' is an unexpected token. The expected token is ';'. Line 5, position 27.

    Ironically I just had session Zero for 2 players who I've convinced to work online with FG, and we had chosen Beasts and Barbarians from multiple options, so I need to have an idea if this is fixable or we will have to change games. Appreciate the help,

    Caratacus
    Attached Images Attached Images

  2. #2
    LordEntrails's Avatar
    Join Date
    May 2015
    Location
    -7 UTC
    Posts
    17,474
    Blog Entries
    9
    Can you use Compile Logs from the launch screen to generate your logs files and then attach them here?

    Problems? See; How to Report Issues, Bugs & Problems
    On Licensing & Distributing Community Content
    Community Contributions: Gemstones, 5E Quick Ref Decal, Adventure Module Creation, Dungeon Trinkets, Balance Disturbed, Dungeon Room Descriptions
    Note, I am not a SmiteWorks employee or representative, I'm just a user like you.

  3. #3
    I've never used that button before. Once I've compiled them where is it saved?

  4. #4

  5. #5

    Join Date
    May 2016
    Location
    Jacksonville, FL
    Posts
    2,211
    Blog Entries
    7
    Which edition of B&B is this happening in? The first and most important problem I'm seeing is that in the SVN neither edition uses the module name 'BnB Player Guide' or 'BnB GM Guide' so I'm not actually sure where to look to hotfix it... I'm unable to duplicate this error with either the retail version or my local development versions.

    Steel Edition (SE) is the most current edition and has been updated to SWADE here on FG. Gold Edition (GE) is no longer available except for customers who had already purchased it. I'm not supposed to give GE any further updates, but hotfixes for broken issues are still permitted.

    I also notice your Garden of Death has an old module name that was changed quite some time ago.
    Last edited by Talyn; August 11th, 2021 at 19:32.

  6. #6
    I've had them for a while, and used them in FG Classic. I am certain they are Gold Edition, due to the actual rules within. Steel edition changed some rules. Truthfully I've had them for a few years, just haven't used them a lot lately.

  7. #7

    Join Date
    May 2016
    Location
    Jacksonville, FL
    Posts
    2,211
    Blog Entries
    7
    I just pulled the Golden Edition off SVN and ran it in Unity and also got no errors there. It sounds like you're still using the old modules from way back when? Run the FG Updater, and if all else fails, delete the older modules before running the Updater to make sure it downloads the most current files.

    Here's what you should be seeing for either one:

    Golden Edition (BBGE)



    Steel Edition (BBSE)


    If your Library window looks different, then you're definitely using really old files.
    Attached Images Attached Images

  8. #8
    ddavison's Avatar
    Join Date
    Sep 2008
    Posts
    6,178
    Blog Entries
    21
    Yes, please move the modules from your modules folder and then run an update. This will make sure that you get the latest version.

  9. #9
    OK, so if I understand correctly I removed the two files from the modules folder, ran an update. Things work fine with everything else, except of course the Beasts and Barbarians modules aren't available to use in game, so when I reloaded them into modules folder I got the same result as before the update.

  10. #10
    ddavison's Avatar
    Join Date
    Sep 2008
    Posts
    6,178
    Blog Entries
    21
    Okay, so we need to find the source for those modules. If you bought it from the store, it should show up in your Order History and they should automatically install for you into either the modules folder, or the vault folder. The vault is the default. If you put a module in the modules folder it will override the module from your vault folder.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
5E Product Walkthrough Playlist

Log in

Log in