Joshua Stream Pre
  1. #1

    [Issue] Periodic Image Sharing Issue

    I am a player in a curse of Strahd campaign, and ususally we can get a full evening in without running into any problems, but over the last week or so we've been running into an issue where some of the players stop receiving images, and see nothing more than a red "?" character instead of the actual image. It does not matter if its an image from the campaign, or a custom image that the DM has added to their assets. To address this we had 2 of the 4 players clear their cache, and 1 (me) simply run FGU in admin mode, and the other player remained as they are (mainly because they never have an issue). The irony here, is that of the 4 players, one is in Europe (never has an issue), and the remaining 3 of us are all in North America, and we're the ones that have issues. The DM has indicated their ISP has had issues, they use an ISP in Florida, and I can't speak to their reliability, but its possible they do have issues.

    When we had the two clear their cache, and they reconnected, the FGU server failed to push modules to them, and even I had issues after I disconnected and reconnected my client with admin mode, in that no modules could be seen to load, and no characters were shown for us to load.

    We all disconnected, and had the DM completely unload all their modules, and reload them, then restart the server to clear everything out, and then had each player that was having issues connect one at a time, that seemed to help in that we were able to load all the modules and our characters, then we would disconnect and allow the next player to connect and do their thing.

    Once all players had done that we all reconnected, had the DM begin to share images again. The first worked (map with effects), and the next image could only be received by myself and the player who has never had issues. Same with the third. It was at this point that we looed over the logs and noticed something. The players who are having issues are regularly sending the file request to the server, but the server never fulfills the request, as per the logs, and from that point on those affected players can never get another image. its as if the communication between the server and the client simply refuses to send new images. When the DM unshares the problem images, and reshares them... no new request shows up in the logs, its as if the server thinks the client already has the image and doesn't try to resend it, or the client never sees the file share so it can make the request.

    I've got logs for everyone except the player who has never had an issue, and the DM, and will be attached to this post, they are names as follows:

    1. fgu_logs_20210724.2 - Orianna.zip (Player who had issues with all images shared after the map)
    2. fgu_logs_20210724_kaldor.zip (Player who also had issues with all images shared after the map)
    3. fgu_logs_20210724.zip (My logs files, even though I had no issues this time, I did have issues prior to the cache clearing and running FGU in admin - these logs are after that issue).
    4. fgu_logs_20210724 - Bunny.zip (DM's logs)
    Attached Files Attached Files
    FGC Ultimate License, FGU Ultimate License
    FG Discord - Stoehovve
    Fantasy Grounds Unity Tutorials - https://www.youtube.com/user/stoehovve

  2. #2
    LordEntrails's Avatar
    Join Date
    May 2015
    Location
    -7 UTC
    Posts
    14,480
    Blog Entries
    9
    Has the GM cleaned up the campaign shared files? Long running campaigns can get "heavy" with hundreds or thousands of shared images that are no longer needed, yet are all stored/duplicated on the client/player computers. As a GM,I keep my "stuff" in homemade modules, so that I can easily unshare/unload entire modules when we are done with a section of the campaign. This way I keep the number of shared images to a few dozen at most. It helps with these types of issues.

    Don't know if it will solve your issue or not, but having the GM clean up what they have shared that is no longer needed is a good practice to help prevent issues and performance problems.

  3. #3
    Hi LordEntrails,

    We are only on our 5th session, and this is the first campaign the DM is running using unity, they had a FGC campaign going prior to my joining, and yes they DID point FGU to a new location, so they should not really have to unload anything at this point in the campaign. On top of that, they've only shared ~ 15 items, so there's not much in the cache to clean up at this point in time.
    FGC Ultimate License, FGU Ultimate License
    FG Discord - Stoehovve
    Fantasy Grounds Unity Tutorials - https://www.youtube.com/user/stoehovve

  4. #4
    LordEntrails's Avatar
    Join Date
    May 2015
    Location
    -7 UTC
    Posts
    14,480
    Blog Entries
    9
    The next thing I would look at is Advanced Security by their ISP, or Flood Protection on the GM or client routers.

    There are some errors of concern in the logs, but I don't know enough of what to make of them. Perhaps opening a ticket with support will get CArl or John to look at them and be able to tell what the issue is. The things I'm seeing that tell me their is a network/connection issue are;


    [7/24/2021 6:26:28 PM] Noble Connect [6656]: Socket can not send [fe80::e0d1:c8de:3dde:8f6e%6]:63885 -> [2604:a880:800:14::7:5000]:3478
    The requested address is not valid in its context.
    (AddressNotAvailable - 10049)
    ...
    [7/24/2021 6:26:28 PM] Noble Connect [6701]: Socket can not send [::1]:63887 -> [2604:a880:800:14::7:5000]:3478
    The requested address is not valid in its context.
    (AddressNotAvailable - 10049)
    ...
    [7/24/2021 6:36:29 PM] Noble Connect [608023]: Handle response from 104.131.11.8:3478 at 192.168.200.103:63886
    [7/24/2021 6:36:29 PM] Noble Connect [608023]: Received REFRESH ERROR RESPONSE [97374691712740353744174b] (438): Stale nonce
    [7/24/2021 6:36:29 PM] Noble Connect [608024]: Stale Nonce. Resending REFRESH REQUEST [97374691712740353744174b] with new nonce
    [7/24/2021 6:36:29 PM] Noble Connect [608025]: Sending REFRESH REQUEST [e5656372f3b938f5afd3711f] from 192.168.200.103:63886 to 104.131.11.8:3478
    ...

  5. #5
    I responded to @GoldBunnyFox in the support ticket created.

    There's more detail in the support response; but here is the information I asked for.

    * Have you tried having the players clear their cache folder through the folder icon in the upper left of launch screen already?
    * Can I get a copy of the whole campaign folder zipped up?

    Thanks,
    JPG

  6. #6
    I think the Curse of Strahd campaign may be corrupt using the new FG Unity software. Bunny (the DM) and two players, including myself, have spent four hours testing things today, not including many other hours of troubleshooting this month.

    We have tested everything with a fresh Strad campaign (i.e., no custom images or material). Certain images, such as Ishmael the Lesser, do not load. Even some Monster’s Manual and Player Handbook images do not load when running a fresh Strahd campaign.

    Before each test, we cleared our cache, and the results were consistent. The problem is not related to antivirus/firewall software or a network issue. I used NetLimiter to monitor network traffic to and from fantasygrounds.exe, and Bunny’s ISP is not causing the issue.

    To verify this, Bunny loaded a new Lost Mine of Phandelver campaign. Within this campaign, maps and images loaded fine. In fact, they transferred faster to players than the Strahd campaign. NetLimiter reports Lost Mine materials downloaded at about 1.1MB/sec, while the Curse of Strahd materials only downloaded at about 320K/sec. These results were consistent over multiple tests, making me question the Strahd campaign’s integrity.

    Would it be possible to grant me temporary access to the Strahd module (username AceHarding), so that I may act as DM and test it with other players? This would help to better determine whether the Strahd campaign itself has issues running on the new FG Unity software. I also greatly appreciate any other help or advice you can offer… it’s been a nightmare for our group.

  7. #7
    Zacchaeus's Avatar
    Join Date
    Dec 2014
    Location
    Scotland
    Posts
    17,285
    Welcome to FG.

    I'm assuming you are one of the players in the same campaign as above?

    If so as Moon Wizard requested he'll need to see the campaign and the log files to try and determine what the issue is. It seems to be something particular to your group since this isn't a widely reported problem.
    If you need to contact customer support or if there is something that you would like to see in Fantasy Grounds that isn't currently part of the software or if there is something you think would improve a ruleset then add your idea here http://fgapp.idea.informer.com/

  8. #8
    I am a player in the campaign. Sorry I did not mention that, and thanks for the welcome. The DM, Bunny, said he sent our logs from yesterday and the campaign. Hopefully Moon Wizard will be able to figure out the issue, as multiple players in the group are affected. Thanks so much for the help!

  9. #9
    I was out of town for a few days; but I have all the information that Bunny sent. Since this is not happening for other users, I'll probably have to have some back and forth with the GM to see if we can identify what is happening.

    Regards,
    JPG

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Fantasy Grounds Fridays Pre

Log in

Log in