Fantasy Grounds Fridays Pre
  1. #1

    Can't add NPC to Battle - error message included

    Weird problem here, I don't seem to be able to add NPCs to a battle. When I try I get the following error message:

    [ERROR] Script execution error: [string "campaign/scripts/encounter_npclist.lua"]:39: attempt to call field 'addLinkToBattle' (a nil value)

    I have only started to encounter this today and it appears to be for Traveller only, as D&D 5e will allow me to add NPCs to an encounter. I have tried using multiple Mongoose Traveller campaigns and newly created ones with the same problem. It does not matter whether I use NPCs from the Traveller Core Rulebook or create a new NPC. I have closed FGU down, I have patched it and re-booted my PC but the problem remains.

    Anyone else having this problem or have any ideas how to resolve it?

    cheers
    Craig

  2. #2
    Please email that to [email protected].
    Don't Dream it, Be it.

  3. #3
    Quote Originally Posted by Cuirassier View Post
    Weird problem here, I don't seem to be able to add NPCs to a battle. When I try I get the following error message:

    [ERROR] Script execution error: [string "campaign/scripts/encounter_npclist.lua"]:39: attempt to call field 'addLinkToBattle' (a nil value)

    I have only started to encounter this today and it appears to be for Traveller only, as D&D 5e will allow me to add NPCs to an encounter. I have tried using multiple Mongoose Traveller campaigns and newly created ones with the same problem. It does not matter whether I use NPCs from the Traveller Core Rulebook or create a new NPC. I have closed FGU down, I have patched it and re-booted my PC but the problem remains.

    Anyone else having this problem or have any ideas how to resolve it?

    cheers
    Craig
    Thank you for the report. We will get in touch with the developer and see what might be causing the issue.
    Dominic Morta
    Ruleset Developer
    Smiteworks

    How to zip up your campaign if the Developers ask for it-How to zip up your campaign if the Developers ask for it

    How to provide an Unity Connection issue?-Connection Issues and What to Provide

    Unity Updater issue?-Updater Issues

    Classic and Unity Port Forwarding?-Fantasy Grounds Connections Explained

    Comcast or Cox ISP User?-Comcast XFinity and Cox Users

    Have a suggestion?-Idea Informer

  4. #4
    Quote Originally Posted by Cuirassier View Post
    Weird problem here, I don't seem to be able to add NPCs to a battle. When I try I get the following error message:

    [ERROR] Script execution error: [string "campaign/scripts/encounter_npclist.lua"]:39: attempt to call field 'addLinkToBattle' (a nil value)

    I have only started to encounter this today and it appears to be for Traveller only, as D&D 5e will allow me to add NPCs to an encounter. I have tried using multiple Mongoose Traveller campaigns and newly created ones with the same problem. It does not matter whether I use NPCs from the Traveller Core Rulebook or create a new NPC. I have closed FGU down, I have patched it and re-booted my PC but the problem remains.

    Anyone else having this problem or have any ideas how to resolve it?

    cheers
    Craig
    Hi Craig,

    Just tested in FGU, new campaign, dragged in an NPC from Drinax Companion appeared as expected and no error.

    Can you supply the error log or a screen shot of the error please.

    Thanks,
    MBM





    Cheers
    Rulesets - Mongoose Traveller 2E & (1e)
    Now on my list, continue building the RQ ruleset

  5. #5
    Looks like a patch in the last 24 hours has resolved this issue.

    I had the problem for two days (with multiple patches, reboots, etc) and it was definitely a problem with the FGU install on my main PC. A friend did not have the problem and I had FGU loaded on a second PC and it did not have the problem. I decided to give it another go this morning before sending off a log file, patched FGU and now suddenly the problem is gone. FGU Traveller is working normally again. No idea what the problems cause was or what solved it but it is now resolved. Thanks for the help and comments guys.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Joshua Stream Pre

Log in

Log in