Joshua Stream Pre
  1. #1

    Sporadic error modifying NPC weapons - Keep the 'type' special solves error

    Hello all,

    After the recent update (to version 4.1.2) I experience a sporadic error when I modified a NPC's weapon details - error = looking for nil value.

    The steps I took to modify the NPC that resulted in the error were;

    1) Copy the NPC
    2) Unlock NPC
    3) Unlock the weapon
    4) Change the 'type' to relevant skill - one handed slashing for eg
    5) Change the weapon - for one handed slashing, say Scimitar

    This resulted in the error occurring. Prior to the update, this worked fine.

    After a bit of testing (removing Exts, checking updates, pairing my laptops to see is different NPCs on either caused the problem, reviewing the youtube vids etc), I found the answer is to keep the 'type' to special - this is the default 'type' when an NPC is unlocked.

    Mace Orc.png

    Just thought I'd post this incase anyone else had experienced this...? Or it helped anyone experiencing the same issue.

    Happy gaming all!

    Rainbird

  2. #2
    Sulimo's Avatar
    Join Date
    Dec 2014
    Location
    Pacific Time Zone
    Posts
    497
    I've never done it that way.

    When creating NPCs, like you I copy an existing one, but if the the attack is just listed as Melee or Missile, I drag the proper weapon from the Items list and modify the OB, that way all of the links are work properly.

    Not all who wander are lost.

  3. #3
    Thanks Sulimo - I'll use that method from now on. I was following one of the Youtube vids and, until recently, it worked.

    Rainbird

  4. #4
    Hi Rainbird,

    Thanks for reporting it and the details to recreate it. I will see about getting it fixed. Do you have the exact error you encountered?

    Dakadin

    Rolemaster Classic for FG Wish List - http://rm4fg.idea.informer.com/

  5. #5
    Hi Dakadin,

    I grabbed a log as I was about to report it before I fluked on to a fix! But I can't see how to upload it here....

    The error was (from memory) '406 trying to match bottom left, looking for nil value'

    Sorry I can't be more specific.

    Regards,

    Rainbird

  6. #6
    Thanks Rainbird. That might be enough for me to track it down.

    Rolemaster Classic for FG Wish List - http://rm4fg.idea.informer.com/

  7. #7
    Hi Rainbird,

    I can't seem to recreate the error. I've been looking through the code and can't find where the error is occurring. When it happens again, can you get the error since it will have the line number and also which value is nil? That will allow me to track it down and put in some code to prevent it from happening again in the future. Please let me know if you have any questions.

    Thanks,
    Dakadin

    Rolemaster Classic for FG Wish List - http://rm4fg.idea.informer.com/

  8. #8
    Hi Dakadin - I've been trying to recreate the error and failing! I have the error log saved. Below are extracts with the error quoted.

    [5/28/2021 9:33:26 AM] FGU: v4.1.2 ULTIMATE (2021-05-19)
    [5/28/2021 9:33:26 AM] OS: Windows 10 (10.0.0) 64bit
    [5/28/2021 9:33:26 AM] GRAPHICS: NVIDIA GeForce RTX 3070 Laptop GPU : 8044
    [5/28/2021 9:33:26 AM] UI SCALE: 0.95
    [5/28/2021 9:33:26 AM] USER: Rainbird
    [5/28/2021 9:33:26 AM] Launcher scene starting.
    [5/28/2021 9:33:37 AM] Starting cloud server mode. [Rainbird]
    [5/28/2021 9:33:46 AM] Game server started. [xxxxxxxxxxxxx]
    [5/28/2021 9:33:46 AM] Launcher scene exiting.
    [5/28/2021 9:33:46 AM] Tabletop scene starting.
    [5/28/2021 9:33:46 AM] NETWORK STATUS: [Server] [Connected]
    [Server Type - CLOUD - PUBLIC]
    [5/28/2021 9:33:46 AM] Match successfully created on lobby.
    [5/28/2021 9:33:56 AM] MEASURE: RULESETS LOAD - 10.5057857 - RolemasterClassic
    [5/28/2021 9:33:56 AM] MEASURE: EXTENSIONS LOAD - 0 - 0
    [5/28/2021 9:33:57 AM] MEASURE: MODULE LIST BUILD - 0.7156645 - 26
    [5/28/2021 9:33:57 AM] MEASURE: REFRESH IMAGE ASSETS - 0.0663414
    [5/28/2021 9:33:57 AM] MEASURE: REFRESH PORTRAIT ASSETS - 0.0039894
    [5/28/2021 9:33:57 AM] MEASURE: REFRESH TOKEN ASSETS - 0.0717384
    [5/28/2021 9:33:57 AM] MEASURE: ASSET LIST BUILD - 0.1430661
    [5/28/2021 9:33:59 AM] MEASURE: LOAD - PART 1 - 13.2862185
    [5/28/2021 9:34:01 AM] MEASURE: MODULE LOAD - 0.9018187 - Arms Law
    [5/28/2021 9:34:04 AM] MEASURE: MODULE LOAD - 3.0183732 - Character Law
    [5/28/2021 9:34:10 AM] MEASURE: MODULE LOAD - 6.0807398 - Creatures and Treasures
    [5/28/2021 9:34:10 AM] MEASURE: MODULE LOAD - 0.1825118 - FG Battle Maps
    [5/28/2021 9:34:14 AM] MEASURE: MODULE LOAD - 4.031603 - Rolemaster Companion 1
    [5/28/2021 9:34:14 AM] MEASURE: MODULE LOAD - 0.0279561 - Shops Instructions
    [5/28/2021 9:34:20 AM] MEASURE: MODULE LOAD - 5.5130086 - Spell Law
    [5/28/2021 9:34:20 AM] MEASURE: MODULE LOAD - 0.5317531 - The Armoury
    [5/28/2021 9:34:22 AM] RULESET: Rolemaster Classic ruleset v2.1.29 for Fantasy Grounds
    Copyright 2020 SmiteWorks USA, LLC and Aurigas Aldeberon LLC
    [5/28/2021 9:34:22 AM] RULESET: Core RPG ruleset (v2021-05-21) for Fantasy Grounds
    Copyright 2021 Smiteworks USA, LLC
    [5/28/2021 9:34:22 AM] MEASURE: LOAD - PART 2 - 22.4458485
    [5/28/2021 9:35:44 AM] [WARNING] Frame tabs contains out-of-range values in BottomLeft.
    [5/28/2021 9:38:25 AM] [ERROR] Script execution error: [string "utility/scripts/tableview_window.lua"]:486: attempt to compare number with nil

    [5/28/2021 9:25:21 AM] [WARNING] Frame tabs contains out-of-range values in BottomLeft.
    [5/28/2021 9:25:34 AM] [ERROR] Script execution error: [string "armor_mm_skilldropdown"]:4: attempt to call field 'ManeuveringInArmorSkillList' (a nil value)
    [5/28/2021 9:29:04 AM] Campaign saved.
    [5/28/2021 9:29:29 AM] [ERROR] Script execution error: [string "armor_mm_skilldropdown"]:4: attempt to call field 'ManeuveringInArmorSkillList' (a nil value)
    [5/28/2021 9:31:53 AM] [ERROR] Script execution error: [string "armor_mm_skilldropdown"]:4: attempt to call field 'ManeuveringInArmorSkillList' (a nil value)
    [5/28/2021 9:32:31 AM] Destroying match
    [5/28/2021 9:32:32 AM] Tabletop scene exiting.
    [5/28/2021 9:32:33 AM] Launcher scene starting.
    [5/28/2021 9:32:38 AM] NETWORK STATUS: [Error]
    [5/28/2021 9:32:38 AM] Launcher scene exiting.

    Hope this helps? And apologies for sending you on a wild goose hunt!

    Regards,

    Rainbird

  9. #9
    Hi Rainbird,

    That definitely helps. I put a few extra checks in the code for the two different errors you encountered that should prevent it from happening after the next release.

    Thanks,
    Dakadin

    Rolemaster Classic for FG Wish List - http://rm4fg.idea.informer.com/

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Fantasy Grounds Fridays Pre

Log in

Log in