PF2E Playlist

Thread: Handler error

  1. #1

    Handler error

    In the past two builds I am occasionally getting this error:

    [ERROR] Handler error: [string "campaign/scripts/image.lua"]:11: attempt to call global 'getGridSize' (a nil value)

    In this last instance it was when putting an effect on an NPC.

    Any idea what it is and any tips on how to make it go away :-)

    Edit: Closing the map and reopening it make the error stop for a while. But then it comes back.
    Last edited by kevininrussia; April 28th, 2021 at 05:14.

  2. #2
    Do you have any extensions running; or any rulesets in folders?

    That file in CoreRPG (nor any other official ruleset) does not have that function call at that line in a file with that name.

    Regards,
    JPG

  3. #3
    That looks like an issue with Token Height Extension
    https://www.fantasygrounds.com/forum...dicator/page17
    bmos' extensions
    he/him | Discord Tag: wil.thieme#3396

  4. #4
    GKEnialb's Avatar
    Join Date
    Jul 2017
    Location
    Castle Rock, CO
    Posts
    288
    That does look like it may be coming from Token Height Extension. The really odd thing is that I don't override getGridSize (even though I am overriding image.lua), so not sure why it would disappear in the middle of a session, especially as the map isn't being changed (in the example that bmos linked to). In the meantime, I put in a semi-workaround where it tries to continue if it fails to call getGridSize().

    kevininrussia, if you can list your other extensions and your rulesset, I'll try to dig deeper.

  5. #5
    Quote Originally Posted by GKEnialb View Post
    That does look like it may be coming from Token Height Extension. The really odd thing is that I don't override getGridSize (even though I am overriding image.lua), so not sure why it would disappear in the middle of a session, especially as the map isn't being changed (in the example that bmos linked to). In the meantime, I put in a semi-workaround where it tries to continue if it fails to call getGridSize().

    kevininrussia, if you can list your other extensions and your rulesset, I'll try to dig deeper.
    I should have closed this tread as the issue went away with a later version of Token Height.

  6. #6
    Is this problem still active as I was getting a similar issue last night testing my campaigns and performance.

    General performance tweaks and \VSYNC & \IMAGEQUALITY looks to have solved performance issues on older kit.

    This HEIGHT extn was unloaded to remove the issue with error throwing in console screen.

  7. #7
    GKEnialb's Avatar
    Join Date
    Jul 2017
    Location
    Castle Rock, CO
    Posts
    288
    It *should* be impossible to get this error now with v3.4, as I check that getGridSize exists before I call it. The two people who reported it earlier haven't been able to recreate. It's hard to speak for what can be occurring in the test channel, though.

  8. #8
    GKEnialb's Avatar
    Join Date
    Jul 2017
    Location
    Castle Rock, CO
    Posts
    288
    If the recent set of errors had to do with nSpace, v3.5 has fixed that (a recent update got confused with tokens that weren't on the combat tracker).

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
FG Spreadshirt Swag

Log in

Log in