DMsGuild
Page 1 of 5 123 ... Last
  1. #1

    Testing Update: Lighting still causing performance issues

    My group has been patiently testing Lighting features with me during our weekly Curse of Strahd campaign and during our most recent session, despite improvements, we were forced to turn off dynamic lighting due to performance issues again. My group got into an effect, lighting, and NPC dense encounter, and the whole client slowed down to the point of unplayability until I turned Lighting off.

    The map:
    Castle Ravenloft (07 - 10) - Spires and Tower Peaks (Players Map) from the third party map pack "Castle Ravenloft Player Maps" from DMsGuild with custom LoS and Lighting definitions

    With:
    Mist FX layer on
    Dynamic Lighting on for all lights on the map (they are probably off in the state of the campaign I will share, turn them on to replicate the environment of the issue)
    Ambient Lighting on, masking used to remove light from interior locations.
    Combat Tracker at one point included the Party, several friendly NPC's, Strahd, all 10 animated swords from the map encounter, and two additional vampire spawn

    System:
    v4.1.0 ULTIMATE (2021-04-13)
    D&D 5E
    Windows 10- 16 Gb RAM
    Ryzen 5 1600 processor
    Nvidia GTX 1070 - 8 Gb dedicated RAM
    2560 x 1440 Resolution

    I am prepared to send a zipped copy of the campaign (and logs) to support if needed, just let me know. According to my recollection and referencing the logs, the issues would have surfaced sometime after sharing the above mentioned map, so probably in the 10:49-11:05 window of the logs. If there are other files I should include let me know.
    Attached Files Attached Files
    Last edited by lavoiejh; April 19th, 2021 at 21:22. Reason: edit: Corrected Gfx card RAM value

  2. #2
    Zacchaeus's Avatar
    Join Date
    Dec 2014
    Location
    Scotland
    Posts
    16,826
    How big is the map?
    If you need to contact customer support or if there is something that you would like to see in Fantasy Grounds that isn't currently part of the software or if there is something you think would improve a ruleset then add your idea here http://fgapp.idea.informer.com/

  3. #3

  4. #4
    Not wanting to 'advertise' my thread, but this is probably partially due to the high GPU load:

    https://www.fantasygrounds.com/forum...-(Build-04-13)

    Nevertheless good findings and reporting.

    Some questions for clarification:
    - Did everyone have problems, you included?
    - Did those problems occur when the party enountered the NPCs or even before? This might give some hints to what exactly is driving the software/hardware to its knees.

  5. #5
    Can you please reference this thread, and send a copy of your campaign to [email protected]?

    Thanks,
    JPG

  6. #6
    @Zarestia - Yes, I do think this is a general GPU load issue, and not necessarily a memory leak or the like. I think that all of FGU is causing high load, and the lighting on top of everything else was too much for my (and my players) PC's.

    1) Yes, everyone had issues, including me.
    2) The problems became impossible to overlook once we added the 10 animated weapon NPC's. Whether that was because the whole thing was bogged down due to high GPU load which would have happened even without the NPC's or not, I don't know. All I know is I turned off the FX layer and the lighting, and the software was able to keep up again.

  7. #7
    @MoonWizard - Done.

    One other note, it looks like in my haste to stop the issue during play, I deleted the FX layer, rather than just turning it off. So to replicate my case just add the FX layer - Myst (speed low ~53) to the map I describe in my post, as well as the 10 Animated Halberds which were on the field during the combat but my players have now bested They were in the heart of sorrow (North West tower on the map, where the PC's currently are)

  8. #8
    Further playing with this issue. I wanted to see if the issue persisted with no players connected, so I recreated the scenario as described in my previous post.

    As I suspected, I don't see a huge load on my computer just having the map with effects and all tokens present on the map. GPU utilization hovers around 40%, GPU memory usage is 1.4 GB, temp is 67 degrees. Very stable. What I did notice in the resource monitor panel was that when I tried to move tokens on the map, there were many graphical hitches and slowdowns in the map image (freezing effect animation and the pulsing lights lag), and during this process the GPU utilization - rather than spiking as I would suspect - actually goes to zero. Very strange. It almost appears that the animations pause when tokens move, which could cause usage to go to 0%, but during long drags of tokens eventually they do stutter back to life.

    update: removing the 10 animated halberd NPC's does drop the utilization more than I would expect, by half down to 20%. Moving tokens in this reduced load situation still tanks GPU utilization to 0%.

    Attached Images Attached Images
    Last edited by lavoiejh; April 19th, 2021 at 21:45.

  9. #9
    Watch your CPU load when those GPU dips happen, you will likely see it increases to max out one of your CPU cores. This in turn leads to the GPU load drops, because FGU is not feeding new data to the GPU. This would then be a CPU bottleneck then, not a GPU one.

  10. #10
    Quote Originally Posted by Weissrolf View Post
    Watch your CPU load when those GPU dips happen, you will likely see it increases to max out one of your CPU cores. This in turn leads to the GPU load drops, because FGU is not feeding new data to the GPU. This would then be a CPU bottleneck then, not a GPU one.
    It does not. CPU usage is constant throughout.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
SWADE Playlist

Log in

Log in