Starfinder Playlist
  1. #1

    "xxx_class" and "xxx_frame" What the?

    {EDIT}
    Actually the naming conventions mentioned below work fine for my NPC sheet but not for my charactersheet. There must be something else about the charactersheet that is causing it to go screwy. Just can't see what it might be right now...
    {EDIT}


    Ok I have a fair idea what is going on here but still. Not nice guys

    I started using a naming convention of _class on the end of windowclass names and _frame on the end of frame names. All was working fine until I started creating windowlists.
    If I try to use a class called xxx_class in a windowlist it simply ignores it (the radial menu item to add an item to the list is not shown, nor are any pre-existing entries in the list)
    If all I do is change the _class to _clss it works.

    Additionally, if the class used for the entries has a frame that has _frame on the end of it's name the entries appear with no frame.

    i.e. This doesn't work
    Code:
    <windowlistname="mylist">
    <class>myclassentry_class</class>
    <datasource>.stuff</datasource>
    <allowcreate />
    <allowdelete />
    <bounds>10,80,235,32</bounds>
    </windowlist>
     
    -- with myclassentry_class defined as:
    <windowclassname="myclassentry_class">
    <frame>myclassentry_frame</frame>
    <datasource>.</datasource>
    <placement>
    <size>
    <width>235</width>
    <height>16</height>
    </size>
    </placement>
    <sheetdata>
    .
    .
    .
    


    but this does
    Code:
    <windowlistname="mylist">
    <class>myclassentry_clss</class>
    <datasource>.stuff</datasource>
    <allowcreate />
    <allowdelete />
    <bounds>10,80,235,32</bounds>
    </windowlist>
     
    -- with myclassentry_clss defined as:
    <windowclassname="myclassentry_clss">
    <frame>myclassentry_frme</frame>
    <datasource>.</datasource>
    <placement>
    <size>
    <width>235</width>
    <height>16</height>
    </size>
    </placement>
    <sheetdata>
    .
    .
    .
    



    Any advice from the devs on naming conventions?
    Would myClassEntryClass be ok?
    or should we try to avoid using any reserved words anywhere in names for classes/frames/controls/templates/etc ?
    Last edited by Toadwart; June 21st, 2007 at 07:17.
    Work Less, Game More!

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Fantasy Grounds Merchandise

Log in

Log in