Fantasy Grounds Fridays Pre
  1. #1

    Module creation headaches - Savage Worlds

    Hi all,

    I'm a FG noob. I'm using FGC and the Savage Worlds ruleset and I'm trying to create a module for the setting "Ultima Forsan", but I'm having problems.

    I was following Dave's tutorial vids, which seemed to work well, but I kept losing stuff from one night to the next (e.g. random Edges and Skills I'd added would be gone the next time I logged in, but others would be there), so I tried a different method, and this is the problem I'd like help with.

    I followed Eric Lamoureaux's video on using the Enhanced Library and thought I'd try that...

    Building the content seemed fine. I added Edges, Skills, Races, Weapons, etc. But when I came to export it I got an error message...

    ...and the new content (Edges, etc.) isn't showing up in the FG desktop areas on the right of screen.

    I tried creating an empty SW campaign and choosing my Ultima module, but still no content appearing in FG.

    In the process of all this, I lost the Module I'd created, so I've been working with a placeholder one since (hence the mostly-empty status in the screenshots)

    I'm loathed to go back and start AGAIN using the WYSIWYG method, but at least that seemed to mostly work.

    Any thoughts FG community?


  2. #2
    The error in your picture points to an issue with an extension; as that script file does not exist in the Savage Worlds nor CoreRPG rulesets. Any error reported during an export will potentially be a failure point, regardless of whether you think you are using features of that extension. I would recommend turning off all extensions, and trying the default export as defined in the wiki.

    If you choose to use a community extension or other community tool, and it doesn't work for you; you will need to reach out to the community extension/tool developer to work through any issues. We do not have any knowledge of their extensions/tools to help.

    Also, I would suggest that you start by creating a very small example of what you want, and use the built-in export or any export extensions/tools. Then, you can verify that the output is what you expect with a minimal amount of work.


  3. #3
    Thanks JPG.

    I've already tried turning off all extensions in the 'Load Campaign' window. Didn't make any difference, as far as I could see

  4. #4

    Join Date
    May 2016
    Jacksonville, FL
    Blog Entries
    The screenshots haven't been approved yet so I can't see them or what the error is, but if you're using SWEL it has its own export functions totally separate from the normal FG export (which I don't think has any awareness of SWEL-created content anyway).

    Once your have your content ready to export, click the 'new' (only appears when you have SWEL loaded) brown edit button, then you'll see two new icons appear for each 'book' the blue down arrow icon is the SWEL export.
    Attached Images Attached Images

  5. #5
    Thanks Talyn. The SWEL export function was the one I was using that was generating the error. If I use the /export command, I don't get the error, but the module doesn't export properly anyway (it's empty).

    JPG mentioned it might be an extension issue/clash. Here are the extensions present in the FG AppData folder -
    SW Charsheet Contacts_v1.5
    SW Defeated Markers Addon Samapler_v0.2
    SW Enhanced Library_v1.51
    SW Fear Penalties_v1.3
    SW Greyscale Lite Theme_v1.2

    Do any of them look amiss? Should I clear out the folder apart from the themes and SWEL?

  6. #6
    BTW in case you can't see the screengrabs, the error I'm still getting when I try to export through SWEL is

    "Script Error: [string "scripts/new_library_module_export.lua"]:548: export: Invalid parameters"

  7. #7

    Join Date
    May 2016
    Jacksonville, FL
    Blog Entries
    Extensions 'present' don't matter, it's the extensions you actually load at the time which can cause problems with each other. I don't use any of those other SW_* extension so I can't comment there. Other than 'make sure you're using the latest SWEL' and 'don't use SWEL in Unity' I'd need to see the markdown that's causing the problem to troubleshoot any further.

  8. #8
    What do you mean by "markdown", Talyn?

  9. #9

    Join Date
    May 2016
    Jacksonville, FL
    Blog Entries
    The SWEL source 'code' is markdown. SWEL converts that into XML which is markup. Totally not confusing!

  10. #10
    Thanks Talyn. I eventually gave up on my failing module, as I couldn't ascertain what had been lost and what hadn't. So I started again from scratch.

    I've been following the WYSIWYG mode in a fresh 'campaign', and saving out with the /export command. This seems to be working. I'm then running the adventure through another new campaign and just loading in the saved Ultima Forsan module. Seems to be working okay.

    Now I'm wrestling with elements that contradict core Savage Worlds elements, such as new Arcane Backgrounds and managing multiple hit location armour values (no I don't have 3 armour, I have three locations at 1 armour!). But that's a conversation for another thread...

    Thanks all for the help.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
Starfinder Playlist

Log in

Log in