PF2E Playlist
Page 1 of 3 123 Last
  1. #1

    Administrator permission issues

    2 out of 4 of my players are ha having the following issue after installing FGU (demo version) and running the updater:

    A window pops out with a "do not have write access to Either the application or data directory" message .

    Neither cancelling or "fix permissions button " resolve the issue.

    They both are logged in their personal computers as administrators.

    I couldn't find in the forums how to solve it.

    Any help to non computers experts would be appreciated.

  2. #2
    That message appears if the updater tries to write to the application/data directory; and is blocked by the OS.

    Either something on their machines has modified access to those folders; or the initial permission creation failed in the installer. If FGU is installed to a different directory than the default, then the user is more likely to have issues. (such as security software rewriting permissions)

    Can those users try uninstalling and reinstalling to default directories? If that doesn't work, we may need to get log files.

    The default directories are:
    App Directory - C:\Program Files\SmiteWorks\Fantasy Grounds\
    Data Directory - C:\Users\[UserName]\AppData\Roaming\SmiteWorks\Fantasy Grounds\

    Regards,
    JPG

  3. #3
    Just had this issue with 6 different people. 1 was on Windows 7 and the other 5 were on Windows 10 Single Language Edition. For some reason, the permissions on SLE Windows are weird, so I had to guide them on how to manually set the permissions for the folders, even FGU's default ones. I believe that the Fix Permissions option on FGU doesn't account for different languages OSs (you being from Mexico basically confirmed this) and SLE's permissions being weird. Anyway, a basic tutorial on how to manually fix this. WARNING: Follow this EXACTLY as written and please be advised that messing with folder permissions can lead to major OS crashes.

    1)Go to the installation folder and right click on it.
    2)Click on Properties.
    3)Go to the Security tab
    4)Click on Edit (a new window appears)
    5)Click on Add (a wild new window appears)
    6)Click on Advanced (hey! another window!)
    7)Click on Search Now (or something similar, running Portuguese version here)
    8)A bunch of names should appear on the bottom of this window.
    9)Double-click on the name that has your username on it (login name, email account, whatever is your login method on windows).
    10)It should return to the previous window. In there, click OK.
    11)It should return to the previous window. In there select the newly added user and on the permissions bellow (which should already be selected, but double-check it), click on the Permit Full Control checkbox. Hit Apply and then OK.
    12)Click OK on any other windows and repeat the process for the Data directory.
    13)Reinstall or Re-update FGU (carefully confirming that the folders you just worked through are the ones in the installation and setup menus)
    14)???
    15)Profit!

    That's it, basically. The process should be the same for Windows 10, 8 and 7. Of all the people I walked through this (6), 5 got it working, but one didn't follow EXACTLY through and deleted his HDD access to EVERY user, rendering his system unusable. So, be cautious!

    Anyway, since this was verifiable and could be reproduced every way, I believe the devs should do a proper testing to see if I am not exactly full of s**t on this. Maybe what causes this is not exactly what I described, but something very akin to it.

    Good luck!!

  4. #4
    So far, 100% of the permissions issues I have dealt with have been caused by third-party anti-virus software. During installation, the installer gives the built-in Users group write permissions to the installation directory. Some anti-virus software, F-Secure and Kaspersky to name a couple, remove those permissions. When the updater starts up, and each time it tries to write files to the application directory, it checks for write permissions and if it fails, it prompts with the Fix Permissions screen. Hitting the Fix Permissions button gives the builtin group write permissions to the directory again and sometimes that resolves the issue, but many times the anti-virus software removes them again. In those cases, two things need to happen in the following order:
    1. Add an exception to the anti-virus software for the installation directory, (typically c:\Program Files\SmiteWorks\Fantasy Grounds)
    2. Either manually add the permissions or run the installer again.

    I don't have any personal experience with Single Language Edition, but I would be very surprised if that edition didn't have a builtin Users group.

  5. #5
    LordEntrails's Avatar
    Join Date
    May 2015
    Location
    -7 UTC
    Posts
    12,463
    Blog Entries
    9
    Quote Originally Posted by rgtschope View Post
    Just had this issue with 6 different people. 1 was on Windows 7 and the other 5 were on Windows 10 Single Language Edition. For some reason, the permissions on SLE Windows are weird, so I had to guide them on how to manually set the permissions for the folders, even FGU's default ones. I believe that the Fix Permissions option on FGU doesn't account for different languages
    Note, FGU is not supported on Windows 7.

  6. #6
    Quote Originally Posted by smelton View Post
    So far, 100% of the permissions issues I have dealt with have been caused by third-party anti-virus software. ... I don't have any personal experience with Single Language Edition, but I would be very surprised if that edition didn't have a builtin Users group.
    Everyone had either their AVs disabled or used default Windows Defender. It had a Users group, but the main user wasn't authorized to make any modifications. Even though we updated the USERS group permissions it still didn't work, it only worked when we added the main user name in the permissions.

    Quote Originally Posted by LordEntrails View Post
    Note, FGU is not supported on Windows 7.
    Yes, we told this guy about that, it was the only case where it didn't work and he ended up watching a stream of someone else's screen on Discord.

  7. #7
    Ah, i ran into that problem now. Had to reinstall Windows 10, same PC, nothing changed. Upon installing FG Unity i get the permissions error, even though every user on PC has full rights, i started as administrator and i used the default folders for installation. Ideas? It used to work flawlessly on the same PC, that what puzzles me.

    Edit: When starting the installation anew, after cleaning up every reg entry and other trace, the installation wants to install the runtime libraries. Every runtime library is already installed. When continuing anyway i get stuck in the permissions loop.
    Last edited by new_vision; October 9th, 2020 at 17:55.

  8. #8
    This really sucks! I just upgraded from my FGC Ultimate and purchased FGU, then this update **** issue pops up. The whole morning I'm scrying through forums, trying out every proposed step -> FGU says "**** YOU, I AIN'T UPDATE!"

    Please Smiteworks, do something to get this **** fixed. Its NOT on the users to change permission **** where every software else is just working.

    Get your **** done!

  9. #9
    To be fair - when following the step by step instruction rktschope and manually adding me as user with all rights it works.

    BUT:
    as I am the only user and admin on my PC I SHOULDN'T be required to adjust user rights for an installation. I thought about moving my FGC game to FGU, but if everyone or even some of my users will encounter this problem, it is not worth it.

    And yes, according to theog file, the software doesn't have permission to write on the standard folder paths. But that is an issue that should not happen at all on a completely newly set up Windows system.

  10. #10
    Interesting thing - i tried installing it on my laptop (on which i used only FGC so far), i received the same runtime library error (of course, as the version included in the installer is older than the MS one), but it got installed flawlessly, despite the error. Normal logging in and updater workds and does what he is supposed to do. I have the same user name on both PCs (as i log in with my MS account), so it can't be user name dependent. And i have the same setup when it comes to security.

    Any ideas?

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Starfinder Playlist

Log in

Log in