FG Spreadshirt Swag
Page 1 of 2 12 Last
  1. #1

    Stuck on loading screen?

    Hey guys. I'm trying out Unity for the first time.
    Everything seems to be starting correctly, but when I try and load a game I get hung up on the loading screen with the Fantasy Grounds logo.
    Nothing in my log seems to be showing an error. Any idea how to fix this?

    Here is the console log:
    [9/20/2020 10:13:03 AM] FGU: v4.0.0 ULTIMATE (2020-09-03)
    [9/20/2020 10:13:03 AM] OS: Windows 10 (10.0.0) 64bit
    [9/20/2020 10:13:03 AM] GRAPHICS: NVIDIA GeForce GTX 660 : 1435
    [9/20/2020 10:13:03 AM] USER: DMJazzyJeff
    [9/20/2020 10:13:03 AM] Launcher scene starting.
    [9/20/2020 10:13:35 AM] Starting cloud server mode. [DMJazzyJeff]
    [9/20/2020 10:13:36 AM] Game server started. [161.35.236.97:61487]
    [9/20/2020 10:13:36 AM] Launcher scene exiting.
    [9/20/2020 10:13:36 AM] Tabletop scene starting.
    [9/20/2020 10:13:36 AM] NETWORK STATUS: [Server] [Connected]
    [Server Type - CLOUD - PRIVATE]
    [9/20/2020 10:13:36 AM] Match successfully created on lobby.

    I should clarify, I've reinstalled Fantasy Grounds, restarted the computer. And it doesn't matter if I make the match public, private, or local. It does the same thing
    Last edited by DMJazzyJeff; September 20th, 2020 at 18:33. Reason: clarification

  2. #2
    Can you provide the full set of logs using the Compile Logs button from the console that you can open from the button in upper left?

    Thanks,
    JPG

  3. #3
    You bet!
    I uploaded the zip file. Is that what you needed?

    Thank you
    Attached Files Attached Files

  4. #4
    It looks like one of the libraries didn't install; or was uninstalled. Can you go to the Microsoft URL below, and download/install vc_redist.x64.exe?
    https://support.microsoft.com/en-us/...al-c-downloads

    This will fix the missing library error that's stopping it from loading.

    Regards,
    JPG

  5. #5
    You are my hero

    Thank you so much. That did it for me

  6. #6
    Hey guys!
    Just found this thread. The same with me. Keep stuck on loading with the map and the FG logo.
    Here is the Compile Logs.

    Thanks, in advance.
    Attached Files Attached Files

  7. #7
    LordEntrails's Avatar
    Join Date
    May 2015
    Location
    -7 UTC
    Posts
    12,351
    Blog Entries
    9
    Hey contadodm, have you tried installing the library linked in Post #4?

    I think that's in the resolution for the error I see in your player.log file

    Code:
    Fallback handler could not load library C:/Program Files/SmiteWorks/Fantasy Grounds Unity/FantasyGrounds_Data/Mono/lua5.1
    Fallback handler could not load library C:/Program Files/SmiteWorks/Fantasy Grounds Unity/FantasyGrounds_Data/Mono/lua5.1.dll
    Fallback handler could not load library C:/Program Files/SmiteWorks/Fantasy Grounds Unity/FantasyGrounds_Data/Mono/lua5.1
    Fallback handler could not load library C:/Program Files/SmiteWorks/Fantasy Grounds Unity/FantasyGrounds_Data/Mono/liblua5.1
    Fallback handler could not load library C:/Program Files/SmiteWorks/Fantasy Grounds Unity/FantasyGrounds_Data/Mono/liblua5.1.dll
    Fallback handler could not load library C:/Program Files/SmiteWorks/Fantasy Grounds Unity/FantasyGrounds_Data/Mono/liblua5.1
    Plugins: Failed to load 'C:/Program Files/SmiteWorks/Fantasy Grounds Unity/FantasyGrounds_Data/Plugins/lua5.1.dll' because one or more of its dependencies could not be loaded.

  8. #8
    Thank you LordEntrails!

    But still on the map FG logo screen... Don't know what to do

  9. #9
    LordEntrails's Avatar
    Join Date
    May 2015
    Location
    -7 UTC
    Posts
    12,351
    Blog Entries
    9
    Quote Originally Posted by contadodm View Post
    Thank you LordEntrails!

    But still on the map FG logo screen... Don't know what to do
    Bummer. Hopefully someone else will be able to advise. Perhaps Moon or one of the devs themselves. If you don't here in a timely manner, you can of course reach out directly to [email protected] and link to your log files here.

  10. #10
    @contadodm,

    Did you follow the directions in post #4 that fixed the issue for the original poster, and re-install the 64-bit version of the redistributable files?
    https://www.fantasygrounds.com/forum...l=1#post543583

    Thanks,
    JPG

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Joshua Stream Pre

Log in

Log in