Starfinder Playlist
  1. #1

    Copy paste, select all... Formatting macros not always working in FGU anymore

    I have put a bunch of keyboard shortcuts like CTRL-C, V, A, J and the like on mouse keys as macros. I use them for formatting text in FGU. It just saves me time as I don't have to move my hand from the mouse. This worked fine up till a few weeks ago.

    Now when I try to copy or paste or whichever the first few times I press the key, it won't work. If I continue to press it multiple times it will eventually work, but I may get multiple inputs. (Multiple pastes etc). Initially I thought maybe to was a key press delay issue, so I increased the delay and also tried removing any delay. Neither made a difference. I thought maybe it was a mouse issue (Swiftpoint) so I tried the macro keys on my Keyboard (Logitech G500) which shows the same behavior.

    These macros worked fine a few weeks ago, unfortunately I'm not sure which version it changed in. They also work fine in any other program, just not FGU. So I suspect something changed, but have no clue what. It appears as if something is registering as the hot key bar changes, I assume with the ctrl key presses, when I use the macro. Key press combos work fine in FGU, CTRL-C etc.

  2. #2
    We had to change the key entry routines we used in Unity engine a few weeks ago to address issues with key drops during fast key entry, as well as supporting non-US keyboards. I would guess that it coincided with that change.

    I'm not sure why the macro fails. Is there a different macro option for key down vs. key up? (i.e. Control key down -> C -> Control key up)

    Regards,
    JPG

  3. #3
    Thanks for the reply Moon Wizard. So I did some more testing. It seems to be working now if I insert a 0.5 second delay in the macro. Which seems kind of long, but it's working for now. Also works in the keyboard software.

    Edit: Well it works in FGU, however in any other windows program it doubles up the pastes
    Edit 2: Spoke too soon it's doubling up in FGU as well. Seems <0.5 second is not long enough and 0.5 second is too long as well.
    Last edited by Jaybob32; August 13th, 2020 at 03:24.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
PF2E Playlist

Log in

Log in