Joshua Stream Pre
Page 1 of 2 12 Last
  1. #1

    Unable to Extract Files and 5E Error: References Missing Child Ruleset (CoreRPG)

    Two issues pertaining to accessing modules and program execution:

    1. I recently purchased the Dungeon Master's Guide, Player's Handbook, and the Lost Mine of Phandelver (order ID 267839 on 29JUL20) and am unable to load these into the modules page of either FantasyGrounds Classic or Unity. I receive error messages (see the message text below) when I go to update my software. I recently requested a change of user name by contacting the support desk at [email protected] and since then, these purchases don't seem to work. Is there something I'm doing incorrectly?

    2. I've downloaded the FantasyGrounds Classic program in order to participate in the FantasyGroundsCollege events but am unable to load a campaign, join a game or manage characters. When I click on these, I receive an error stating that I am "references missing child ruleset (Core RPG)." (Exact text from error below).

    I have tried deleting the CoreRPG file and the 5E ruleset from the ruleset folder inside the appdata folder and then reloading it via the upload tool but this has not fixed the issue. I have also uninstalled and reinstalled the program twice, clearing my username and password along with the purchased product key, with no change.

    Upon advisement from the support technician, I was advised to post these issues here if we were unable to solve the problem. Is there something else I can do to access this game?

    (a) - SavetoVault - Unable to extract file (modules/DD Lost Mine of Phandelver.mod) for product (WOTC5ELMOP)
    (b) - SavetoVault - Unable to extract file (modules/DD Dungeon Masters Guide.mod) for product (WOTC5EDMG)

    (c) - Ruleset: 5E Error: References missing child ruleset (CoreRPG) Do you want to try reloading data?

  2. #2
    LordEntrails's Avatar
    Join Date
    May 2015
    Location
    -7 UTC
    Posts
    12,452
    Blog Entries
    9
    Can you post a screen shot or your ruleset folder with details shown? That way we can make sure your ruleset files are the correct size.

    I assume you updated your account info in the settings?

  3. #3
    damned's Avatar
    Join Date
    Mar 2011
    Location
    Australia
    Posts
    22,166
    Blog Entries
    1
    For C you want to delete the 2 files - corerpg.pak and 5e.pak and re-run the updater
    For A and B it sounds like either you havent got your license or your forum login details loaded correctly in settings.
    After you fix that re-run the updater.

    Did you install to a custom folder path?

    MoreCore - Generic Ruleset
    --- Projects ---
    Extensions | Tutorials | MoreCore | MoreCore Themes | Call of Cthulhu | Maelstrom | FG Con

  4. #4
    Trenloe's Avatar
    Join Date
    May 2011
    Location
    Isle of Wight, UK (for a bit)
    Posts
    27,559
    As mentioned by @damned - you should re-enter your FG username and password in the FG settings and re-run an update. See information from steps 4 here: https://www.fantasygrounds.com/wiki/...Setup_Tutorial
    FG Con 16 Fantasy Grounds Online RPG Convention - Postponed New date To Be Confirmed.
    Register at www.fg-con.com for all the latest info.

    Private Messages: My inbox is forever filling up with PMs. Please don't send me PMs unless they are actually private/personal messages. General FG questions should be asked in the forums - don't be afraid, the FG community don't bite and you're giving everyone the chance to respond and learn!

  5. #5
    Hello All,

    Thank you for your suggestions. Yes, I updated my username and password on the setting page before the updates, I even confirmed the license key with tech support who emailed me the license numbers again to verify. As for the rulset folder, I deleted both the E5.pak and the CoreRPG.pak and re-ran the updater. No change. I have attached a image here of my ruleset folder along with a screenshot of the uploader log.

    One other piece of information that may be helpful. I was able to log in / access all my purchased content a few days ago prior to asking the admin to change my user name. I'm a new player and when I first created my FG account, I used my real name. A buddy told me it was better to have a handle, so I emailed support and they changed my username. That said, they wrote that they "linked my subscriptions with my account." Not sure if that matters.

    Update log.PNG

    Ruleset Folder.PNG

  6. #6
    One last note, no, I did not save anything to a custome file path. Everything I've downloaded has gone to the original folders created upon installation.

    I appreciate all the responses, thanks for the help!

  7. #7
    Zacchaeus's Avatar
    Join Date
    Dec 2014
    Location
    Scotland
    Posts
    14,774
    Try going into your vault folder (also in the data folder) and delete the files WOTC5ELMOP.dat and WOTC5EDMG.dat files and then update again. It looks like FG is linked up to your account ok but the network timeouts suggest that you may have something on your computer or router that is interfering with the downloads. Maybe check that you have a rule in yout antivirus and check your router for anything like flood protection or parental controls.
    If there is something that you would like to see in Fantasy Grounds that isn't currently part of the software or if there is something you think would improve a ruleset then add your idea to the wish list http://fg2app.idea.informer.com/

  8. #8
    I've added FG, FG Updater and FG Updater Engine to my anti-virus exception list and am looking into the router for flood protection (no parental controls have been activated). As for the WOTC5ELMOP.dat file and the WOTC5EDMG.dat file, I have neither of those in the vault file folder. See attached screenshot.

    Vault Files.PNG

  9. #9
    Update - after adding the programs to my anti-virus software exception list, it seems like the downloads have been successful. I am no longer receiving the error message "SavetoVault - Unable to extract file (modules/DD Dungeon Masters Guide.mod) for product (WOTC5EDMG)." That said, when I go to the home page of FG and try to create a character through the Manage Character button, I receive a new error message (a). Additionally, I have lost the E5 ruleset from the selection list (b) and receive the "Missing child ruleset" error (c) when I attempt to create a character using one of the available rulesets.

    I will re-try unintsalling and reinstalling the program again.

    (a) - Unable to load ruleset file.PNG
    (b) - Available Rulesets.PNG
    (c) - Missing Child Ruleset.PNG

  10. #10
    Update 2 - Reinstalling the program made the E5 Ruleset reappear, but I am still receiving the "missing child ruleset" error and am unable the access anything.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
5E Product Walkthrough Playlist

Log in

Log in