Fantasy Grounds Fridays Pre
Page 2 of 7 First 1234 ... Last
  1. #11
    Quote Originally Posted by vaughnlannister View Post
    Hi, though your extension is working fine it does seem to hamper performance of the combat tracker a bit, making it a little laggy. Could you maybe investigate if you're also seeing this issue in FGU, with your extension?
    There should be nothing going on except a button override which should only deal with inventory carried item. I just played a huge game (via LAN because Cloud connections are bugged for some of my players and we have had lag going through cloud) where combat tracker had a LARGE number of things with this extension in play and noticed no lag.

    Test for you would be disable extension - and try the same things your doing. I don't know what could possibly effect combat tracker as nothing should be in there from my code.

  2. #12
    Ok, that is reassuring, probably was because I loaded to many modules and extensions we didn't need through play today that was causing it. I do see a small speed bump after disabling your extension when opening the combat tracker, but this speed bump is negligible. I will investigate a bit more, with a few players next Monday. Thanks again for bringing out some cool extensions !

  3. #13
    Quote Originally Posted by vaughnlannister View Post
    Ok, that is reassuring, probably was because I loaded to many modules and extensions we didn't need through play today that was causing it. I do see a small speed bump after disabling your extension when opening the combat tracker, but this speed bump is negligible. I will investigate a bit more, with a few players next Monday. Thanks again for bringing out some cool extensions !
    Well if you find something let me know - I only run with the three extensions - in signature.

  4. #14
    damned's Avatar
    Join Date
    Mar 2011
    Location
    Australia
    Posts
    23,212
    Blog Entries
    1
    There should be a reason you run each extension. Do not just load up all the extensions that sound cool.

    MoreCore - Generic Ruleset
    --- Projects ---
    Extensions | Tutorials | MoreCore | MoreCore Themes | Call of Cthulhu | Maelstrom | FG Con

  5. #15
    It just ran so well in our last game with a bare minimum setup. I may have pushed it a bit to far though with the extra loaded mods and extensions, albeit I was also running zoom which also chunks up precious cpu on my laptop. Turning back the clock to bare minimum set up for our next session , to see if it makes a difference, I'd rather run with less extensions, mods and zoom. Without any lag then with lag.
    Last edited by vaughnlannister; July 5th, 2020 at 12:39.

  6. #16
    LordEntrails's Avatar
    Join Date
    May 2015
    Location
    -7 UTC
    Posts
    13,476
    Blog Entries
    9
    EDIT: not applicable
    Last edited by LordEntrails; July 6th, 2020 at 18:12.

  7. #17
    I've just installed the extension, and am using it in a Starfinder campaign. No other extensions loaded. I can apply the effect to the item, and when I equip the item, I see the effect in the CT. But when I unequip the item, the effect does not leave the CT. Am I doing something wrong?

  8. #18
    Quote Originally Posted by Curuthanir View Post
    I've just installed the extension, and am using it in a Starfinder campaign. No other extensions loaded. I can apply the effect to the item, and when I equip the item, I see the effect in the CT. But when I unequip the item, the effect does not leave the CT. Am I doing something wrong?
    Which rule set is starfinder?

    If its one of the ones I listed then Ill have to test it out tomorrow.

    For sure the effect should be expired when you unequip it. Is there an error in console log?

  9. #19
    Quote Originally Posted by Curuthanir View Post
    I've just installed the extension, and am using it in a Starfinder campaign. No other extensions loaded. I can apply the effect to the item, and when I equip the item, I see the effect in the CT. But when I unequip the item, the effect does not leave the CT. Am I doing something wrong?
    Alright, I just got into my test project for SFRPG which is starfinder and all the tests I made previously appeared to work. As you stated, I also only have this extension and nothing else running. I basically create a new campaign with SFRPG ruleset and this one extension under Fantasy Grounds Unity. I then create a basic dummy character who has almost no data and drop him in combat tracker, then create a cursed test item (the ring you see in video) and a regular item (the cloak of protection you see in video) and run through the test. I drop both items in the dummy characters inventory - then cycle through the 3 states of equipped status and watch my effects in combat tracker change for the host. I then attach myself as a test player and do the same tests - as in the video the player side will lock up and be unable to move out of the equipped status for the cursed item but the host can cycle it out just fine. As in the previous test the CT tracker shows the effects removed.

    The console log shows nothing going on - which is good.

    I'm not sure what the problem is your seeing as I've had nothing previously wrong reported on this extension - nor do I have any problems myself but I play exculsively with 5E ruleset. That does not mean I don't believe you are seeing something weird going on. Just need more data to figure out what it is.

    1) Does your \console log show any errors popping up when the DB.addHandler("charsheet.*.inventorylist.*.carried ", "onUpdate", onCarriedChanged) trigger (only performed on host side even when player triggers the change) onCarriedChanged() code does the EffectManager.removeEffect(rActorCT, sCarriedItem)? Probably much to much information but that is what is literally doing the removal of the effect.

    2) This is Fantasy Grounds Unity your running right? Not classic? All my extensions have only been designed with Unity as I don't own classic. So no guarantees when it comes to running in there per the DMsG text description and in here.

    So I'm willing to help figure out your issue - but I have no idea what it is at that moment based on the data I have.

  10. #20
    Quote Originally Posted by SilentRuin View Post
    Alright, I just got into my test project for SFRPG which is starfinder and all the tests I made previously appeared to work. As you stated, I also only have this extension and nothing else running. I basically create a new campaign with SFRPG ruleset and this one extension under Fantasy Grounds Unity. I then create a basic dummy character who has almost no data and drop him in combat tracker, then create a cursed test item (the ring you see in video) and a regular item (the cloak of protection you see in video) and run through the test. I drop both items in the dummy characters inventory - then cycle through the 3 states of equipped status and watch my effects in combat tracker change for the host. I then attach myself as a test player and do the same tests - as in the video the player side will lock up and be unable to move out of the equipped status for the cursed item but the host can cycle it out just fine. As in the previous test the CT tracker shows the effects removed.

    The console log shows nothing going on - which is good.

    I'm not sure what the problem is your seeing as I've had nothing previously wrong reported on this extension - nor do I have any problems myself but I play exculsively with 5E ruleset. That does not mean I don't believe you are seeing something weird going on. Just need more data to figure out what it is.

    1) Does your \console log show any errors popping up when the DB.addHandler("charsheet.*.inventorylist.*.carried ", "onUpdate", onCarriedChanged) trigger (only performed on host side even when player triggers the change) onCarriedChanged() code does the EffectManager.removeEffect(rActorCT, sCarriedItem)? Probably much to much information but that is what is literally doing the removal of the effect.

    2) This is Fantasy Grounds Unity your running right? Not classic? All my extensions have only been designed with Unity as I don't own classic. So no guarantees when it comes to running in there per the DMsG text description and in here.

    So I'm willing to help figure out your issue - but I have no idea what it is at that moment based on the data I have.
    I appreciate you looking at it. So more details about my setup, I'm using Fantasy Grounds Unity, with no other extensions loaded. Running SFRPG ruleset with the official core rules book and modules loaded. I am using a copy of an existing campaign, so that if I mess something up my players will not be affected in our weekly game.

    I've added a suit of armor, that has a resist effect. (I made sure to copy the exact name from the item to the effect.) When I equip the armor, the effect appears on CT. When I unequip the armor, the effect remains in CT. No error message in console log. I've attached a screen shot. (Maybe you'll see something that I'm doing wrong.)

    I'll try creating a new test campaign, and using the extension in that.
    Attached Images Attached Images

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
FG Spreadshirt Swag

Log in

Log in