Page 1 of 2 12 Last
  1. #1

    Join Date
    Jun 2006
    Location
    West Coast
    Posts
    30

    Token Box Causes Program Crash

    Greetings,
    My husband and I just downloaded FGII after not having done much with FG for many months. I moved our collection of tokens out from storage and put them into the appropriate shared tokens folder in application data so that my husband connecting to me could get the tokens easily...in theory. Problem is...every time he connects to my game, it crashes the moment he attempts to even open the token box. Any ideas please? Thank you very much for your time.

    Wrose

  2. #2

    Join Date
    Mar 2006
    Location
    California
    Posts
    6,459
    This often means you may have a corrupted token or two. Try putting half the tokens in shared and then keep halfing until you find the culprit.

  3. #3
    It's best to keep large volumes of tokens in the host folder, that way people connecting to you don't get all the tokens you have. Transferring them doesn't help in any way except to spread tokens. Unless as a player he likes to throw a bunch of tokens onto the maps.

    If you are on the same network, I'd try to just copy them to his machine and put them into his host folder that way. Without using FG as the means.

    -D

  4. #4
    In case you manage to track this down to a violating individual token or similar, please let us know so it can be fixed.
    Tero Parvinen
    Fantasy Grounds Guru

  5. #5
    I'm having the same problem with FG2. It doesn't seem like the tokens are ever transfering no matter how many or how few there are.
    ~Lee S.

  6. #6
    Yes, it's from me that Lee is trying to get tokens, and I gotta tell ya, I am about ready to tear my hair out over this one.

    I spent most of today making a series of tokens. I have about 40 Player Tokens that I have placed in the Shared Folder, and I have approximately 250-300 tokens that make the range of monsters, status, and other tokens, that I have placed in the Host folder. Everyone is able to load up into the game session okay, but as soon as they click on the token box, they crash out. At first, one of my players was able to click on the box, and nothing happened. Of the three connecting tonight, he was the only one with a light license. However, after several attempts to adjust the folders and token files, he was no longer able to open the box without crashing, either.

    It was weird, too. I was able to take my status tokens (about 16 items), and drop them into the Shared folder, and I was able to access them thru my laptop connection. But if I took those same tokens, and added them to a folder named Status, clicking on the token box forced a crash. Please note that doing either of these in the Host folder resulted in a crash every time. As far as my monsters go, I had 3 seperate folders, each with about 70 tokens. Having them in the Host folder yielded a crash every time. Adding one folder to Shared resulted in crashing. Adding just the 70 tokens to Shared resulted in crashing. Leaving only one token in the Shared folder worked.

    I ultimately pulled all the files from the FGII folder in the Docs & Settings, uninstalled FGII, then reinstalled and updated. After re-adding tokens, then adjusting as before, every combination resulted in a crash.

    I'm at my wits end. I had a game tonite that I had hoped FGII would be a huge help in, but after over an hour of trying to fix the issue, we decided to just fall back on FG1 for tonight, and hope that there'd be a fix soon. If you need any further details from me, let me know.

    All issues aside, you guys have done an amazing job. I am incredibly impressed with the new product, and I am sure once the kinks are worked out, it will be awesome! Keep up the great work!

  7. #7
    On a related note, while playing in the game tonight, the DM (Andy) attempted to load a map from an imported module. I believe it was in a sub folder as well. All players recieved a 404, file not found error. I'm wondering if there is a relation between crashing token folders and missing map files?

    Later, I was able to fire up a game session and had Andy connect. I was able to share maps and images just fine.
    ~Lee S.

  8. #8
    Oberoten's Avatar
    Join Date
    May 2006
    Location
    Älvsbyn, Sweden
    Posts
    2,583
    Sounds like one or more of the tokens have become corrupt. Sadly the one way to find out which is to remove all of them. Start up, see if the program works without any of them present, then shut down, add a few until it crashes, then remove the ones added one at a time until you no longer get a crash.
    For your Ars Magica needs :
    https://fgrepository.com




    Atque in perpetuum frater, Ave atque vale.

  9. #9
    If this is indeed caused by a corrupt token, it will be hard to track down without having access to that token file. We can also take a look at your tokens if you can track it down to a bunch of them, zip them up and e-mail them to us.
    Tero Parvinen
    Fantasy Grounds Guru

  10. #10
    After I posted last night, I tried somethng else to see if it would help. I copied and pasted tokens that were used in original Fantasy Grounds into the folders in FG2, but the result was the same. These tokens have been used in FG1 almost since it's introduction to my game, and I have never had a problem. So I don't think it's an issue of the token files being corrupted. Keep in mind, as I posted earlier, some of the tokens worked once, and then when tried again, failed to work. Also, it wouldn't make sense that tokens, such as my status tokens, would work OUT of a folder, but not when put into a folder, and also work in Shared, but not in Host.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

Log in

Log in