FG Spreadshirt Swag
Page 2 of 2 First 12
  1. #11
    Quote Originally Posted by gamerhawaii View Post
    This has been my experience: if I use the base equipment type record (weapon, armor, etc.) and drag it onto the magic item, it creates the magic item fine. If I try to use the "magic item" version of the base equipment, then it does not work. The base item has the silver header, the magic item version has the yellow header. I do not know how to access the base version from the "Items" icon (as that seems to always treat the record as a magic item), I have to do it from the module directly. See image.

    Attachment 33189
    Thank you, this completely explains my issue. In one mod I have longsword is in the magic item format, and in another it's in the mundane item format. Only the one that's in the mundane item format works.

  2. #12
    Hm interesting. I don't have a silver version of the mentioned weapons. Did also load the PHB as a seperate Module but those are golden too. Meaning in the past it must have worked since i already created items.

  3. #13
    Terenor, if you used the 4E Item parser to create your modules then opening the items from the main "Items" tab does not show mundane items as mundane, you have to navigate to it through the library (per my previous post.) Only by navigating through the library and module can you get to the mundane (silver) record.


  4. #14
    Ah thank you good sir. That worked. Was it always that way? I hope i got all other books parsed with base weapon infos in them.

    Edit: just tested it with said Fey Strike Longsword +2. This weapon should do 2d6 extra on a crit. this doesn't seem to work. its in the description but not in the line with the numbers and doesn't add damage when rolling a crit.
    Last edited by Terenor; April 6th, 2020 at 21:27.

  5. #15
    Terenor, the magic item was created or else it would not say "Longsword" in the name but I see what you are saying. Now that I checked I am having an issue with any weapon even if I create it from scratch. When I drag to the character sheet the critical dice do not show up. Then even if I add them to the weapon on the character sheet, they still do not add on a crit. (However, once I add them manually, then the chat when I roll seems to know about the crit dice but does not roll them.) So I think the critical damage is a separate issue. And hopefully operator error. (I am usually DM and we hand-roll, so I never noticed the issue.) Maybe someone else can help.

    (Also, noticed if I drag them on the weapon on the character sheet a new XML tag called "criticaldice" is added.)

  6. #16
    By checking the code, I found that it is looking for the words "critical damage" instead of just "damage" (even though it is looking in the "<critical>" tag.) So just edit the damage listed on the critical field of the weapon to say "+2d6 critical damage" and then everything seems to work. And if it has a type put that immediately after the dice, e.g., "+2d6 fire critical damage"

  7. #17
    i tried as you described. Right now when a crit occurs i have to open the weapon, click on the crit damage. this applies an effect on the player. then when rolling damage the 2d6 are rolled. i have the impression that i either haven't implemented it right or it doesn't work as intended.

    ok figured it out. seems all weapons i created before were missing the crit extra damage. had to drop dice on the crit field then it worked. i thought this would be generated automaticly. thanks for all your help
    Last edited by Terenor; April 12th, 2020 at 07:19.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
Fantasy Grounds Fridays Pre

Log in

Log in