Page 2 of 2 First 12
  1. #11
    UPDATE (written after the stuff below):
    I removed my two softlinks in ruleset dir (to CoreRPG and 2E) and restored saved .pak files for 2E/Core.

    My pak files are a bit old. Core is from Jan 3rd and 2E is from Feb 7th.


    Steps:
    1. New Campaign, 2E
    2. Load PHB, DMG, MM
    3. Open NPC
    4. Selecte 3HD Ankheg, open sheet
    5. Open Items, scroll to Longsword +3, Frostbrand
    6. Drag Longsword to Ankheg sheet in the Inventory section.
    7. Drag Ankheg (3HD) to CT.

    I see in chat log that the effect of resist fire applied. Also see it in CT
    I click the sword "carried" shirt to bag or empty. No change in chat log or CT. I cycle and cycle, no change.

    Tried the above adding it with not equipped on sword and it does not add the effect. Then clicking to equip it on NPC Sheet does not effect the npc in CT.

    I spelled it all out in case I am NOT doing it in right way/order/steps?

    I'll try this on my main PC when get home. That one has NO lua coding on it. >>>> I do NOT doubt you Celestian <<<<< you showed me it works. So if you didn't recently fix it, it appears my environ is hosed and have to figure out why this is happening (probably: why it is not adding the required nodes under CT for item and only puts in effects.)



    ======

    OK - just tried the click on bag/shirt/blank thing.
    Nothing in console log, nothing in chat log and no changes in CT.

    Adding an npc (anklet) with the three items "equipped" does cause the chat log to print the adding of effect, the effects are in the CT and the log of "carried" callback triggers.

    I can only imagine, after seeing it live with you clicking that your db.xml has that CT....inventorylist...effects... etc path.
    Only thing I can think of then is that since you didn't say "oh yeah, I fixed that 3 months back" that it isn't I am running a behind the updates one (prob 1-3 months max) but it is that I somehow modified something when adding logging that I didn't mean to.

    I have the stuff in a local git every time I update from Smiteworks (after expanding the zipped files) so will see if that points out the problem.
    Definitely NO inventorylist appears for NEITHER char or npc in CT tree.

    Sorry, it seems this will be again my issue. Will update once I find what is changed. Ah, even easier than diffing - I will move the unzipped dir out of the folder so it uses the 2e.dat instead and while I won't hav the console trace logging, I can see it in chatlog and in the updated db.xml ct path.

    BRB with update on that first.
    Last edited by Varsuuk; February 24th, 2020 at 21:37.

  2. #12
    Have to help son, just got home - but short of it is:

    When testing on Character, opened sheet and equipped/unequipped. All clear.
    When doing NPC, opened NPC Sheet, dragged to CT - whatever was on NPC was registered effects-wise on CT. Good so far and a BIG CLUE...

    When changed an effect on NPC Sheet (note, the SOURCE of what dragged to CT, not the CT npc...) nothing happened. Celestian mentioned "just make sure you are equipping on npc ct entry not npc record..." so yeah, with his help it is solved now.

    I was clicking in wrong place. Verified works now as expected. Will continue working tonight if can stay awake after the game.

    Thanks again, Celestian.

    ==============
    EDIT: Update for any who were not aware of Celestian's CT optimization and are checking campaign xml files:

    If you edit an existing (module/ruleset) npc it marks it with the pencil icon to indicate it has been modified. If you drag this to the CT, it creates an entry and runs the on carried (if item with effect is carried) callback for the effects.

    However, no entry is made in CT for "inventorylist" which can fool you if you do a /save right after adding it. Instead, you need to first click on the npc in the CT to make it generate the inventorylist entry (and others - since Celestian has an optimization in CT to load lazily)

    The same goes for ones you copy first before adding to the CT.
    Last edited by Varsuuk; February 25th, 2020 at 02:34.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

Log in

Log in