Page 6 of 7 First ... 4567 Last
  1. #51
    Glad to see that some of the issues seem to have been resolved.

    Quote Originally Posted by radgh View Post
    Hi Ryan, I tried your installer in a new folder again. It did not open the updater immediately after install, not sure if that is a bug or intended. I ran "FantasyGroundsUpdater.exe" manually from the install path, and it opened the v4.0.0 version. I think this one is working, too, other than not automatically updating after install.
    The first part is still a bug. The updater *should* open immediately after install completes, but this is one I can't reproduce, so I've been trying things to see if they work so far.
    The only idea I have for even testing/getting more info on this is:
    1: Install to an empty folder
    2: If the updater doesn't open, check the install folder for FantasyGroundsUpdater.log

    This would at least tell me if at least the first program ran, and may contain clues to why the second/main FGUpdaterEngine didn't open.
    Or if the Log doesn't exist, it would tell me that the installer couldn't find the installed program on the post-install step.

    As to why it doesn't automatically start updating when you open the app:
    This is currently as intended. The updater only begins updating automatically when passed a specific argument. The installer doesn't pass this argument because generally the first time people install, they have to login and enter their keys.
    Last edited by redeyesofnight; February 18th, 2020 at 05:49.

  2. #52
    First time I tried to install. I got all the same symptoms that were reported pretty much throughout the thread. I was unable to uninstall too.

    As I was working my way through everything I finally came upon this: FGUWebInstallPrev.EXE

    That one worked for me. If there is additional info you'd like from me that might help, let me know and I will get it to you.

  3. #53
    Quote Originally Posted by Bouzouki View Post
    First time I tried to install. I got all the same symptoms that were reported pretty much throughout the thread. I was unable to uninstall too.

    As I was working my way through everything I finally came upon this: FGUWebInstallPrev.EXE

    That one worked for me. If there is additional info you'd like from me that might help, let me know and I will get it to you.
    With the Current Installer, were you prompted with the Visual C++ Redistributable? If you were, did it install properly or did you have another issue with it?

    Did the updater open after the install process or not? If not, did it open after running from the folder?

    When did you download the current installer? We posted a new version to the same link on Monday, so if by chance you downloaded it any time before then, you may not have the most recent version.

    --Ryan--

  4. #54
    Quote Originally Posted by Bouzouki View Post
    First time I tried to install. I got all the same symptoms that were reported pretty much throughout the thread. I was unable to uninstall too.

    As I was working my way through everything I finally came upon this: FGUWebInstallPrev.EXE

    That one worked for me. If there is additional info you'd like from me that might help, let me know and I will get it to you.
    I tried to run a one-shot in FGU last night and we all had issues with the updater. 2 of us were able to get it running after the whole: Update launcher, it closes... doesn't reopen... run FGUUpdaterPrev.exe (I forget the exact name). 2 Players were unable to get it to update and therefore weren't able to connect to my game. I don't think they were seeing an error code or anything, but I've asked them to try to document another attempt to update over the weekend and will report anything we all find.

  5. #55
    Quote Originally Posted by redeyesofnight View Post
    With the Current Installer, were you prompted with the Visual C++ Redistributable? If you were, did it install properly or did you have another issue with it?

    Did the updater open after the install process or not? If not, did it open after running from the folder?

    When did you download the current installer? We posted a new version to the same link on Monday, so if by chance you downloaded it any time before then, you may not have the most recent version.

    --Ryan--
    No prompt for C++ redistributable.
    The updater did open after the install (Meaning the successful install with the Prev.exe). I did not have to run it from the directory.
    I downloaded it yesterday (Feb 20th around 2-ish EST).

    I uninstalled. The Smitework directory still exists but it is empty.
    I reinstalled with the link you have in post #53
    The install went ok. No request for c++ redist. After shortcut creation, clicked close, asked me to run updater.
    Note: Remember to click settings and ensure you are logged in before clicking update!
    Clicked update, update ran.
    I can send you the log if you want it. I did see this in it though. Not sure if it's useful or not.

    e: FileMoveSafe - Could not move file: System.IO.IOException: Sharing violation on path C:\Users\mohda\AppData\Roaming\SmiteWorks\Fantasy Grounds\vault\PZOSMWPZO40152FG.dat.tmp

    I was able to launch and connect to a test game I created with yesterday's install. Haven't gone further than that though.

  6. #56
    This is still broken. No joy on the install. Seems to hang on the getting purchases from FG server. nothing after that.
    Attached Images Attached Images
    They say the fight between good and evil is an equal struggle, but evil is a giant and good only happens while evil sleeps.

    Mistral, The book of time


    www.ipm.nf.ca/myr

  7. #57
    I re-installed FGU after a while of not doing anything with it. It loaded fine before I tried updating it. Then all of the .exe files disappeared from the SmiteWorks>Fantasy Grounds folder. (as shown in Image below)
    FGU_NoJoy.png
    I included the re-install window showing that the re-install was indeed completed. I had requested Startmenu and Desktop icons, but they were not created either. Since those need an .exe to connect to to be created.

  8. #58
    ddavison's Avatar
    Join Date
    Sep 2008
    Posts
    4,825
    Blog Entries
    16
    Quote Originally Posted by RavenSaint View Post
    Then all of the .exe files disappeared from the SmiteWorks>Fantasy Grounds folder. (as shown in Image below)
    All of the EXE files disappearing sounds like anti-virus is quarantining files. Can you check your A/V software to see if the FG files are there in a quarantine and you can mark them Safe or recover them?

    -Doug

  9. #59
    What versions of Windows does FGU work with? I have Win10 Professional. Checked Anti-virus, FGU is white listed, as is FGC. I have Smiteworks whitelisted. I ran the installer with Admin. I cleared caches. I even turned off firewalls, anti-virus, and Malware programs incase they were still blocking even though they installer was white listed. Still having issues. Will be trying to go through compatibility next.

  10. #60
    Update on FGU missing .exe. Found file C:\Program Files\SmiteWorks\Fantasy Grounds\FantasyGroundsUpdater_OLD.exe
    This allowed me to open the updater. Will update if this updater file works to update FGU to a working state.


    UPDATE: The file listed above allowed the FGU to update and I had to link the window opened to task bar. Need to find out where the .exe is that opens the working window.
    Last edited by RavenSaint; March 30th, 2020 at 15:59. Reason: Test of listed file worked in updating and making working .exe

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

Log in

Log in