Page 1 of 3 123 Last
  1. #1

    Connection issues

    Hey folks.

    I backed Unity and I'm just now starting to play around with it.

    I can't seem to get a player connection to the program. I'm attempting to connect on LAN, but I've also tried a second instance on the same PC. All I get is this response. "Unable to connect to host - Could not connect to the host. Verify network settings and try again."

    I have port 1802 forwarded on my router. I can't figure what is causing this.

    Anyone else run in to this?
    Attached Images Attached Images

  2. #2
    Zacchaeus's Avatar
    Join Date
    Dec 2014
    You don’t need to worry about port forwarding in Unity if you use the cloud. That is set the game to public.

    If the host and player are on the same network then set the game to local and the player should connect using the local IP address of the host’s computer. To connect a second instance use local and connect using localhost in the connection box rather than the IP address.
    If there is something that you would like to see in Fantasy Grounds that isn't currently part of the software or if there is something you think would improve a ruleset then add your idea to the wish list

  3. #3
    I've been trying it exactly as you describe and getting the error I describe. Really not sure what to try next.

  4. #4
    When connecting on LAN, make sure to use the internal IP address. Also, you need to make sure that your network connection is set to Private, and not blocked by any security software.


  5. #5
    I am indeed using the internal IP address. The network connection is set to private on all three devices that I've tried. I have rules set in my firewall to allow fantasy grounds to pass through. I've even tried shutting the firewall off entirely. Same issue.

  6. #6
    Did the host instance have a campaign loaded and running or was it sitting at the launcher? The server portion of FG only operates while actually in a campaign.

    On the host system, can you launch a second instance of FG and connect as a player to "localhost" instead of to an IP address?

  7. #7
    I do have a campaign running when trying to connect. Attempting to connect to "localhost" yields the exact same result.

  8. #8
    Did you happen to change the port used by FG by chance (maybe by accident)? Before starting the campaign on the host, does your "Campaign Details" section look pretty much like this, or different?
    campaign details.jpg

  9. #9
    Sorry to say that's not the issue. Campaign details looks exactly like that.

  10. #10
    Have you restarted the host computer recently (since this started)?

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
DMsGuild Classic

Log in

Log in