1. #1

    Connection Test is no longer working for FG

    I have not had this issue in a long time with my Full License. Is there something going on and the non-Unity FG is no longer connecting at all or is it my computer only? I checked my firewall settings and everything is set up correctly, but now I am having connection issues and wonder is this external or internal, and what do I need to do to get it going again?

    Thanks for any assistance

  2. #2
    LordEntrails's Avatar
    Join Date
    May 2015
    Location
    GMT -7
    Posts
    8,656
    Blog Entries
    9
    Its something on your computer or network. Here are some possibilities;
    - Windows Update has now set your connection type to public
    - Your ISP has changed you to IPv6
    - You modem/router/gateway is no longer forwarding using UPnP and may need to be rebooted
    - Your security software has decided to start blocking FG
    - Your computer internal IP has changed and your port forwarding needs to be updated.

    See this post and then post the answer to the 7 questions here if you are still having trouble;
    https://www.fantasygrounds.com/forum...ions-Explained

    Current Projects: Ultimate Undermountain (NYDUM)
    Community Contributions: Gemstones, 5E Quick Ref Decal, Adventure Module Creation, Dungeon Trinkets
    DMsGuild Content: Balance Disturbed (Adventure), Dungeon Room Descriptions
    FG Product Reviews: Virtual Scribe Reviews

  3. #3
    Zacchaeus's Avatar
    Join Date
    Dec 2014
    Location
    Scotland
    Posts
    11,684
    Check that your network is still set to private. Delete any and all rules in your anti virus and create new ones. And check that your port forward rule is still pointing at the correct internal IP address since that can change. Oh, and also first reboot your router; sometimes that’s all it takes.
    If there is something that you would like to see in Fantasy Grounds that isn't currently part of the software or if there is something you think would improve a ruleset then add your idea to the wish list http://fg2app.idea.informer.com/

  4. #4
    Quote Originally Posted by wychfate View Post
    I have not had this issue in a long time with my Full License. Is there something going on and the non-Unity FG is no longer connecting at all or is it my computer only? I checked my firewall settings and everything is set up correctly, but now I am having connection issues and wonder is this external or internal, and what do I need to do to get it going again mycfavisit?

    Thanks for any tellgamestop assistance
    I have been experiencing disconnects/reconnects for a couple months as well. I thought it was my wifi router, but after factory resetting it, and then replacing it with a Tap-Link mesh that gets me top quality link status all the time, I am moving my diagnosis to the computer. I have updated the network driver with the latest (uncertified) driver, to no avail.

    The interesting part is that we’re using TeamSpeak for voice chat in parallel to FG. I never get any disconnections from TS while FG is experiencing these issues. If I’m the GM, every player gets disconnected from my host. If I’m playing, no other player has disconnections issues when I do.

    I’m using Windows 10 64 bits on a Dell XPS 13 laptop. I did change laptop during winter, but I’m not sure if the timing of the issues coincide. Other than reinstalling my previous laptop, I’m running out of idea to diagnose this.
    Last edited by Lil2; January 2nd, 2020 at 21:54.

  5. #5
    JohnD's Avatar
    Join Date
    Mar 2012
    Location
    Winnipeg Canada
    Posts
    4,520
    Blog Entries
    1
    If you are on Wi-Fi switch to a directly wired connection.
    DMing since 1979. Ultimate License holder.

    Currently GMing:
    * Yggsburgh and Castle Zagyg - Castles and Crusades Greyhawk (Monday)
    * Temple of Elemental Evil - Castles and Crusades Greyhawk (Thursday - on hiatus)
    * 2e Greyhawk (Wednesday)

    Thanks for 7+ years of gaming via FG my friends (2e / 3.5e / Rolemaster Classic / Castles & Crusades / Pathfinder / Savage Worlds / 5e).

    There/Their/They're are all different words and do not mean the same thing.

  6. #6
    Zacchaeus's Avatar
    Join Date
    Dec 2014
    Location
    Scotland
    Posts
    11,684
    Quote Originally Posted by Lil2 View Post
    I have been experiencing disconnects/reconnects for a couple months as well. I thought it was my wifi router, but after factory resetting it, and then replacing it with a Tap-Link mesh that gets me top quality link status all the time, I am moving my diagnosis to the computer. I have updated the network driver with the latest (uncertified) driver, to no avail.

    The interesting part is that we’re using TeamSpeak for voice chat in parallel to FG. I never get any disconnections from TS while FG is experiencing these issues. If I’m the GM, every player gets disconnected from my host. If I’m playing, no other player has disconnections issues when I do.

    I’m using Windows 10 64 bits on a Dell XPS 13 laptop. I did change laptop during winter, but I’m not sure if the timing of the issues coincide. Other than reinstalling my previous laptop, I’m running out of idea to diagnose this.
    Hi Lil, welcome to FG.

    The fact that you are getting disconnects both as host and client does suggest a loss of signal or something is interfering with a FG operations. The usual suspects would be anti virus or programs like Malwarebytes or similar or your IP address is changing which might be indicative of your ISP sharing IP addresses.

    Have a look at this post and answer the questions at the end if you don’t find a solution in the text. https://www.fantasygrounds.com/forum...ions-Explained
    If there is something that you would like to see in Fantasy Grounds that isn't currently part of the software or if there is something you think would improve a ruleset then add your idea to the wish list http://fg2app.idea.informer.com/

  7. #7
    damned's Avatar
    Join Date
    Mar 2011
    Location
    Australia
    Posts
    19,382
    Blog Entries
    1
    Hi Lil2

    Can you open two command prompts (cmd) when next playing or running
    in the first type
    ping 192.168.1.1 -t but use your routers address as the target instead of 192.168.1.1
    and in the second type
    ping 8.8.8.8 -t

    When you have a disconnect or timeout check these windows

    if the first and second pings are timing out then the issue is on your pc or wifi router
    if the first works and the second doesnt then you have an issue with the actual internet connection

    Definitely try and test with a network cable instead of wifi

    MoreCore - Generic Ruleset
    --- Projects ---
    Extensions | Tutorials | MoreCore | MoreCore Themes | Call of Cthulhu | Maelstrom | FG Con

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

Log in

Log in