Thread: Choppy 3d dice

  1. #1

    Choppy 3d dice

    I was wondering if any of you guys are having this issue. I started up FG to prep for my game and the 3d dice animation is extremely choppy. I don't see them land, I see about 3 images of the dice rolling, it is like a 2-4 image slideshow and I don't see the dice landing and the result is displayed on the chat. It doesn't rend the program unusable, it is just very distracting. It was choppy for me before but it wasn't this bad.

  2. #2
    LordEntrails's Avatar
    Join Date
    May 2015
    Location
    GMT -7
    Posts
    8,426
    Blog Entries
    9
    This is usually due to an issue with DirectX9 and your graphics card driver. Has your driver updated recently? If so try rolling it back. Also see if you can disable advanced setting having to do with 3D options on your driver properties and if you have a second graphics processor (discrete and onboard) set FG to use the other one.

    Current Projects: Ultimate Undermountain (NYDUM)
    Community Contributions: Gemstones, 5E Quick Ref Decal, Adventure Module Creation, Dungeon Trinkets
    DMsGuild Content: Balance Disturbed (Adventure), Dungeon Room Descriptions
    FG Product Reviews: Virtual Scribe Reviews

  3. #3
    What kind of graphics card does your computer have? If it's an Intel GPU, those are known to perform fairly badly with FG Classic, due to the old DirectX 9 based graphics engine in FGC. I've mostly noticed performance issues with lots of text being displayed in FG.

    In general, check to make sure you have the latest video driver for your graphics card.

  4. #4
    I use NVIDIA GeForce GTX 1060 3gb. Tried updating and disabling advanced settings for fantasy grounds it, still looks like a slide show. I'm hesitant to downgrade my GPU drivers, since they have aided performance for few games that I play.

  5. #5
    Zacchaeus's Avatar
    Join Date
    Dec 2014
    Location
    Scotland
    Posts
    11,369
    Make sure that you don't have cross-platform compatibility checked in settings. In the NVidia settings you can set individual settings for FG. Try turning off anti-aliasing.
    If there is something that you would like to see in Fantasy Grounds that isn't currently part of the software or if there is something you think would improve a ruleset then add your idea to the wish list http://fg2app.idea.informer.com/

  6. #6
    I tried fiddling around with AA settings, toggling them on and off, tried toggling of a few other things as well. The dice remains choppy and distracting looking. Well at least rest of the program works fine and I get results otherwise. Thanks for your suggestions.

  7. #7
    Do other 3d programs (games, for example) operate normally?

    Have you rebooted your computer since this started?

    Does your computer happen to have more than one GPU? Maybe it's using a different one than it should. This is most common with laptops that have a basic Intel GPU for general use plus an nVidia chip for games. You can usually specify which GPU a program will run on in the nVidia Control Panel application.

  8. #8
    Other 3d programs work well, I have rebooted my computer (every night and in case of updates or when I don't use it). I have only one GPU, I use a desktop pc. I did use Nvidia control panel in previous attempts to improve the performance such as toggling v sync, turning off AA and other things. Thank you for suggestions.

  9. #9
    For some reason when I did these same things yesterday evening, making sure I didn't miss anything and whilst upgrading my pen tablet I rebooted my PC, there was a update available for FG and I installed it, and now they look fine. But I wouldn't be surprised if it went soon looking to choppy. It has happened before.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

Log in

Log in