Page 1 of 2 12 Last
  1. #1

    Not your average savetovault issue.

    Hello again all!

    Having an issue with XG to everything. It was purchased along with the 5E players guide and upon updating the PG was added fine but XG was not. Got the savetovault error for XG and started researching. After reading similiar issues I went to my folder to delete the file and try to start over but it wasnt in the vault. Tried updating again and the .dat file appears as it tries to update but deletes itself upon failure. Not sure what the issue is. Hoping someone might have the answer. Any and all help is appreciated.

  2. #2
    LordEntrails's Avatar
    Join Date
    May 2015
    Location
    GMT -7
    Posts
    8,673
    Blog Entries
    9
    Not on my computer at the moment so I wont get the names etc exactly right. But you should have an update.log file and a console.log file. Check those and see if they provide any info. Also check your security software and see if it has quarantined anything.

    Current Projects: Ultimate Undermountain (NYDUM)
    Community Contributions: Gemstones, 5E Quick Ref Decal, Adventure Module Creation, Dungeon Trinkets
    DMsGuild Content: Balance Disturbed (Adventure), Dungeon Room Descriptions
    FG Product Reviews: Virtual Scribe Reviews

  3. #3
    Quote Originally Posted by LordEntrails View Post
    Not on my computer at the moment so I wont get the names etc exactly right. But you should have an update.log file and a console.log file. Check those and see if they provide any info. Also check your security software and see if it has quarantined anything.
    This is the only thing from the log files for XG to everything

    MANIFEST REQUEST
    Checking package WOTC5EXGTE for updates
    MANIFEST XML - WOTC5EXGTE
    <productmanifest>
    <name>WOTC5EXGTE</name>
    <version>1.0.0</version>
    <manifest>
    <file>
    <name>extensions/Decal_XGTE.ext</name>
    <size>4655009</size>
    <hash>82dda57696014363b96a2f1295b9c7e38a1c014e</hash>
    </file>
    <file>
    <name>modules/Xanathar's Class Tokens.mod</name>
    <size>4121089</size>
    <hash>8898a31806a2b265bd4ba9152ef8827e11f4c979</hash>
    </file>
    <file>
    <name>modules/DD Xanathar's Guide to Everything Players.mod</name>
    <size>10707907</size>
    <hash>42b08f3aaee6f22c82f42b646bcc624430c846c8</hash>
    </file>
    <file>
    <name>modules/DD Xanathar's Guide to Everything.mod</name>
    <size>28149985</size>
    <hash>74d64319776b3ea5ec02f7f40ba7c4ab3090db1e</hash>
    </file>
    <file>
    <name>portraits/Xanathar Portraits.ppk</name>
    <size>649982</size>
    <hash>779077f4d3e54ee111250d78a50a7be52445eefb</hash>
    </file>
    </manifest>
    </productmanifest>

    The console log doesn't have anything that mentions the file at all. No antivirus running currently on the system in question.

  4. #4
    Edit: Here is the full error upon the updater failing...

    Unable to extract file (modules/DD Xanathar's Guide to Everything.mod) for product (WOTC5EXGTE).
    HandleFile: Unable to save file (modules/DD Xanathar's Guide to Everything.mod) in product (WOTC5EXGTE) to content vault.
    FILE REQUEST
    updating portraits/Xanathar Portraits.ppk
    Validating packages
    Unable to update at least one product.

  5. #5
    LordEntrails's Avatar
    Join Date
    May 2015
    Location
    GMT -7
    Posts
    8,673
    Blog Entries
    9
    I've got a couple WAGs, but cant take a look until tonight. Hopefully someone else can give you a solution. Or you can reach out directly to support and link to the thread here. Otherwise I will try to take a look when I get home tonight.

    Current Projects: Ultimate Undermountain (NYDUM)
    Community Contributions: Gemstones, 5E Quick Ref Decal, Adventure Module Creation, Dungeon Trinkets
    DMsGuild Content: Balance Disturbed (Adventure), Dungeon Room Descriptions
    FG Product Reviews: Virtual Scribe Reviews

  6. #6
    Quote Originally Posted by LordEntrails View Post
    I've got a couple WAGs, but cant take a look until tonight. Hopefully someone else can give you a solution. Or you can reach out directly to support and link to the thread here. Otherwise I will try to take a look when I get home tonight.
    Thanks for the help. Will forward this link to support and see if anything turns up. If we get the issue resolved before you make it home I will be sure to update the post.

  7. #7
    Zacchaeus's Avatar
    Join Date
    Dec 2014
    Location
    Scotland
    Posts
    11,713
    Make sure that you have full read/write access to the area that you are saving FGData to; and also make sure that you have set an exception for FG in your Antivirus and check that you don't have flood protection set on your router.
    If there is something that you would like to see in Fantasy Grounds that isn't currently part of the software or if there is something you think would improve a ruleset then add your idea to the wish list http://fg2app.idea.informer.com/

  8. #8
    Quote Originally Posted by Zacchaeus View Post
    Make sure that you have full read/write access to the area that you are saving FGData to; and also make sure that you have set an exception for FG in your Antivirus and check that you don't have flood protection set on your router.
    Since the PH downloaded without a problem doesn't that rule out a read/write issue? No antivirus running on the system and windows firewall turned off. The system is using a hotspot for internet so I suppose the issue could be with the flood protection or something on the hotspots firewall. Will try installing again using a different connection.



    Edit: Switching to another connection did not solve the issue. The update still failed in the same place.
    Last edited by KvotheComplex; December 2nd, 2019 at 22:00. Reason: More Information

  9. #9
    ddavison's Avatar
    Join Date
    Sep 2008
    Posts
    4,738
    Blog Entries
    16
    In one or two very unusual reports, we found that there was some sort of Internet Filtering in place between the PC and us that was blocking the file based on the contents. You said that your A/V was turned off and that you also tried with a hotspot, but is there any other sort of Internet protection that might be in place for your connection?

  10. #10
    Quote Originally Posted by ddavison View Post
    In one or two very unusual reports, we found that there was some sort of Internet Filtering in place between the PC and us that was blocking the file based on the contents. You said that your A/V was turned off and that you also tried with a hotspot, but is there any other sort of Internet protection that might be in place for your connection?
    Not that I can think of. No AV program, Windows firewall disabled completely, and firewall for router used when switching off of hotspot connection was set to lowest settings. Unaware of any other programs that could be in the way.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

Log in

Log in