1. #1
    Zacchaeus's Avatar
    Join Date
    Dec 2014
    Location
    Scotland
    Posts
    11,363

    Occluders have stopped being functional

    Ok, following reports on Discord there is a problem with occluders and LOS.

    I've been working on the occluders for Tomb of Annihilation on and off over the last couple of weeks. When I try to add occluders to a new map I get nothing; the lines don't show at all - just nothing happens. For maps which are already done it appears at first that the occluders are missing from those maps. Additionally the LOS button does not toggle LOS off or on (more below). However if I place any token on the map I am then able to see the occluders. But LOS still won't switch on or off. What does happen is that the token switches between visible and invisible. In play mode I can still mouse over occluders and they will show closed or open etc, but LOS itself is non functional.

    If I open any other module in this campaign I can draw occulders on maps in that module. I have tried to relocate the xml file for maps that I have done to a new campaign but I get the same issues as in the original campaign.

    I have looked at all the other campaigns that I have which were used to create occluders and all of them have the same issues.

    This issue may be related somehow to resizing the map.

    I tested on Lost Mines which I know to have had the occluders done and are included in the module. I opened Cragmaw Castle, unlocked the map and toggled LOS on. I then was able to move a token around and the occluders worked, I could see the occluders etc - everything normal. However as soon as I resized the map LOS disappeared; the occluders disappeared and the LOS toggle ceased to function.

    Hopefully there's enough in this for you to diagnose the issue.
    If there is something that you would like to see in Fantasy Grounds that isn't currently part of the software or if there is something you think would improve a ruleset then add your idea to the wish list http://fg2app.idea.informer.com/

  2. #2
    Patou's Avatar
    Join Date
    Feb 2015
    Location
    South-shore of Montreal, QC. Canada
    Posts
    466
    Same on my end. Thanks Z for the follow-up.
    Patou a.k.a: Patmaster
    Challenging players since 1987
    2E, 3.5E & now 5E
    https://twitter.com/PatouLeFou

  3. #3
    Thanks for reporting. I've escalated to Carl as FGU-724.

    Regards,
    JPG

  4. #4
    Allmight's Avatar
    Join Date
    Jun 2016
    Location
    Stockholm, Sweden
    Posts
    253
    I can support this, and it's related to the bug i reported here.

    This is also true for clients loged on to the server. If they resize a LOS enabled map, LOS vanishes and they can see the whole map.

    But as i mentioned in my bug report, if you close the map and reopen it (unlocked), LOS data comes back.
    Fantasy Grounds Official Discord Server
    [ULTIMATE LICENSE HOLDER]
    [FGU BACKER]


  5. #5
    I was experiencing something similar. Zacc if you add a new layer to the map do they show up?

  6. #6
    Zacchaeus's Avatar
    Join Date
    Dec 2014
    Location
    Scotland
    Posts
    11,363
    Quote Originally Posted by H2Os View Post
    I was experiencing something similar. Zacc if you add a new layer to the map do they show up?
    Yes, adding or removing a layer reveals the occluders. But then they go away again as soon as the map is resized. Zooming in and out is ok but not resizing.
    If there is something that you would like to see in Fantasy Grounds that isn't currently part of the software or if there is something you think would improve a ruleset then add your idea to the wish list http://fg2app.idea.informer.com/

  7. #7
    Thanks for the additional information. This has allowed Carl to identify the issue, and we'll be working on another set of fixes for today or tomorrow.

    Regards,
    JPG

  8. #8
    A new build is available which addresses the LOS data disappearing on resize.

    Regards,
    JPG

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

Log in

Log in