Page 1 of 2 12 Last
  1. #1

    customdice script fails to load

    I am seeing this behaviour in FGU only with my custom Dark Eye ruleset.

    The console shows this error:
    [10/30/2019 10:10:27 PM] [WARNING] Could not load script file () (customdice_scripts/customdice_3.lua)
    [10/30/2019 10:10:27 PM] [WARNING] Could not load script file (d3) (customdice_scripts/customdice_3.lua)

    Definition in gameelements.xml
    <customdie name="d3">
    <model>d6</model>
    <menuicon>customdice</menuicon>
    <script file="customdice_scripts/customdice_3.lua" />
    </customdie>


    content of customdice_3.lua:
    function onValue(result)
    DebugM.printLogMessage("customdice_scripts/customdice_3.lua, onValue");
    DebugM.printLogMessage("customdice_scripts/customdice_3.lua, onValue, Ende");
    return math.ceil(result/2);
    end

    I was fixing the game version to <root version="2.9">
    Is it connected to this and does FGU ignore the root version tag or is there another problem I am not aware of?
    Loading the same ruleset in FGC works fine.
    Last edited by JMessmer; October 31st, 2019 at 20:00.

  2. #2
    Any ideas anyone? Right now I am clueless.

  3. #3
    damned's Avatar
    Join Date
    Mar 2011
    Location
    Australia
    Posts
    19,042
    Blog Entries
    1
    There is a similar post by Valarian and Moon Wizard has replied.

    MoreCore - Generic Ruleset
    --- Projects ---
    Extensions | Tutorials | MoreCore | MoreCore Themes | Call of Cthulhu | Maelstrom | FG Con

  4. #4
    LordEntrails's Avatar
    Join Date
    May 2015
    Location
    GMT -7
    Posts
    8,425
    Blog Entries
    9
    Yes, customdice not working at the moment

    Current Projects: Ultimate Undermountain (NYDUM)
    Community Contributions: Gemstones, 5E Quick Ref Decal, Adventure Module Creation, Dungeon Trinkets
    DMsGuild Content: Balance Disturbed (Adventure), Dungeon Room Descriptions
    FG Product Reviews: Virtual Scribe Reviews

  5. #5
    Are you still seeing this? Can you point me at a version of a ruleset that does this?

    I just tried setting up a custom_d3.lua script in CoreRPG; and replacing the built-in d3 in-line script with that file reference. And, it worked without any issues for me.

    Thanks,
    JPG

  6. #6
    the only way I managed to get it working was with inline scripting...
    I don't know why it did not work.

  7. #7
    I understand; but I tried with a separate file as well, and it was working for me.

    Perhaps it was the specific way that you did it that caused an issue? Do you still have the problem version of the files?

    Regards,
    JPG

  8. #8
    I have no idea why it is working inline but not as external script. I even removed the DebugMessages because I thought they might not have been initialized yet but that was not the reason.

    The issue still persists. I just checked with the latest FGU version. Inline works while with an external script I receive this error message:
    [11/9/2019 6:33:33 PM] [WARNING] Could not load script file () (scripts/customdice_3.lua)
    [11/9/2019 6:33:33 PM] [WARNING] Could not load script file (d3) (scripts/customdice_3.lua)

  9. #9
    Can you provide a link to the ruleset or extension that is throwing this error?

    Thanks,
    JPG

  10. #10
    Hi Jpg, I sent you a PM just now with the link. The rule set has some license issues and cannot be published yet. Thanks a lot for trying to investigating this.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

Log in

Log in