Starfinder Playlist
Page 7 of 21 First ... 5678917 ... Last

Thread: 5E Enhancer

  1. #61
    I am a completely new user and am trying to setup my system to DM a home game, as well as be able to play online with friends while in quarantine. This extension looks extremely useful, but I have been unable to use it yet. The error below is what I see when I open the combat tracker. Where am I going wrong here?
    5e Tracker Errors.jpg

  2. #62
    If you want to report a bug then please use this template.

    Bug Report

    Are you using Fantasy Grounds Unity? (I only support FGU with this extension. If you're using FG classic I'll refer you to the finalized version of my 5E Combat Enhancer extension instead.)

    Is your FG software up to date?

    Do you have the latest version of the extensions installed? (You can see the most up to date version number in the first post on page 1, the version number is printed in FG on start in the chat.)

    Please post the console error printout here:
    (This is the error log window text. It can be opened by typing '/console' in the FG text window if it didn't open by itself. Also if there are no output errors, state that here.)

    If you create a new (clean) campaign, with ONLY the 5E Enhancer extensions enabled, does the error still occur?

    Can you recreate the error consistently?

    What are the precise steps to recreating the error?

    Does this always happen?

    Does this only happen when using a specific module, map, NPC, PC, weapon, etc.?
    (The more in depth information on which these are the better.)

    Do you have a screenshot you could share?

    Any further information that could help to replicate and trace the error?
    Extension writer, FGU Backer, Ultimate License holder.

    5E Enhancer (limited support for FGU)

    Combat Enhancer 5E Classic (no longer officially supported)

    ps. Do not send PM's for support for the extensions I write, I will not not be able to respond there. Use the relevant forum threads instead so the community can benefit from the replies, thank you.



  3. #63
    This looks amazing, I am installing it now .

    May I recommend changing the title of the thread to include "FGU" or "FGU Only", I am currently searching through loads of extensions trying to find out if any work with FGU haha.

    Another noob question - does every player have to install the extension? Thank you so much!

  4. #64
    Issue: ranged attacks do not seem to work with the automatic ranged modifier option enabled.


    Are you using Fantasy Grounds Unity? Yes

    Is your FG software up to date? Yes

    Do you have the latest version of the extensions installed? Yes

    Please post the console error printout here:
    [3/31/2020 2:06:26 PM] Launcher scene starting.
    [3/31/2020 2:07:10 PM] Starting private server mode. [(192.168.1.128:1802) (fe80::a4c9:fa05:40e6:b63a:1802)]
    [3/31/2020 2:07:10 PM] Game server started. [192.168.1.128:1802]
    [3/31/2020 2:07:11 PM] Launcher scene exiting.
    [3/31/2020 2:07:11 PM] Tabletop scene starting.
    [3/31/2020 2:13:26 PM] Campaign saved.
    [3/31/2020 2:18:26 PM] Campaign saved.
    [3/31/2020 2:23:26 PM] Campaign saved.
    [3/31/2020 2:24:19 PM] [WARNING] Frame tabs contains out-of-range values in BottomLeft.
    [3/31/2020 2:24:40 PM] [<color="red">ERROR</color>] Script execution error: [string "scripts/automatic_range_modifier/ranged_att..."]:475: bad argument #1 to 'find' (string expected, got nil)
    [3/31/2020 2:25:18 PM] [<color="red">ERROR</color>] Script execution error: [string "scripts/automatic_range_modifier/ranged_att..."]:475: bad argument #1 to 'find' (string expected, got nil)
    [3/31/2020 2:25:31 PM] Handler error: [string "scripts/automatic_range_modifier/ranged_att..."]:475: bad argument #1 to 'find' (string expected, got nil)
    [3/31/2020 2:25:36 PM] [<color="red">ERROR</color>] Script execution error: [string "scripts/automatic_range_modifier/ranged_att..."]:475: bad argument #1 to 'find' (string expected, got nil)
    [3/31/2020 2:26:01 PM] [<color="red">ERROR</color>] Script execution error: [string "scripts/automatic_range_modifier/ranged_att..."]:475: bad argument #1 to 'find' (string expected, got nil)


    If you create a new (clean) campaign, with ONLY the 5E Enhancer extensions enabled, does the error still occur? Yes

    Can you recreate the error consistently? Yes

    What are the precise steps to recreating the error?

    Seems to be any ranged attack completed by dragging the hit dice onto the monster on the CT. If you drag it onto an icon, it doesnt do anything at all (no error, no roll).

    Does this always happen? Yes as long as automatic ranged modifiers is turned on.

    Does this only happen when using a specific module, map, NPC, PC, weapon, etc.? No.
    (The more in depth information on which these are the better.)

    Do you have a screenshot you could share?

    Any further information that could help to replicate and trace the error?

  5. #65
    Window resizing does not seem to work. It does not cause an error, but does not resize the window.

    Are you using Fantasy Grounds Unity? Yes

    Is your FG software up to date? Yes

    Do you have the latest version of the extensions installed? Yes

    Please post the console error printout here:

    No error or log is produced


    If you create a new (clean) campaign, with ONLY the 5E Enhancer extensions enabled, does the error still occur? Yes

    Can you recreate the error consistently? Yes

    What are the precise steps to recreating the error?

    Change the size of a window on a brand new campaign with only 5e extension enabled, does not change the window sizes.

    Does this always happen? Yes

    Does this only happen when using a specific module, map, NPC, PC, weapon, etc.? No.
    (The more in depth information on which these are the better.)

    Do you have a screenshot you could share?
    window resizer.PNG
    Any further information that could help to replicate and trace the error?

  6. #66
    @Houndy

    Can't change the title after a post has been made. It states that it's for FGU in the first post. Besides soon enough FGU will become the standard, so it will be assumed.

    Only you as the DM needs the extension for it work for everyone.


    Ranged attack bug report:

    Ran a game this evening, ranged attacks were working as intended and did not get any ranged errors.

    Usually if this occurs it is because the NPCs you're using have a non-standard entry for their range values.
    Standard meaning similar to what you'd find in the monster manual, volos guide to monsters, mordenkeinens etc.

    I may add an exit clause for those cases to avoid getting an error for those cases.


    Resizer bug report:

    Tested it now on my end and it's working. It resizes the windows on change.
    You need to close and reopen the window for it to do so.
    Last edited by Styrmir; April 1st, 2020 at 03:03.
    Extension writer, FGU Backer, Ultimate License holder.

    5E Enhancer (limited support for FGU)

    Combat Enhancer 5E Classic (no longer officially supported)

    ps. Do not send PM's for support for the extensions I write, I will not not be able to respond there. Use the relevant forum threads instead so the community can benefit from the replies, thank you.



  7. #67
    Thank you for testing it again Stymir. You are correct, the resizer seems to work as expected, sorry about that!

    Edit in - Ok, the window resizing stopped working again, do not know why. I will keep on messing around with it over next few days and if I can find the exact sequence to what causes it to stop working I will let you know.

    Ranged attack - So I have retested it, I was using a thrown dagger, that still gives the error. The rest of the ranged weapons I tested (thrown axe, longbow, shortbow) seem to work.
    RangedAttackModifier1.PNG
    Last edited by Houndy; April 1st, 2020 at 10:26.

  8. #68
    I *think* Daggers might be the only weapon that has two properties before the range: Finesse, Light, Thrown (), and for everything else the range is either the first or second property. I wonder if deleting Finesse or Light, would make a difference, or changing the property order

    Edit: Could Ammo:0 in your picture there also be a culprit?
    Last edited by The High Druid; April 1st, 2020 at 10:38.

  9. #69
    I reloaded the game and its suddenly started working .... I dont understand. This is confusing me. I am gonna take a break and try it all again later and see if I can recreate the issue. Sorry about this mess

    With regard to the window resize - could it be that I accidentally resized the window at some point? Is there a way to reset it, so that this mod can be the overrider again?

  10. #70
    I put the file FG-5E-Enhancer v0.7.1.ext in the Folder like I did with the wildshape extensions:
    C:\Users\xxx\AppData\Roaming\SmiteWorks\Fantasy Grounds\extensions
    This one does not show in the list of available extensions on hosting a game.
    Any idea what I do wrong?

Thread Information

Users Browsing this Thread

There are currently 2 users browsing this thread. (1 members and 1 guests)

  1. Styrmir

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Joshua Stream Pre

Log in

Log in