Thread: T1 support?

  1. #1

    T1 support?

    While I'm killing time waiting on the Conan 2d20 release I find myself drifting towards preparing a new SF game. I'm thinking maybe doing a short campaign using Traveller and the T1 Judge Dredd rules. How well-supported will T1 be in the future (in comparison to T2)? Since I'll be creating the Dredd library myself I'm a little leery of diving in only to find out that T1 just won't work anymore with whatever future upgrades come up (I'm still iffy on this whole Unity thing but I'm not a tech guy).

  2. #2

    Join Date
    Jan 2014
    Location
    California
    Posts
    515
    Quote Originally Posted by ProfDogg View Post
    While I'm killing time waiting on the Conan 2d20 release I find myself drifting towards preparing a new SF game. I'm thinking maybe doing a short campaign using Traveller and the T1 Judge Dredd rules. How well-supported will T1 be in the future (in comparison to T2)? Since I'll be creating the Dredd library myself I'm a little leery of diving in only to find out that T1 just won't work anymore with whatever future upgrades come up (I'm still iffy on this whole Unity thing but I'm not a tech guy).
    I cannot answer for certain, but, from prior comments it appears that it is the preference of Mongoose that development focus on MGT2 as it is the current new, shiny.

    I should add, however, that MBM has been doing a good job of keeping both rulesets operational. Both are also already supported on Unity.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

Log in

Log in