1. #1

    Making Your Own 13th Age .MOD File

    I'm posting this here as much for myself as I am for everyone else. After I exported the file for the Book of Heroic Races: Age of Races (coming soon), I was not able to find it. After some experimenting and some awesome help from Laendra on Discord, we came up with the answer. Here's the modifications you have to make a .mod file work for 13th Age.

    For those with experience: You have to change a line in definition.xml to '<root version="3.3">'

    Step by Step for those without experience:
    1. Once you export the .mod file (see the many youtube videos on how to do that), you want to go to the modules folder. I recommend getting there by clicking on Images and Maps, clicking the Folder button, in the new window go to the Fantasy Grounds folder and then opening the modules folder.
    2. Find the file you just exported and change the .mod part of the file to .zip (if you don't have file name extensions turned on, you'll need it turned on). Open the zip file.
    3. Copy the file definition.xml to the modules folder and open it. If you don't have an xml reader, change the .xml part of the file to .txt and open it in Notepad. DO NOT OPEN IT IN WORD. For a free XML reader, I recommend downloading Notepad++.
    4. The second line is going to be something like "<root version="3.3" release="31|4E:28|CoreRPG:4">". Change this to "<root version="3.3">". Save the file. If you renamed definition.xml to a txt file, change the name back.
    5. Place definition.xml back in the .zip file. Change the name of the .zip file back to .mod.


    And that is it. You are done. Happy Mod creating.
    Last edited by dmccoy1693; September 11th, 2019 at 18:48.
    Dale McCoy, Jr (Ultimate License holder)

    President of Jon Brazer Enterprises. See all of our products available for Fantasy Grounds.

  2. #2
    Hey guys, on this specific topic, could someone fill me in on what the problem was?

    I just exported an example module with a few images here on my machine, exited, created a new campaign, and I was able to load the exported module. I checked the definition.xml, and it was using the <root version="3.3" release="31|4E:28|CoreRPG:4"> tag and didn't appear to have any problems.

    Just wanted to figure out to make sure it's not an issue we can fix for the next version.

    Thanks,
    JPG

Thread Information

Users Browsing this Thread

There are currently 12 users browsing this thread. (0 members and 12 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

Log in

Log in