1. #1

    Internet Connection Sharing Service, port 1802, and Windows 10

    Hello! I'm just posting this in the hopes that the information helps someone at some point and/or is searchable.

    The Problem

    The symptom in this case was that Fantasy Grounds would not open port 1802, but nothing else seemed to be listening on that port to occupy it. The way to tell if this is the specific problem (rather than a port forwarding or firewall problem) is with good ol' netstat or tcpview: Run Fantasy Grounds, load a campaign, then in a command prompt, run netstat -an | findstr "1802". If the result is not empty, this is not specifically your problem (although you could have a related problem, which is that some other server is taking the port, which I won't help diagnose here, check the sticky thread for that).

    ...and the Solution

    If the command result is empty, then what may be happening is that the Internet Connection Sharing Service is reserving that port (and others). Use window button + r to bring up the run prompt, type "services.msc" into that. In the list, scroll down to find the Internet Connection Sharing (ICS) entry. Right-click it, choose "properties", then in the resulting window under the "startup type" dropdown, choose "disabled". Apply that setting, then in the same window, click the "Stop" button just under the startup type dropdown. Once you've done this, fantasy grounds should be able to bind to port 1802.

    Unfortunately, anything that was depending on Internet Connection Sharing will now not work. So bewaaaare. You might have better luck running fantasy grounds with the -p option instead to select a different port.

  2. #2
    One note with the -p option is that the host and all players must use that option in their command line in order to connect to each other.

    Regards,
    JPG

  3. #3
    I'm just waiting for FGU and the "one click connect" that was advertised. This porting to 1802 thing. I can't figure it out. A dozen Youtube "easy" port forwarding videos. You need 5 college degrees to figure it out. It's the most ridiculous thing.
    Hopefully when FGU comes out, I'll actually be able to play a remote game.

  4. #4
    damned's Avatar
    Join Date
    Mar 2011
    Location
    Australia
    Posts
    18,878
    Blog Entries
    1
    Quote Originally Posted by Milke View Post
    I'm just waiting for FGU and the "one click connect" that was advertised. This porting to 1802 thing. I can't figure it out. A dozen Youtube "easy" port forwarding videos. You need 5 college degrees to figure it out. It's the most ridiculous thing.
    Hopefully when FGU comes out, I'll actually be able to play a remote game.
    Players dont need to Port Forward.
    If you have the capacity to learn how to play a RPG you can definitely handle port forwarding - although you may not want to.
    If you need help setting it up there are plenty of people willing to.

    MoreCore - Generic Ruleset
    --- Projects ---
    Extensions | Tutorials | MoreCore | MoreCore Themes | Call of Cthulhu | Maelstrom | FG Con

  5. #5

    Join Date
    Apr 2008
    Location
    Virginia Beach
    Posts
    2,998
    Quote Originally Posted by Milke View Post
    I'm just waiting for FGU and the "one click connect" that was advertised. This porting to 1802 thing. I can't figure it out. A dozen Youtube "easy" port forwarding videos. You need 5 college degrees to figure it out. It's the most ridiculous thing.
    Hopefully when FGU comes out, I'll actually be able to play a remote game.
    Come on, Milke , you are giving us Okies a bad name. If you will just let some of the experts walk you through it, it will be easy or it will be impossible without a vpn if your ISP is sharing IPs or using IPv6.
    I am not sure how you can bitch when there are people almost begging to help you.

    I am from Marietta, born in Stillwater living in Virginia Beach. Go Sooners or Cowboys, depending on your school of choice!

  6. #6
    To be fair to Milke, most of us have been slowly learning RPGs over the course of several years, with incremental payoff each time. For a lot of people who use technology in their day-to-day work, it can be pretty hard to understand how much background knowledge is assumed in even the most newbie-friendly port-forwarding tutorials out there.

    That said, if Milke's not accepting help when offered, there's not much that can be done about that, so I sympathize with the frustration, too. Let's just all agree that computers are bad and never should have been invented.

  7. #7
    I think wristwatches should never have been invented and we should go back to the ocean...
    Paul Grosse
    PCGen BoD
    PR Silverback

  8. #8
    I've had the same issue when having Hyper-V setup. Very annoying and took lots of time to debug.

    If you develop, you can see the issue by creating a small TCP listener where it will get the error 'an attempt was made to access a socket in a way forbbiden by its access permissions' or the like.

    You can also see it with this little tool TCP Listen https://www.allscoop.com/tcp-listen.php Just put in 1802 and click Listen (Without FantasyGrounds loaded), and you'll get the same error.

  9. #9
    I finally found an actual solution. At least if Hyper-V is the culprit. Likely others, however the solution would require you to know which as you have to uninstall that feature then reinstall it after making some changes.

    You can check what ports are being restricted with the following;
    Code:
    netsh interface ipv4 show excludedportrange protocol=tcp
    
    Protocol tcp Port Exclusion Ranges
    
    Start Port    End Port
    ----------    --------
          1091        1190
          1801        1902
          1955        2054
          2055        2154
          2180        2279
          2380        2479
          4272        4371
          4554        4653
          4654        4753
          4768        4867
          4868        4967
          5041        5140
          5241        5340
          5357        5357
          5358        5457
          5985        5985
          9030        9030
         18058       18157
         18158       18257
         22221       22221
         22223       22223
         47001       47001
    
    * - Administered port exclusions.
    I tried to delete the reservation that's effecting 1802, but got a denied response even as administrator.
    Code:
    # Didn't work, error denied.
    netsh interface ipv4 delete excludedportrange protocol=tcp startport=1801 numberofports=100
    
    Access is denied.

    To resolve, again if Hyper-V is the one causing all of the reservations. Otherwise, hopefully the above command will work for you;

    Code:
    # Disable hyper-v (which will required a couple of restarts)
    dism.exe /Online /Disable-Feature:Microsoft-Hyper-V
    
    # When you finish all the required restarts, reserve the port you want so hyper-v doesn't reserve it back
    netsh int ipv4 add excludedportrange protocol=tcp startport=1802 numberofports=1
    
    # Re-Enable hyper-V (which will require a couple of restart)
    dism.exe /Online /Enable-Feature:Microsoft-Hyper-V /All
    
    # Delete the exclusion from above, which will show with a * in the list
    netsh int ipv4 delete excludedportrange protocol=tcp startport=1802 numberofports=1
    Originally found here https://github.com/docker/for-win/issues/3171

  10. #10
    damned's Avatar
    Join Date
    Mar 2011
    Location
    Australia
    Posts
    18,878
    Blog Entries
    1
    Well done Mortani

    MoreCore - Generic Ruleset
    --- Projects ---
    Extensions | Tutorials | MoreCore | MoreCore Themes | Call of Cthulhu | Maelstrom | FG Con

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

Log in

Log in