Page 1 of 2 12 Last
  1. #1

    Issues with players seeing Map

    Hi, I hope someone can point me in the right direction to fix this issue.

    Our group has been running Dragon Heist and then Dungeon of the Mad Mage for almost a year now. We're all very familiar with Fantasy grounds, so I don't think we've run into any rookie mistakes. Yesterday, we ran into an issue where half of the players couldn't see the map at all. The map was partially masked, but of course not fully masked.

    Today, I created a test campaign to try and narrow down the issue. I loaded up only Dungeon of the Mad Mage module and shared a few artwork images, one map of skullport unmasked and one map of level 1 with 50% mask. The issue still persisted for about half of the players. The one's who couldn't see the partially masked map could see the skullport map and artwork without issue.

    Based on all this and the fact that the issue is recent, I'm guessing it has something to do with the newest version of Fantasy Grounds. I looked through the threads on 3.3.8 but couldn't find any similar reports.

    We appreciate any help in troubleshooting this issue,
    Chris

  2. #2
    damned's Avatar
    Join Date
    Mar 2011
    Location
    Australia
    Posts
    19,064
    Blog Entries
    1
    Hey Chris

    How much RAM is FG using when you have the game running as GM?
    How much RAM does the player instance use?

    You might need to reduce the number of:
    a) tokens on the GM instance
    b) shared images (unshare them)
    c) too many open/shared modules

    Try reducing some or all of these and then have the player Nuke their Cache and retest. The first connection will take some time as everything will be redownloaded.

    MoreCore - Generic Ruleset
    --- Projects ---
    Extensions | Tutorials | MoreCore | MoreCore Themes | Call of Cthulhu | Maelstrom | FG Con

  3. #3
    On the GM side, Fantasy Grounds is using about 1GB of ram. My system total is only running at 22% capacity which is 64Gb total.
    On the player side, it's using about 300 mb.

    As for the other suggestions, that's why I started a new campaign to test. It is just the ruleset with DOTMM loaded and nothing else. No extensions, decals, tokens, or anything else loaded and the issue is still persisting. They can't see the partially masked image at all.

    I know at least one player tried nuking the cache and it didn't work. I cleared it on the GM side as well with no change.

    Quote Originally Posted by damned View Post
    Hey Chris

    How much RAM is FG using when you have the game running as GM?
    How much RAM does the player instance use?

    You might need to reduce the number of:
    a) tokens on the GM instance
    b) shared images (unshare them)
    c) too many open/shared modules

    Try reducing some or all of these and then have the player Nuke their Cache and retest. The first connection will take some time as everything will be redownloaded.

  4. #4
    damned's Avatar
    Join Date
    Mar 2011
    Location
    Australia
    Posts
    19,064
    Blog Entries
    1
    Do you have another computer at your location? Can you connect the other computer at your GM computer by the Local/Internal IP Address and see if the issue persists?

    MoreCore - Generic Ruleset
    --- Projects ---
    Extensions | Tutorials | MoreCore | MoreCore Themes | Call of Cthulhu | Maelstrom | FG Con

  5. #5
    Quote Originally Posted by damned View Post
    Do you have another computer at your location? Can you connect the other computer at your GM computer by the Local/Internal IP Address and see if the issue persists?
    I just tried this and I wasn't able to recreate the issue with my laptop connected to my home network. It was working normally. However, when I connected the laptop to a different network I had the same issue that the players have been reporting.

    This is really confusing since I haven't changed anything about my internet configuration in quite some time. Also, not all of the other players had the same issue. Some were able to see the masked map as intended while others only saw a gray window.

  6. #6
    Quote Originally Posted by B3hodlr View Post
    I just tried this and I wasn't able to recreate the issue with my laptop connected to my home network. It was working normally. However, when I connected the laptop to a different network I had the same issue that the players have been reporting.

    This is really confusing since I haven't changed anything about my internet configuration in quite some time. Also, not all of the other players had the same issue. Some were able to see the masked map as intended while others only saw a gray window.
    I went back and tried this again with the laptop connected to the home network and this time I was able to recreate the issue while connected to the home network. So one out of two times, it worked correctly when connected to the home network.

  7. #7
    damned's Avatar
    Join Date
    Mar 2011
    Location
    Australia
    Posts
    19,064
    Blog Entries
    1
    Is the GM computer on Wifi? If so please try improving its signal/reception and/or try with a LAN cable.
    Have a look at what AV or Security products might be running on the GM computer and try disabling them for 15mins while you test?

    MoreCore - Generic Ruleset
    --- Projects ---
    Extensions | Tutorials | MoreCore | MoreCore Themes | Call of Cthulhu | Maelstrom | FG Con

  8. #8
    I ran a session on Friday and one of my players also complained about her map not updating (3.3.8). At the time it was minor (fixed with a sync) so I hadn't dug into it any more. I probably won't have time to until this weekend. I have a session as a player this Friday so I'll keep an eye out for it.

  9. #9
    I'm a player in B3hodler's game. I've noticed that the masks are stored as png files and assigned filenames based upon what appears to be a unix timestamp.

    From the client side, I've been able to view some maps and not others, apparently because my system loaded an erroneous mask. The player icons are present but the map is totally masked or is mostly masked.

    I noticed that on the test server he set up, I was able to view a map with the correct mask and that this mask's filename matched with the creation metadata for the file. (other players were unable to view this map)

    One of the maps that displayed an incorrect mask has a filename that does not match the metadata for the file. The filename indicates a June creation date and the metadata indicates a July creation date and an August modification date.

  10. #10
    Zacchaeus's Avatar
    Join Date
    Dec 2014
    Location
    Scotland
    Posts
    11,393
    How big are these maps (resolution and size) and are they .jpg files?
    If there is something that you would like to see in Fantasy Grounds that isn't currently part of the software or if there is something you think would improve a ruleset then add your idea to the wish list http://fg2app.idea.informer.com/

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

Log in

Log in