5E Storm Kings Thunder Playlist
  1. #1

    Higher Refresh Rate Monitor: Fantasy Grounds Causes Screen Flicker

    Any Ideas?

    It fixes when I manually change the monitors settings to 60, but obviously this isn't ideal, because I then have to constantly change it back and forth. Does anyone know of any solutions? And this is definitely Fantasy Grounds. It doesn't do it on any other software or in Windows itself.

    EDIT: It does this when I type.

  2. #2
    FG is built using DirectX 9 libraries. My guess is that the graphics and/or monitor drivers you have are not handling the graphic updates from the DirectX 9 libraries. You can try updating drivers for both.

    A couple other things to try:
    * Make sure compatibility mode is turned off in FG Settings.
    * Try adjusting the graphics control panel options for each application (such as NVidia Control Panel or AMD Catalyst Control Panel).

    Regards,
    JPG

  3. #3
    Quote Originally Posted by Moon Wizard View Post
    Try adjusting the graphics control panel options for each application (such as NVidia Control Panel)
    I'm betting this is the most likely solution, given that the monitor and video cards I possess have come out years after Fantasy Grounds was even released, since its a 144 hz monitor and I've always got an up-to-date RTX 2080 ti GPU driver. Do you have any inkling of what graphic options would likely be the culprit? Otherwise, this could be anything...

  4. #4
    Hey,
    Nevermind on that. I think I've fixed it. Putting it here just in case someone else comes along looking for a the same solution. Create a Program Specific Setting, then Monitor Technology > Fixed Refresh and Preferred Refresh Rate > Application-controlled. That did it for me. Don't ask me why on some of that. I just assumed since Fantasy Grounds was built on old technology that it was only scale up to 60 hz. Hopefully, that works for others. So far, it's working for me.
    Twitch Channel: PlayForth
    Ultimate License Holder
    Time Zone: Central Standard (Daylight Savings) Time: GMT -6:00 (-5:00)
    Fantasy Grounds Address/Alias: able castle cruel gate

    Currently Running...
    Claim the Stars | Savage Worlds Sci-Fi Campaign (Livestream at PlayForth)

  5. #5
    Thanks for letting us know the resolution.

    Regards,
    JPG

  6. #6
    I'm glad I came across this thread!

    I also have a 144 HZ/Gsync monitor with a 2080 card. When starting FG Classic, the screen would slowly 'bleed' horizontally. It appears as if the screen moves from left to right and pixels were leaving traces. After about 10 seconds, I couldn't read text. (This doesn't happen with FG Unity by the way).

    Up until now I got past this problem by enabling the 'cross-platform mac and linux compatibility mode' in the settings, which stopped this effect. However, this caused slight screen flicker that was tiresome on the eyes after awhile.

    So I tried the suggestion here of changing the refresh rate for the FG application within the NVidia Control Panel but it didn't change anything for me, the bleed effect was still happening (though at a slower rate). However, I went through every Nvidia option and found the one that was causing my problem: Image Sharpening. Turning this to OFF fixed the bleed so I can run without enabling the 'Mac and Linux compatibility mode' and so I don't have screen flicker.

  7. #7
    LordEntrails's Avatar
    Join Date
    May 2015
    Location
    -7 UTC
    Posts
    13,501
    Blog Entries
    9
    Quote Originally Posted by ironsplitter View Post
    ... However, I went through every Nvidia option and found the one that was causing my problem: Image Sharpening. Turning this to OFF fixed the bleed so I can run without enabling the 'Mac and Linux compatibility mode' and so I don't have screen flicker.
    Thanks for letting us know

  8. #8
    Rylan Storm's Avatar
    Join Date
    Apr 2020
    Location
    Derbyshire, England
    Posts
    44
    Quote Originally Posted by cyphus5 View Post
    Hey,
    Nevermind on that. I think I've fixed it. Putting it here just in case someone else comes along looking for a the same solution. Create a Program Specific Setting, then Monitor Technology > Fixed Refresh and Preferred Refresh Rate > Application-controlled. That did it for me. Don't ask me why on some of that. I just assumed since Fantasy Grounds was built on old technology that it was only scale up to 60 hz. Hopefully, that works for others. So far, it's working for me.
    Thank you sooooooo much!
    www.accidentaldm.com - The diary of a Newbie DM

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
PF2E Playlist

Log in

Log in