Page 16 of 18 First ... 61415161718 Last
  1. #151
    Advanced Player's Guide is fantastic, I definitely want it
    The past is a rudder to guide us, not an anchor to hold us back.

  2. #152
    Good morning

    The 1.08 is out according to the updates in the City Watch forum and I was quite excited to get it, but now I am more frustrated than before. I am not sure what I got. I even moved to the Test branch just to confirm that this is the same (and it is). I also went to extremes and deleted the .dat files to ensure nothing is wrong with the file itself. I really don't have time to verify if each fix is working, but several things I noticed that leads me to believe that something is not right with the way updates are pushed or maintained.

    Before I list the problems I found, I still want to thanks for the improvements - changing the initiative for example on the CT.

    • The chat box states 1.07 as version. I know this is text in the XML but still is confusing.
    • The stated NPC, Races and Traits buttons are not available, it is still text on diamond-shaped border
    • The NPC creation is still problematic (more on that below)


    I have no opportunity to test if the abilities and mystical powers work properly.

    The biggest problem for me is the NPC dialog. What I have issues with and I hope it is just me not using it properly:
    • I still have to create blank ability using the + button before I can drag and drop something from the library. Even on unlocked sheet.
    • I am unable to put ranks in ability that is dropped, I must lock-unlock the sheet first (it was like that in the PC sheet). Unfortunately, when I attempt to put rank, no matter what I do I am getting script error: Script Error: [string "scripts/abilitylist_checkbox.lua"]:107: attempt to call field 'onUpdate' (a nil value)
    • When I assign attributes to a NPC, unless I am using the tab key to move to the next attribute, the character sheet is not calculating the modifier. This causes problems with the weapons and their to-hit value. I can't type number, mouse-click the next, type number etc. have to use tab. It is not problem to use tab, just reporting this bug.
    • When I modify an Accurate attribute after I have a weapon assigned, the new value is not taken into account in the "To Hit". This makes impossible to rework a NPC without re-creating its weapons completely.
    • When I drag custom NPC to the combat tracker, the damage field of the weapon is empty. When I try to click it, I get script error: Script Error: [string "scripts/manager_action_damage.lua"]:351: attempt to perform arithmetic on field 'modifier' (a string value). Obviously, it shouldn't be null, as in the sheet I have 4, 6, 8 and etc as flat damage.
    • Racial category string of custom NPC is not taken into account in the filtering dialog of NPC library. I must select (Empty) to appear in the filter. I am using the same string as the other NPCs. After experimenting, it seems that the categorization is done on the XML files rather than the NPC sheet and it does not matter what I write.
    The past is a rudder to guide us, not an anchor to hold us back.

  3. #153
    I can confirm Valyar's post that I just updated FG today July 5th 2019 @ 1842 CST and when launched FG is still saying Symbaroum 1.07.

    Really hoping then issues get fixed so I can start running some games as my local scene is kinda lame and FG is my only outlet to run other games like Symbaroum....

    Thanks guys and keep up the great work....
    Sell you my soul?...What makes you think I still own it!

    Ultimate License Holder!

  4. #154
    The 1.08 is now rolled out and I am very happy with the progress. The NPCs can now be created without issues and at least I can proceed with the homebrew adventure I am planning. There is some regression and I have to report some new bugs that are problematic (as always, screenshot attached):
    • When PC or NPC is dragged to the combat tracker, the abilities are zeroed unless the campaign is reloaded. This is for custom and library-based NPCs and PCs.
    • Even if I reload the campaign, it seems that the modifiers for Defense based on Quick for example is not taken into account and Kvarek is rolling against Def 0 even if the targeted enemy has Quick of -3 or more. There is some issue with the rolls, I can't replay all possible scenarios though.
    • There is script error when damage is rolled, related to manager_action_armor.lua. Rolling damage against target does not work.
    • When I expand a NPC in the Combat Tracker and I click the link to its Trait or Ability, so I can remind myself what the hell it is doing, it is no longer opening the proper article. Every trait or ability is opening blank window of the same category, as shown in the screenshot with the Poisonous. If I open the link from the NPC library or PC sheet everything is OK. Something breaks when an instance of the NPC is copied to the Combat Tracker.
    • There is some graphical glitch when PC/NPC is targeted but the "Target" category in the combat tracker is hidden. I highlighted this in the screenshot as well.

    The attack modifiers are still not amended when attribute is changed.

    PS: I love the new Races and Traits icons... hilarious Maybe for the Abilities button you can put something similar to the "flex biceps" emoji.
    Attached Images Attached Images
    Last edited by Valyar; July 10th, 2019 at 07:41.
    The past is a rudder to guide us, not an anchor to hold us back.

  5. #155
    Any update planned to address the critical bug with the CT?
    The past is a rudder to guide us, not an anchor to hold us back.

  6. #156
    Hey guys,

    So sorry about this! I haven't received any notifications for this thread so I assumed that everything was going well and was having a nice summer. I'll look into these issues ASAP and will make sure to hand you guys fixes as soon as possible. Sorry for the inconvenience!

    Cheers,
    Simon

  7. #157
    Hi,

    Just wanted to follow up with progress:

    Valyar: Thanks a ton for reporting the bugs - as usual! Extremely helpful!

    NPC Creation : Some of these were fixed in 1.08 which I think you got patched after the posting - but I'll go through them anyway!

    * The + for adding abilities should no longer be needed as of 1.08
    * Dropping ranks onto a sheet can be done even if it's not set to writeable (maybe I should change that?). Changing level of abilities is only possible if the sheet is unlocked. However, if the sheet is unlocked and you drop an ability onto it - it should be possible to change the level of it directly as of 1.08.
    * onUpdate crash should be fixed as of 1.09
    * Attributes should be applied when the element loses focus now, not only when using tab.
    * Weapons/equipment should be correctly updated after changing accurate (or any stats) as of 1.09.
    * Damage fields on NPC's weapons in CT should now be correctly calculated from its instance, and not cause the crash you describe. (the reason of the crash is that the value was somehow not copied/updated correctly).
    * Racial category thing is separate from actual race, which is why you're seeing this issue. This will unfortunately be patched in 1.10.


    * The zeroing of attributes has been reproduced and fixed.
    * The modifiers for defense based on quick is not taken into account I have not been able to reproduce. I did this after the zeroing of attributes fix though,
    * I could not reproduce the rolling of damage vs targets. I'm not sure what you're seeing but maybe this is if you're trying to fight something without armor. I'll try to look into this and see if I can find a solution tonight!
    * The graphical glitch for targeting when not expanding all - I've tried to solve this previously but it seems to be how CoreRPG handles things. If anyone has any solution to it, I'd gladly accept help with it!

    I'll continue to work on these fixes tonight and send a patch to SW before heading off to bed. Hopefully this should be up on the test branch within a day or two!

    Thanks
    Simon

  8. #158
    I think due to the criticality of the CT bug, the update once confirmed that works should be pushed to the production server
    The past is a rudder to guide us, not an anchor to hold us back.

  9. #159
    Yes agreed! I'll make sure that SW gets that info - thanks for the reminder!

  10. #160
    Hey all,

    I just pushed a new patch to SW. Here is the changelist for 1.09:

    FIXED:
    * Traits & Abilities were not correctly editable for dropped abilities/traits onto npc's.

    * NPC Equipment received no name in CT.

    * Script crash when trying to deal damage to something without an armor

    * Npc's weapons not updating correctly when the associated attributes are updated.

    * Script crash when dropping the wrong things into the CT

    * Attributes were not updated correctly for NPC's and players when dropping them into the CT.

    * NPC's stats were not correctly updated even when losing focus but only on tab movement.

    * Iron fist, natural weapon and alternative damage were applied wrong or not at all.



    I've also updated the Copper Crown with the following patch notes:

    FIXED:

    * Missing thumbnail

    * Items were not listed correctly in the library

    * Some categories were incorrect

    Please evaluate the ruleset if you can on testing once it's patched and/or on live. If I don't respond within 24 hours - just ping me on the discord server as Simpe.

    Cheers,
    Simon

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

Log in

Log in