Page 7 of 9 First ... 56789 Last
  1. #61
    damned's Avatar
    Join Date
    Mar 2011
    Location
    Australia
    Posts
    20,340
    Blog Entries
    1
    There was one... I was conversing with him semi-regularly up to about a year ago but they have since gone quiet...

  2. #62
    Quote Originally Posted by Felcelot View Post
    MoreCore Rolls work. And yeah, just like you described, only in the context of the character they belong to. That's all good.

    The issue is with macrobar. This happens independently of the type of roll.
    Here is my repro steps:

    1) Drag and drop die into slot on macrobar.
    2) Click on macrobar.

    Observed behavior:
    Immediately after click two separate rolls appears in chat area. Their results reported separately. Just the same as if I would roll same die twice.
    If I substitute simple die for a MoreCore roll dragged from PC sheet, same thing happens. Chat reports that PC made two separate rolls with it's results and names.

    AFAIR, behavior doesn't change whether CTRL, SHIFT or ALT are pressed.

    Same happens when my player do that.
    damned, superteddy57 so, I was a bit wrong.

    First: yeah, MoreCore rolls doesn't work on macrobar, just as you said. I mixed it up with attribute check roll, from sotdl extension charsheet.
    In both cases it rolled twice in a row with one click on the bar.

    Second: I tried to reproduce it on different ruleset and without sotdl extension. Here is what I found:

    - MoreCore with SotDL: reproduces.
    - 5e ruleset without extensions: doesn't reproduce.
    - MoreCore without any extension: reproduces.

    So, either it's something wrong with my environment. Although, I didn't make any changes to MoreCore ruleset.
    Or it may be something up with MoreCore.

    My MoreCore version is 1.52 20200115.


    Quote Originally Posted by Moon Wizard View Post
    The current answer is that we have publisher permission, but we do not have a community DLC developer who has signed up to take on the project.
    That's actually sounds very appealing to try. What are the requirements?

  3. #63
    One more thing: sometimes boons and banes stuck.

    Like this.

    There is nothing in modifier field. And we were unable to reset them in any way, except from reconnect.

    Any help will be appreciated.

  4. #64
    damned's Avatar
    Join Date
    Mar 2011
    Location
    Australia
    Posts
    20,340
    Blog Entries
    1
    It is a bug.
    It is something that has been there for a long time.
    If you can work out how to replicate the issue everytime then I might be able to fix.
    Right now I think when it happens you have to restart the session....

    MoreCore - Generic Ruleset
    --- Projects ---
    Extensions | Tutorials | MoreCore | MoreCore Themes | Call of Cthulhu | Maelstrom | FG Con

  5. #65
    Quote Originally Posted by damned View Post
    It is a bug.
    It is something that has been there for a long time.
    If you can work out how to replicate the issue everytime then I might be able to fix.
    Right now I think when it happens you have to restart the session....
    I see, thanks. I'll keep an eye on it.

  6. #66
    Quote Originally Posted by Felcelot View Post
    I see, thanks. I'll keep an eye on it.
    FWIW, I experienced it on occasion as I was in the early stages of setting up my campaign, but at some point ... it just stopped happening. I have no idea what is triggering it, but hopefully you have the same experience I did and it goes away.

  7. #67
    I know you more or less put this in maintenance mode SuperTeddy, but today's MoreCore update broke the Abilities button you created for this extension. Any chance of getting a fix?

  8. #68
    Updated first post with changes to get abilities working. I'll relay this to damned as it appears to be a MoreCore issue than the extension. Not sure if removing abilities was intended. They are back in the extension currently. Let me know if you see anything else like this.

  9. #69
    Hmm. I'm still not getting them to work. Screenshot (88).png

  10. #70
    I'm unsure of the original name used in past versions of MoreCore and went with the name used in the latest update. So they may work, but won't display old ones due to the type mismatch now. Did you happen to export your abilities to a module? If so, can you post them and I can try to do a type match in the library to see if I can get them to display.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

Log in

Log in