1. #1

    Sharing too much.

    I'm having a problem with sharing image files in that all the images in the folder are instantly shared no matter what. This makes so many files for my players they can't load into the game and have connectivity issues. I unshared all of them, closed the game, opened it back up, and they're all shared again ( There's a symbol with a P in it). Other games I host don't do this and I have a LOT of work put into this campaign I don't want to start another one to fix this problem.

  2. #2
    Zacchaeus's Avatar
    Join Date
    Dec 2014
    Location
    Scotland
    Posts
    9,886
    Hi Feoral, welcome to FG.

    In your campaign chat box, with no players connected, type /flushdb and press return.

    Before your players rejoin your game have them nuke their cache (small nuke button on the top right of the start screen).

    This will clear out all shared material on both sides of the equation. Note also that it is good practice to unshare images, especially large maps, once they are no longer required for the campaign.
    If there is something that you would like to see in Fantasy Grounds that isn't currently part of the software or if there is something you think would improve a ruleset then add your idea to the wish list http://fg2app.idea.informer.com/

  3. #3
    To add to this, clicking on the "P" will unshare that specific asset.
    Ultimate License - You Do Not Need A License To Play In My Games.
    Games: Savage Worlds, Cypher System, Genesys, WOiN, D&D 5E
    Server Alias: Huge Echo Huge Echo

  4. #4
    I've had this as a bug in a couple of games in the past in SW. Where everything became shared as soon as it was created, be it images, notes, story entries etc.
    Never did find out exactly what caused it.

    In order I'd try the following:
    1) Pressing P to unshare, restart, see if it holds. [didn't for me when the bug appeared]
    2) I'd try /flushdb as suggested by Zaccheus above. [in my case removed all the shares, but again on restart still the same, with everything shared]
    3) Manually editing the db.xml file (make backup first) and saving, removing all the shared xml tags in the text. You can do a find and replace search (replacing it with an empty string) through the whole db.xml file to do this. [this is what finally worked for me, and removed the bug, so as a guess it would seem as this is related to some error entry by FG into the xml file at some point]

    This is a rare error to come up. In both cases it happened was after I had manually entered hundreds of story entries and items to the db for that game.
    Last edited by Styrmir; February 19th, 2019 at 10:47.
    Ultimate License holder, enables Demo Players to join my games for free.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

Log in

Log in