1. #1

    FG not working with GPU

    Greetings,
    I'm on a Windows 10 PC (Build 17134.471).
    Yesterday I started Fantasy Grounds and it updated to 3.3.7. It worked until the updater window closed and it gave me two errors: "CheckDeviceType failed! Error code 16" and a following "Could not initialize graphics system!", repeating that every time I try to start Fantasy Grounds. The updater still works with no errors.

    I've found several posts on this forum about this kind of issue and I've tried to:
    - reboot the system;
    - reinstall Directx 9.0c;
    - rollback GPU drivers several times;
    - reinstall GPU drivers;
    - resintall Fantasy Grounds;
    - uninstall last Windows updates;
    - uninstall last software updates;
    - deactivate antivirus;
    but so far I haven't got any good results.

    I noticed that if I start Fantasy Grounds with no GPU drivers (I have a ASUS ROG Strix GeForceฎ GTX 1080) it works perfectly, however this was not the problem until yesterday, and nothing changed since 18 December 2018 because I went on holiday and came back yesterday.

    Is there a solution for this issue?
    Thanks!

  2. #2

    Join Date
    Apr 2008
    Location
    Virginia Beach
    Posts
    2,715
    I think sometimes toggling the setting of compatibility mode can make a difference. It is also possible your computer installed a windows update while you were gone (depending on how your update settings are set) and that is the culprit (but if you actually uninstalled windows updates that should have eliminated). Windows updates are notorious for changing system settings without your knowledge or appproval.
    Other than that, I have no new ideas.
    You might try restoring your entire machine to a state when you know it last worked and then updating FG again. That should eliminate a spurious system update completely.

  3. #3
    Here are a few things you can check:

    * Make sure to disable any GPUs that you are not using. (i.e. motherboard graphics vs. separate graphics card, alternate display applications (such as Duet Display), etc.)

    * Try installing DX 9.0c from Microsoft's website.
    https://www.microsoft.com/en-us/down....aspx?id=34429

    * Try alternate versions of the manufacturer's drivers.

    Regards,
    JPG

  4. #4
    Hello,

    Duet Display seems to cause problems with Fantasy Grounds. I uninstalled it and now FG seems to work stable.
    It's weird because I used Duet along with FG many times in the past year.

    Thanks for your support.

  5. #5
    LordEntrails's Avatar
    Join Date
    May 2015
    Location
    GMT -7
    Posts
    6,542
    Blog Entries
    9
    Yea, I used to use something similar to Duet, forget what it was called,but was for my Dell USB dock. It updated at one point and I couldn't run any OpenGL programs. It was a pain to figure out. Glad you got it sorted!

    Current Projects: Ultimate Undermountain (NYDUM)
    Community Contributions: Gemstones, 5E Quick Ref Decal, Adventure Module Creation, Dungeon Trinkets
    DMsGuild Content: Balance Disturbed (Adventure), Dungeon Room Descriptions
    FG Product Reviews: Virtual Scribe Reviews

  6. #6
    Thanks for this thread! I happened to have this same issue on two PCs tonight, and the only thing in common is that they both had Duet Display installed. Uninstalled Duet Display and FG worked just fine now!

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

Log in

Log in