Page 7 of 7 First ... 567
  1. #61
    Quote Originally Posted by Valerian Stormbreaker View Post
    That's an easy fix too. I can use WinMerge to identify the differences between AE and WH and run the AE code if it is enabled.
    Wait! Maybe I got it. Is the host renaming the extension file? Is the name different from "AdvancedEffects.ext" ?
    My twitch channel


    Currently DMing:
    D&D 5e - "Waterdeep: Dragon Heist"

    Language: Italian

  2. #62
    Quote Originally Posted by Valerian Stormbreaker View Post
    We did test it. However, if you truly want to exclude AE code when it is not loaded, then drop this into the extension! It is a version of the char_weapon.lua that does what you want. I already did preliminary testing with these new changes.
    Ok I see. I totally miss those if statements for the strength stat earlier. Probably those have been added later in the Advanced Effects extension.

    The problem will still be there if the AdvancedEffects file is renamed but I guess it's ok for now.
    My twitch channel


    Currently DMing:
    D&D 5e - "Waterdeep: Dragon Heist"

    Language: Italian

  3. #63
    Quote Originally Posted by st4lk3r87 View Post
    Wait! Maybe I got it. Is the host renaming the extension file? Is the name different from "AdvancedEffects.ext" ?
    No. The name of the extension remains the same. Even on my system I was having problems running both of them together because both extensions override the char_weapon.lua script used by the char_weapon windowclass.

    <windowclass name="char_weapon" merge="join">
    <script file="campaign/scripts/char_weapon.lua" merge="replace" />
    ...
    </windowclass>

    This is what is causing the problem. So, I merged AE's code into the char_weapon.lua file used by WH because WH loads after AE. The char_weapon.zip file I posted does what you want. It excludes the code ran by AE when it is not loaded. I only zipped the char_weapon.lua file. Check it out!

    There were certain effects in AE that are not being processed. That is why it seems to work for you if you didn't test those specific effects. However, if you look at the code I posted in the .zip file, you will see where these effects get broken if the AE code isn't merged into the WH code.

    Search for the variable m_bAdvancedEffects in the zipped up char_weapon.lua script. You'll see where the AE code is being ran if the AE extension is running.
    Last edited by Valerian Stormbreaker; July 18th, 2019 at 21:56.

  4. #64
    Quote Originally Posted by Valerian Stormbreaker View Post
    No. The name of the extension remains the same. Even on my system I was having problems running both of them together because both extensions override the char_weapon.lua script used by the char_weapon windowclass.

    <windowclass name="char_weapon" merge="join">
    <script file="campaign/scripts/char_weapon.lua" merge="replace" />
    ...
    </windowclass>

    This is what is causing the problem. So, I merged AE's code into the char_weapon.lua file used by WH because WH loads after AE. The char_weapon.zip file I posted does what you want. It excludes the code ran by AE when it is not loaded. I only zipped the char_weapon.lua file. Check it out!

    There were certain effects in AE that are not being processed. That is why it seems to work for you if you didn't test those specific effects. However, if you look at the code I posted in the .zip file, you will see where these effects get broken if the AE code isn't merged into the WH code.

    Search for the variable m_bAdvancedEffects in the zipped up char_weapon.lua script. You'll see where the AE code is being ran if the AE extension is running.
    Ok, could you give me an example of the bug? What effects doesn't work? I'm curious to see if there's a better solution to propose to the creator of AE.
    My twitch channel


    Currently DMing:
    D&D 5e - "Waterdeep: Dragon Heist"

    Language: Italian

  5. #65
    Quote Originally Posted by st4lk3r87 View Post
    Ok, could you give me an example of the bug? What effects doesn't work? I'm curious to see if there's a better solution to propose to the creator of AE.
    Intruder tested the problems he was having and they are gone. I asked him what they were exactly, but they are caused because you missed some of the AE code. In the image below, which is from the new code I posted in the char_weapon.zip file, the left pane contains the code fixes I made, the right pane contains your original code:

    Last edited by Valerian Stormbreaker; July 18th, 2019 at 22:12.

  6. #66
    Quote Originally Posted by Valerian Stormbreaker View Post
    Intruder tested the problems he was having and they are gone. I asked him what they were exactly, but they are caused because you missed some of the AE code. In the image below, the left pane contains the code fixes I made, the right pane contains your original code:
    Yes I got it but I'd like to know what could cause the rAction.stat from being empty and why the Advanced Effect need that. Well nvm! The important part for now is to have a working extension I just uploaded and updated the first post.
    My twitch channel


    Currently DMing:
    D&D 5e - "Waterdeep: Dragon Heist"

    Language: Italian

  7. #67
    Quote Originally Posted by st4lk3r87 View Post
    Yes I got it but I'd like to know what could cause the rAction.stat from being empty and why the Advanced Effect need that. Well nvm! The important part for now is to have a working extension I just uploaded and updated the first post.
    Once Intruder gets back to me, I'll let you know what effects were broken so you can test 'em. When code is missing, things don't work. So, when I noticed that the char_weapon.lua file was being overridden, I knew that the AE code needed to be merged into the WH code. Intruder did mention what the problem was originally, but that was a few moons ago...
    Last edited by Valerian Stormbreaker; July 18th, 2019 at 23:25.

  8. #68
    Hey Guys, This is the issue I was having....

    I use Advanced Effects for placing Global and Item-Specific Effects, such as Racial and Archetype effects Globaly and any type of effect that is dependent on the Weapon/Item being used.
    The Item dependent effects would work during testing when I, as DM, activated them, but in practice players could not get them to work, though Global effects did.

    What I found was that disabling WH allowed item effects to function correctly. Valerians patch corrected the problem.

    The other issue was Theogeeks most recent update prevented the IMMUNE and RESIST effects from working. After informing him of this, he re-posted a corrected version.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

Log in

Log in