Page 67 of 79 First ... 1757656667686977 ... Last
  1. #661
    @Axoid

    The error messages and your reply tells me that it's not finding what it's looking for in the campaign XML (db.xml).
    The code looks for a standardized xml entries similar to that which are created when items are added from the Players Handbook. So if the entries are custom made, they might also not fit this setup and thus again the regular expression would fail if it's not done similarly.
    So it does make sense that removing and re-adding the items would rewrite them into the campaign database and thereby fix the problem.

    Spells are written somewhat differently into the database, so it could be that they had the xml needed in place, where as the weapons simply didn't. They again depend on a standarized entry.

    Just to make sure, this doesn't happen again each time you start the campaign right, after having deleted and added the items back in the time before? That is you have a permanent fix you figured out?
    Last edited by Styrmir; August 4th, 2019 at 22:57.
    Ultimate License holder, enables Demo Players to join my games for free.

    [FGU backer, extension writer]

    5E Enhancer

    Combat Enhancer 5E Classic





  2. #662
    @HuseyinCinar

    Don't have a mac myself, but googling found me this to check memory:
    https://www.wikihow.tech/Check-Memory-Usage-on-a-Mac

    The error message would indicate it's linked to pinging the map. (shift + left click / shift + control + left click). It seems to be unable to catch the window instance and thus do further work on it. Aka. ping etc.

    I opened up my test campaign, with a secondary FG connecting to it. Found the Nightstone map and added it and some grids with players and monsters on it. Sharing and pinging produced no errors despite it being a large map.

    Try making a new campaign, loading up Storm King's Thunder and the same map with only the Combat Enhancer and Token Helper loaded. See if you get the same problem.

    Last time I saw this happen was over half a year ago (no pinging involved, just loading up the map). When it was happened, it kept happening to certain players (one in particular), and myself sometimes. In my case the memory usage was hovering around the 3GB range when it happened.
    After I stripped down loaded assets to drop the memory usage to a safer level (FG starts breaking around 3GB) the problem stopped.

    ps. My test campaign has a minimal load of under 1GB memory usage. Of course a fully running campaign will have more, but try to make sure to leave some wriggling room below 3GB. Opening an image, particularly a large one will be much larger in memory than on the hard drive, due it becoming un-compressed on load.
    Ultimate License holder, enables Demo Players to join my games for free.

    [FGU backer, extension writer]

    5E Enhancer

    Combat Enhancer 5E Classic





  3. #663
    Correct, removing/adding the item back fixes the issue. These were not custom items, just normal stuff pulled from the PHB. I'll just move forward with replacing all ranged weapons. Thanks.

  4. #664
    The only thing I am still having an issue with is the clear saves button doesn't do anything. I click it to try and clear the X or check, and nothing happens. It doesn't even feel like the button is 'active' if that makes sense.

  5. #665
    I was more talking about the automatic removing of multiple conditions. As I've got several conditions that are stackable.

  6. #666
    @Axoid

    Good to hear.

    Never had any issues with clearing saves on my end, nor any error messages related to it. Only thing I can think of is to try it on the different layers. The button itself has no indicator to it, it should be light grey all the time.
    Overall I just click it after someone has made a save on the top layer (where the players are), and a green check mark or red x appear, and it clears it.

    That aside, same procedure as above, if you want to file another error report to give me the information I need to try to start narrowing down the issue.




    Bug Report

    Describe your error/bug in as much detail as possible:

    Is your FG software up to date?

    Do you have the latest version of both extensions installed?
    (You can see the most up to date version numbers in the first post on page 1, the version numbers are printed in FG on start in the chat.)

    How much memory is Fantasy Grounds using while the error occurs? (You can check this in the Task Manager if you're using Windows)

    Please post the console error printout here:
    (This is the error log window text. It can be opened by typing '/console' in the FG text window if it didn't open by itself. Also if there are no output errors, state that here.)

    If you create a new (clean) campaign, does the error still occur, with ONLY the 5E Combat Enhancer and Token Helper extensions enabled?

    Can you recreate the error consistently?

    What are the precise steps to recreating the error?

    Does this always happen?

    Does this only happen when using a specific module, map, NPC, PC, weapon, etc.?
    (The more in depth information on which these are the better.)

    Do you have a screenshot you could share?

    Any further information that could help to replicate and trace the error?
    Ultimate License holder, enables Demo Players to join my games for free.

    [FGU backer, extension writer]

    5E Enhancer

    Combat Enhancer 5E Classic





  7. #667
    @StarDrifter

    Not possible in the current code. The way it works now is that it compares the full condition text to that on the CT, if it's there it removes it, if not it adds it.
    Removing all of them would require new code entirely. As it's not something that you all that frequently, at least I don't. And as it's quick to do it manually in the CT I don't feel the need for that as an improvement at this stage.
    Ultimate License holder, enables Demo Players to join my games for free.

    [FGU backer, extension writer]

    5E Enhancer

    Combat Enhancer 5E Classic





  8. #668
    Damn was hoping for a quick and easy. Well, like you said, it's not that big of a deal and the extension is super fabulous anyway. Thanks for answering. Keep up the fantastic work.

  9. #669
    Uh oh, should have not updated on game night, getting a version compatibility error from today's patch.

  10. #670
    Quote Originally Posted by garr71 View Post
    Uh oh, should have not updated on game night, getting a version compatibility error from today's patch.
    I'm getting no errors.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

Log in

Log in