Page 2 of 2 First 12
  1. #11
    midas's Avatar
    Join Date
    Jun 2015
    Location
    Michigan, USA
    Posts
    265
    Just to be clear--you won't connect to them, they'll connect to you. You'll launch the campaign, and they'll join your game. Are you saying only one of them can connect to you (either via direct IP or an alias) but the other can't? If so, start with JohnD's question above:

    - What does it say in the upper-right corner next to the version number?
    - What happens when the second user tries to connect to you (error, etc)?

  2. #12
    So to reiterate I (the GM) am trying to connect my friends out of state who are room mates. We all have fully updated FG and are getting connection errors saying to check our settings and host adress. I tried having the two room mates player start a game on one of their computers while the other room mate uses the internal IP and I use the External IP to no avail. I am actually unclear on how to use the alias as well so if somebody could explain that to this noob it would be appreashiated.

  3. #13
    Zacchaeus's Avatar
    Join Date
    Dec 2014
    Location
    Scotland
    Posts
    10,166
    First thing to check is that your network is set to private and not public. Then make sure that you have set up an exception in your Anti Virus for Fantasy Grounds. If neither of those is the problem you will need to forward port 1802 in your router pointing to your computer’s internal IP address. How you do that will depend on your router.

    You create an alias by clicking on the create alias button on the new campaign start screen. This will generate 4 random words which you give to your players, when they join a game they type those 4 words exactly as they are in the right hand box in the join screen. You only need to do this once.

    If after all of the above has been tried and if you still can’t get players to connect can you post a screenshot of a tracert 8.8.8.8 so we can diagnose further.
    If there is something that you would like to see in Fantasy Grounds that isn't currently part of the software or if there is something you think would improve a ruleset then add your idea to the wish list http://fg2app.idea.informer.com/

  4. #14
    midas's Avatar
    Join Date
    Jun 2015
    Location
    Michigan, USA
    Posts
    265
    It sounds like you're trying to connect to your players, which you don't want to do--the GM (you) hosts the game, and the players connect to you. The only person that needs to worry about the connectivity tests or aliases or port forwarding is you, the GM.

  5. #15
    For anybody in the same house as the GM, they should use the internal IP (neither alias or external IP will work). If all the players are in the same house, then port forwarding and the connection test is not needed.

    If anybody is connecting from external, then the GM (and only the GM) will need to have port 1802 forwarded from their Internet connection point to their computer, which is what the Test Connection button checks. For these players connecting from the Internet, they would use the external IP (or alias, if enabled).

    If the Test Connection button doesn't work, check these things:
    * Network connection on Windows set to Private (not Public)
    * Windows Defender and any other security programs have explicit rules allowing Fantasy Grounds access to Internet

    If it still doesn't work, then posting the results of a trace route utility from the GM machine can help diagnose any network configuration considerations.
    * Run a trace route by entering "cmd" in the Windows search bar, press Enter, then type "tracert 8.8.8.8" in the command prompt window.
    Then, paste the results here.

    Regards,
    JPG
    Last edited by Trenloe; December 17th, 2018 at 10:20. Reason: Clarified using the internal IP address

  6. #16
    Trenloe's Avatar
    Join Date
    May 2011
    Location
    Denver, Colorado, USA (for a bit)
    Posts
    22,024
    @GenisDraco - to clarify: if you are the GM then the players connect to you. You don’t try to connect to them.

    Try these steps (summarizing what people have already been saying):
    1) Open Fantasy Grounds. Create a new campaign - make a note of the External Address on the new campaign screen. Click the connection test button. Does this pass or fail? If it fails then players won’t be able to connect to you as port forwarding is not setup. To help us start to troubleshooot your issue, Please run the following command from a Windows command prompt and post the results here: tracert 8.8.8.8
    2) If the connection test shows success then click the “start” button to load your new campaign.
    3) Wait for Fantasy Grounds to fully load, then ask your players to use “Join Game” with the server address you made a note of in step #1 above.


    FG Product Development status: Pathfinder Playtest Ruleset and add-ons: In development. Pathfinder Bestiary, Pathfinder Bestiary 2, Pathfinder Bestiary 3 (in store).

    Private Messages: My inbox is forever filling up with PMs. Please don't send me PMs unless they are actually private/personal messages. General FG questions should be asked in the forums - don't be afraid, the FG community don't bite and you're giving everyone the chance to respond and learn!

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

Log in

Log in