Joshua Stream Pre
Page 22 of 22 First ... 12202122

Thread: 13A Bug Reports

  1. #211
    I'll do some experimentation and get back to you. If we could only see the code ourselves, it would be easier to track down...

  2. #212
    I think I've isolated the problem - it seemed to be triggering the error if I had assigned an implement to attack/damage power action. When I remove those, it works fine.

    I have the implement listed at the top of the window as the default one, so I hope it will still pick up the magic item bonus from there.

  3. #213
    I don't fully understand your description, can you provide an example?

    EDIT: I see the "Imp" box for attack/damage actions. But I can't repro the error you're seeing. An example would be helpful.
    Last edited by darrenan; June 29th, 2021 at 17:28.

  4. #214
    Ok, I got a repro finally. I need to add some tooltips to the controls. I'm still learning how a lot of this stuff works in 13th Age and it was totally unclear to me that the "Imp" control is an index back to items on the Combat tab. I thought it was just a flat bonus field.

  5. #215
    Fix has been checked in and marked for hotfix. Not sure if it will make today's update, or later this week.

  6. #216

  7. #217
    So this week, we ran into a bunch of errors, which kind of stopped everything. So first, regular weapons work fine, and effect applying does as well, but doing any attack or damage power throws an error instead without any resolution. That happens for both GM and player. In particular, this is the error in the console log:

    [7/30/2021 2:48:56 AM] [ERROR] Script execution error: [string "campaign/scripts/manager_char.lua"]:1647: attempt to index local 'nodeFocus' (a nil value)
    [7/30/2021 2:48:58 AM] [ERROR] Script execution error: [string "campaign/scripts/manager_char.lua"]:1647: attempt to index local 'nodeFocus' (a nil value)
    [7/30/2021 2:48:59 AM] [ERROR] Script execution error: [string "campaign/scripts/manager_char.lua"]:1647: attempt to index local 'nodeFocus' (a nil value)
    That is without any added extensions running, which I thought may do something.

    I also note I get some of this in the log:

    [7/30/2021 2:48:15 AM] [WARNING] Could not load script file (13th_Age) (Desktop13a) (scripts/data_desktop_13a.lua)

    [7/30/2021 2:48:18 AM] [WARNING] Frame desktop contains out-of-range values in Decal.

    [7/30/2021 2:48:49 AM] [WARNING] Frame tabs contains out-of-range values in BottomLeft.
    I don't think the latter two relate at all, and unsure if the first is relevant. I note that also there were some extra errors when using the wizard desk theme (also shout out to whomever designed that, as it looks super cool).
    [7/30/2021 2:55:16 AM] MEASURE: RULESETS LOAD - 6.1079893 - 13th_Age
    [7/30/2021 2:55:16 AM] [WARNING] font: Font (idactivefont) defined with merge attribute, but asset name does not match existing asset. [SWKTHEME_WIZARDSDESK] [graphics/graphics_fonts.xml]
    [7/30/2021 2:55:16 AM] [WARNING] font: Font (idinactivefont) defined with merge attribute, but asset name does not match existing asset. [SWKTHEME_WIZARDSDESK] [graphics/graphics_fonts.xml]
    [7/30/2021 2:55:19 AM] [WARNING] font: Could not find TTF font file. (SWKTHEME_WIZARDSDESK) (graphics/graphics_tabs.xml) (graphics/fonts/Open_Sans/OpenSans-Regular.ttf)

    (other loadings)

    [7/30/2021 2:55:40 AM] [WARNING] Frame dicetower_normal contains out-of-range values in Middle.
    Thank you for the continued work! Let me know if you need any other specific info about this.
    Attached Files Attached Files

  8. #218
    I have just pushed fixes for the 'nodeFocus' errors, the missing script file warning, and the frame out-of-range warnings. I have marked this as a hotfix since it is blocking crucial functionality so a new build should be pushed today or tomorrow. The new reported version will "v2021-07-30"

    I don't own the Wizard's Desk theme, so I can't troubleshoot that one.

    dicetower_normal is defined in CoreRPG and neither 4E nor 13th Age layers changes it in any way. Does the Wizard's Desk theme change the dice tower? That might be the cause of that one.
    Last edited by darrenan; Today at 21:49.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Fantasy Grounds Fridays Pre

Log in

Log in