Back our Kickstarter Campaign going on Now
  1. #1

    Monster record issues

    I just noticed two separate possible monster record issues:
    1) When using monsters from the parser, saves and action points do not seem to read in properly. They always seem to be set to 0 even though I can see the "saves" and "actionpoints" records in the db.xml (see example below.)
    2) If I edit a monster to add action points, Action Points do not show unless Saving Throws is also not 0.

    From Elder Red Dragon:
    <saves type="string">+5</saves>
    <actionpoints type="string">2</actionpoints>

    Am I doing something wrong?

    Thanks

  2. #2
    Also, the saves and actions points did not seem to read in even if I changed them to "number" instead of "string". For example this did not work either:
    <saves type="number">5</saves>
    <actionpoints type="number">2</actionpoints>

  3. #3
    The easiest way to make a monster module within FG is to build the NPCs directly in the interface in a separate campaign, and then export the NPC data to a module for use in other campaigns. Keep the module campaign handy, in case you want to update the module later.

    If you really have to muck around in the XML, the best way to figure out what you need is to build a few NPCs in a test campaign, exit, and look at the db.xml file in the test campaign folder.

    Looking at my 4E test campaign, I see that those fields are:
    <ap type="number">0</ap>
    <save type="number">0</save>

    Regards,
    JPG

  4. #4
    Moon Wizard, that was exactly it for the first issue. Thank you very much.

    For the second (where Action Points do not show unless Saving Throws are not 0), I forgot to mention that only occurs when the record is locked. Both fields always appear when the record is unlocked.

    Thanks

  5. #5
    They are in the displayed record when locked, but not laid out correctly. I'll add to be corrected in the next patch release.

    JPG

  6. #6
    Fantastic, thank you very much for the excellent support!

  7. #7
    I see the fix was implemented already. Thank you!

    (I did notice one minor thing (that I am not asking to be fixed) is that if monster is displayed from a reference module, the action points still do not show up unless the save is not 0 (e.g., Living Flaming Sphere.) That is, from a module when monster is locked and save is 0 and action points exist, the action points still do not show. But if I copy the record, the save and actions points show even if saves are 0 and the record is locked. I even tried copying exactly what was put in the campaign db.xml for the monster into a module to make sure there were no differences at all and it still did it. Not sure why the difference.)

  8. #8
    Thanks, I've found the issue, and added to the next release. This cycle will be longer, so it may be a couple months before you see a fix.
    Once a creature is added to the combat tracker, all the information is still visible; so it's not urgent.

    Regards,
    JPG

  9. #9
    I see the permanent fix for this is in the 3.3.6 update. Greatly appreciate the exceptional support! Thank you!

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

Log in

Log in