Thread: Update Loop

  1. #1
    Beerbelly's Avatar
    Join Date
    Jan 2016
    Location
    Central Time Zone, GMT -6
    Posts
    74

    Update Loop

    I seem to have an infinite loop of updating. After updating to 3.3.7, Fantasy grounds doesn't want to stop. After it finishes, it loops right back into doing the update again. The only way to get it to stop is to tell it no when windows asks if I want to allow FG to make changes to the computer. I cannot than open FG without it starting the loop again.

    I have uninstalled and reinstalled FG already.

    What can I do next?

  2. #2
    My guess is that your license key is not valid/active. It should report this in the updater status window.

    You can turn on Enhanced Update Logging in FG Settings, and send update.log file from the FG data folder to [email protected]. Then, we can double-check your settings are valid/active.

    Regards,
    JPG

  3. #3
    Beerbelly's Avatar
    Join Date
    Jan 2016
    Location
    Central Time Zone, GMT -6
    Posts
    74
    Is that the update txt file?

  4. #4
    LordEntrails's Avatar
    Join Date
    May 2015
    Location
    GMT -7
    Posts
    7,767
    Blog Entries
    9
    Quote Originally Posted by Beerbelly View Post
    Is that the update txt file?
    the update.log file is a text file. You can open it in Notepad or other text editors.

    Current Projects: Ultimate Undermountain (NYDUM)
    Community Contributions: Gemstones, 5E Quick Ref Decal, Adventure Module Creation, Dungeon Trinkets
    DMsGuild Content: Balance Disturbed (Adventure), Dungeon Room Descriptions
    FG Product Reviews: Virtual Scribe Reviews

  5. #5
    This is the exact thing that has happened to me, I've had FG for years and now when I did the update it just loops. Did the license end up being the issue for original poster?

  6. #6
    Zacchaeus's Avatar
    Join Date
    Dec 2014
    Location
    Scotland
    Posts
    10,857
    Quote Originally Posted by shadowbug View Post
    This is the exact thing that has happened to me, I've had FG for years and now when I did the update it just loops. Did the license end up being the issue for original poster?
    Hi shadowbug, welcome to FG.

    We don't know, but if you are having the same issue and you have made sure that your license is correct and in the correct location and that your username and password are also correct I'd suggest you do the same thing as Moon Wizard advices in post #2 above.

    You probably want to refresh all your credentials (ie delete them and re- enter them) rather than just looking to see if they are ok.
    If there is something that you would like to see in Fantasy Grounds that isn't currently part of the software or if there is something you think would improve a ruleset then add your idea to the wish list http://fg2app.idea.informer.com/

  7. #7
    I had this today. For me it was a license key issue. I have a license key that I've had since 2005 I think, and a couple of years ago, when I subscribed to an ultimate license, the fantasy ground settings window changed my main license to something else and kept my original license in the upgrade license section. This worked fine even after I cancelled my subscription to ultimate, until today. I put my original license back in both license fields and it seems to be working fine now. It even fixed my 'check for updates' button so it isn't red constantly.

  8. #8
    Also for what it's worth I didn't see anything in the update.log to indicate it is a license key problem, even though it seems to be, but I didn't think to save the log I had when it wasn't working.

  9. #9
    damned's Avatar
    Join Date
    Mar 2011
    Location
    Australia
    Posts
    18,865
    Blog Entries
    1
    You should only have your license in the first field.
    The second field is only for the player/lite to full upgrade key.
    Standard to Ultimate does NOT go here.

    MoreCore - Generic Ruleset
    --- Projects ---
    Extensions | Tutorials | MoreCore | MoreCore Themes | Call of Cthulhu | Maelstrom | FG Con

  10. #10
    Quote Originally Posted by damned View Post
    You should only have your license in the first field.
    The second field is only for the player/lite to full upgrade key.
    Standard to Ultimate does NOT go here.
    Thanks, noted and fixed. I'm honestly not sure how I ended up with a license key in both fields, but didn't worry about it since it didn't seem to be an issue. The main point though, is that perhaps people need to double check that they aren't using an ultimate license key that they stopped subscribing to. That appears to have been the issue for me, even though it had worked as a standard install for quite a while after I'd unsubscribed. Once I replaced that ultimate license key with my original standard key today, it worked perfectly.
    Last edited by Archamus; January 5th, 2019 at 07:00.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

Log in

Log in