5E Product Walkthrough Playlist
Page 1 of 5 123 ... Last
  1. #1

    Clients get disconnected And need to change username before they can reconnect

    Hello fellow FG-Gamers,

    I recently got FG and began convincing my players of the benefits of it and now we are slowly moving our regular group over to FG.

    So far it works fine. We already had a handful of test-connections and a short game with two players (plus GM).

    But after this little testing and fiddling around with FG we repeatedly ran into the same issue. I tried search on the forum but couldn’t find this issue. So here is what happens:

    At the very beginning of each session the players connect to my machine. The connection is successful and I see them logging in in the chat window (status message showing „playername is connected“). Meanwhile the players machines are downloading content from my machine which seems to work fine. As soon as they finish downloading, or somewhen on the way to finishing the download, but before they can choose a character they suddenly get disconnected. When they immediately try to reconnect they find out that this is not possible, unless they first change their playername.

    After changing their playername they are able to reconnect, finish the download, choose a character and start play. The connection stays stable for the whole time of play and we don’t encounter any disconnects thereafter.

    So they basically have to log in twice with different usernames before we can start play. So far this happened every time we played/tested with FG. It happened to every player and it happened with different campaigns loaded and with different installations of FG using different wine wrappers (I‘m using a Mac) on different versions of the hosting OS (macOS Sierra and High Sierra).

    Since it‘s always the same I get the impression that there is some setting responsible for that. But which? Or is this normal system behavior? I doubt it.

    Could it be that we would have to wait a little bit longer before trying a reconnect? My players, eager to start playing, always tried to reconnect right away.

    As said before, apart from this little thing everything works perfectly as it should. So it’s rather a small annoyance than a real problem. Nevertheless I would really appreciate to get it fixed.

    Hope there’s someone out there who can help me.

    Thanks a lot in advance and happy gaming

    Daniel
    Last edited by DWeiers; October 20th, 2017 at 14:30. Reason: Typo

  2. #2
    damned's Avatar
    Join Date
    Mar 2011
    Location
    Australia
    Posts
    26,827
    Blog Entries
    1
    Welcome Daniel

    I suspect your router/firewall is seeing the Fantasy Grounds traffic as some sort of TCP Flood Attack and is dropping the connection.
    Because the disconnect happened rudely the host machine thinks that the original session will rejoin and is keeping the connection open/reserved.
    If you were to wait maybe 2mins before reconnecting I suspect it would let you reconnect with the same username...

    Anyways... to fix this check your routers firewall and DDOS protection settings and try disabling them one by one - but start with anything that looks like TCP Flood protection...

  3. #3
    Okay, thank you damned!

    Good to know we just have to wait. What puzzles me, though, is the fact that the disconnect only occurs during the initial connection. When the players connect again the connection stays stable and doesn’t drop anymore. Might this be because of the bigger amount of data transferred during the initial connect?

    Anyway, I will check my router settings.

    Thanks a lot

  4. #4
    LordEntrails's Avatar
    Join Date
    May 2015
    Location
    -7 UTC
    Posts
    17,544
    Blog Entries
    9
    What's happening is during the initial connection FG is downloading a bunch of stuff. This is what your router/firewall probably thinks is a 'flood attack' (i.e. someone is trying to overwhelm it). So it cuts it off.

    Other than waiting 2 minutes for them to re-connect, I think you can kick them from the FG server on your side, and then they should be able to reconnect. But, as Damned says, fixing the settings is the preferred way to go.

    Problems? See; How to Report Issues, Bugs & Problems
    On Licensing & Distributing Community Content
    Community Contributions: Gemstones, 5E Quick Ref Decal, Adventure Module Creation, Dungeon Trinkets, Balance Disturbed, Dungeon Room Descriptions
    Note, I am not a SmiteWorks employee or representative, I'm just a user like you.

  5. #5
    Also, make sure you aren't sharing too much. Like the DMG and MM.

  6. #6
    Thanks for the input, folks.

    Just waiting a short time until the sessions time out solves the problem with the usernames, as was recommended by damned already.

    I had a chat with one of my players and we did some testing to figure out what’s happening in detail.

    Here it comes:

    The players connect with the campaign and download the stuff that’s shared. The downloads all run through smoothly. The error occurs when the clients finish downloading and start to work through the downloads.

    After downloads have finished each client gets an error:

    Ruleset: name of ruleset
    Error: Unable to load ruleset file (base.xml)
    Do you want to try reloading data?
    Yes / No


    Trying to redownload doesn’t work. Answering the question with No is terminating FG on the client side, thus producing the disconnect.

    The funny thing is:
    After a restart of FG my players can connect again (even using the same username if they wait for the session to time out) and then everything works fine and FG doesn’t download the data again. So after a restart on the client side FG behaves as if the data was downloaded correctly. My players connect to the game can choose a character and we can start playing.

    We tried to reproduce the error several times and it only occurs when my players have to download the ruleset (I.E. after a ruleset update or when playing on a campaign that uses a ruleset not yet know to them. If the campaign was played before (and the ruleset is already present on the players FG and no ruleset-download is made) everything works like a charm.

    From that I conclude that the problem is not my router but some problem on my players FG‘s unpacking or incorporating a newly downloaded ruleset.

    We tried it with two rulesets. Castles and Crusades and Savage Worlds and the error was the same on both. One player using Windows had the issue as well as one using a Mac (although i‘ll Have to check on that - I only talked to the player using windows, so far). I‘m hosting the game using a Mac.

    So looks like the problem is somewhat different from what I thought first.

    Any suggestions on this new situation?

    Nevertheless many many thanks to you all. Having a community so fast in responding and so helpful with the responses really is amazing.

  7. #7
    damned's Avatar
    Join Date
    Mar 2011
    Location
    Australia
    Posts
    26,827
    Blog Entries
    1
    Your description of what is happening is good right up to your conclusion... it is almost definitely the router doing flood protection.

    Any data previously downloaded will not be redownloaded which is why the second attempt works.

  8. #8
    Well okay, if it’s the flood protection I‘m out of luck.

    I worked through every setting of my router and there is nothing about flood protection or something similar. So looks like the router has it implemented without the possibility to disable it. Well it‘s a model from my ISP so it might not be the best choice when it comes to fine tuning, but since I‘m using a DSL/LTE Hybrid connection(which is somewhat specific) I‘ll probably have to live with it.

    What still makes me wonder is, if it‘s an issue with my router why do the clients get an error that they can’t load the ruleset file? Shouldn‘t they get something like an „connection lost“ or „disconnect error or something like that? And why do they always get this error after the download seemingly has finished?

    I have to check this again with my players but it looks like the connection is not lost the moment the error on the client side is displayed but the moment the user on the client side clicks „No“ on the error message. So far, at least according to the error message displayed, it seems like the error does occur during download and the client is prompted if he wants to retry (which makes sense). Choosing „Yes“ does nothing which leaves the user only the choice of „No“. The disconnect then occurs if the user chooses not to try to reload because this choice will terminate FG thus breaking the connection. Maybe I got this wrong but if the problem is on my side or (as perceived by FG) somewhere in between the server an the clients why does the client FG then crash with an error? Shouldn’t it just produce an error message (as it does) and then return to the launcher?

    I mean if I was the player and I connected to a FG-Host and them something goes wrong somewhere along the long way between me and the Host I would expect FG to:
    1. inform me about that (what it actually does)
    2. offer me to fix it (what it does too)
    3a. if it can be fixed, fix it (what’s obviously not possible in this case)
    3b. If it can’t be fixed, return to the launcher

    But since it’s crashing on the client side, I get the impression of something being wrong on there.

    Well I‘ll investigate on this somewhat closer and will report.

    Anyway many thanks so far

    Daniel
    Last edited by DWeiers; October 21st, 2017 at 09:47. Reason: Hopefully making the point more clear

  9. #9

    Join Date
    Apr 2008
    Location
    Virginia Beach
    Posts
    3,096
    Sounds fishy to me based on your timing discussion, DWeiers. Hard to see how the flood protection is consistently occurring as the download is completing. How can you tell again that the download has completed?

    Also, one would hope flood protection would be more effective than to let several computers download man MB of material and only invoke the protection once the computer activity rates dramatically dropped (assuming that is the case).

  10. #10
    Since the issue occurs only on the client side (I get no errors at all and my FG is running perfectly the whole time. The only thing I can see is the disconnect and connect messages in the chat) I have to check with my players again to be absolutely sure. But as far as my players told me things are as follows:

    I am going to host a game. I prepare the game well in advance so that when we want to start playing everything concerning the contents and settings of the game is already in place. Now there are three possibilities for the game to be played:

    A. It’s a game using a ruleset that my players never used before (new game with ruleset new to the players FG).
    B. It’s a game using a ruleset that my players used before but where an update of the ruleset occurred since the last time we played.
    C. It’s a game using a ruleset that my players used before and where no update or ruleset change occurred since the last time we played.

    In case C everything works fine and there are no problems at all.

    The issue only occurs in cases A and B. Which absolutely makes sense since the issue seems somehow to be connected to the initial transfer of the ruleset-data from me (host) to the players (clients). In case C the transfer is unnecessary will not be performed by FG and so no error occurs.

    Now we follow these steps (the following describes what happens in one of cases A or B from above):

    1. I start FG and fire up the campaign to be played. Since I’m going to be the Host my FG and the campaign has to run for the players to be able to connect.

    2. I give necessary information for connecting to the players (i.e. the four word „phrase“ that’s generated by my FG to facilitate connecting.

    3. My players start their FG chose „Join Game“ type in their username and the four word „phrase“ and click connect.

    4. My players FGs connect successfully to my FG. I see the „username connected“ message in the chat for each of them. Because we have either case A or B from above the players get the download screen and their FG starts downloading.

    This actually is the point where a lot of data gets transferred. I’m not an expert, but if flood protection is the issue and my router thinks „well there is too much data moved, that might be an attack!“ , shouldn’t it interrupt the transfer as quickly as possible? Isn’t that, like Bidmaron said, what flood protection is actually supposed to do?

    I‘m wondering because it doesn’t look like that at all. Instead the following happens:


    5. The data transfers run for a short while. It's not long, only maybe 30 seconds, but I have about 25 to 30 MBit upstream (2.5 to 3 MB/s) and I‘m not sharing much (only the basic Rulebook). So it’s plenty of time to transfer everything.

    6. Finally my players get an error message (as stated before in one of my previous posts) telling them that the ruleset couldn’t be loaded and asking them if they wanted to try again. I don‘t see anything of this on my machine, though. For me everything still looks perfectly okay.

    7. If my players tell their machines to retry the download (by answering the error message with „Yes“) nothing happens (the error message just comes up again - immediately! So without any further delay that might hint at their machine starting a download again). I still can’t see anything of all this on my machine. Everything still looks perfectly normal and okay on my side.

    8. Since retrying a download obviously doesn’t work, my players have no choice than choosing not to retry a download (by answering the error message with „No“). This however immediately terminates their FG (= it crashes!) which naturally results in a dropped connection. It‘s exactly at this point that I can see for the first time that something is going wrong. But still all I get is a message in chat telling me „playername disconnected … waiting for reconnect“.

    Now things start to get interesting:

    Note: We had the issues with the usernames (as describe in my first post on this thread). We solved this by just waiting for the interrupted session to time out (thus waiting for the chat message „playername disconnected“ on my machine) before we continue as follows:

    9. My players start their FG again and start over with the whole procedure of joining a game (Point 1 - 3 from above). Meanwhile I don’t change anything on my side. I just sit there in front of my machine waiting for them.

    10. They start connecting like before. This time however their FG doesn’t do any downloading. The connection process runs through as if it was a case C scenario. They connect, choose their characters and we start playing as if nothing happened. And the whole System stays stable and robust for the whole time of play (we played a two hours session this way without any further issues).

    So my conclusions:

    I. Since the players FGs initiated a download during the first connection there obviously was a need to download something. Being on a case A or B scenario that totally makes sense. When connecting again after the crash, however, they don’t download again and everything works perfectly during gameplay thereafter. That means that miraculously their FG now has all the data it didn’t have before even though there occurred an error during the first connect reporting to be unable to load. So obviously the data actually got transferred successfully during that first connection.

    To me this doesn’t look like an issue with the actual transfer of data but rather like one with the client working through the received data after transfer. Mind: the error message on the client reads „unable to load ruleset file (base.xml)“. It reads „load“ not „download“ if that means anything.

    II. I don‘t think the issue is flood protection because of two reasons.

    IIa. Flood protection usually is enforced to protect a system or network from become overwhelmed by too many connections within a short amount of time (I.e. DOS-attacks = denial of service attacks). But here there aren’t many connections. It’s just a few connections which happen to transfer some data. But that’s nothing unusual. I can easily download a 3GB movie from my Nas while on the move using my tablet or smartphone. That traffic is going through my router as well and I never had any issues with that.

    IIb. If flood protection was the issue and it was in place to prevent an increased amount of data suddenly getting transferred. Then it really did a bad job if it obviously only steps in after the data has already been transferred (see conclusion I.).

    I’m not an expert but as Bidmaron said, this looks fishy (to me too).

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Starfinder Playlist

Log in

Log in