Page 1 of 3 123 Last
  1. #1

    Mac High Sierra Updates for Fantasy Grounds

    The latest OSX update for Fantasy Grounds prevents Fantasy Grounds from launching properly. We have resolved this with the latest installer on our website but updating for people who already have it installed may take some manual steps in order to preserve your custom campaigns and personal data. For now, we recommend holding off on the High Sierra Mac Update.

    Important: Before doing anything else, please make a backup of your file. Your custom campaigns and creations are stored within this file and you can access them to copy them over from one app package to another (described later).

    Installing Fresh:
    Use the Downloads > Mac OSX Installation and follow the instructions there.

    Updating an existing WINE wrapper or installation:
    • Locate your file in Finder or in your Applications. If you are on Steam, launch Steam, go to Games Library and then right-click on Fantasy Grounds
    • Right-Click on Fantasy Grounds
    • Click on Show Package Contents
    • Double-Click on Wineskin
    • Click On "Set Screen Options"
    • Uncheck "Auto Detect GPU Info for Direct3D"
    • Click "Done"
    • Click "Quit"
    • close All the windows

    Fantasy Grounds Should now Launch

    Copying contents from a backup copy
    • On the current version of Fantasy Grounds, launch Fantasy Grounds and then click on the Folder icon on the launch screen. This will open a Finder Window and put the folder into the location where your custom content is stored. Look for folders like campaigns, portraits, modules, extensions and tokens. Make a note of the path within Finder.
    • Right-click on the (your name might be different) and then click on Show Package Contents. Navigate to the same folder structure as the step above to find your old Data Folder. The starting folder should include a "drive_c" folder within the WINE package.

  2. #2
    The settings change is not working for me in 10.13.1. Updating existing or fresh install.

  3. #3
    After making a backup of any custom campaigns or other creations you've made, can you try the latest installer from here?

    * I see that you said fresh install, but just wanted to verify since we have a number of people successfully using it on High Sierra now.

  4. #4
    Thank you for your response! Fresh install was attempted using the Mac installer as well as the Steam installer. Both fresh installs come with the option for Auto Detect GPU unchecked in the, but do not produce the Fantasy Grounds opening dialog window. The app launches for about a minute or so in the Dock, and then encounters a segfault and quits itself.

    It turns out that I'm actually running 10.13.2 beta 2. If you can confirm normal functionality in 10.13.1 I can reinstall back to a public release of macOS. If interested, I've posted the crash log here:

    If you would prefer I open a support ticket rather than use this thread, I am happy to do so.

    Thank you!

  5. #5
    Erin Righ's Avatar
    Join Date
    May 2016
    Vernon, BC, Canada
    Welcome tothe Forums

  6. #6
    Thanks for the report. We will get that over to our main Mac guy to review. We have had a number of successful tests on the new beta release of High Sierra, so that *might* be the cause. While that is a variable to consider, I hesitate to lay it completely on that when there could be other variables at work as well.

  7. #7
    I recently updated to High Sierra and found my FG no longer working. I just reinstalled using the link above after backing up my old install. Once I got my modules, extensions, campaigns, and characters copied over from the back up everything seems fine. I thought I'd add another successful datapoint in hopes it helps someone in some way.

  8. #8
    Thanks DDavison, I was going crazy.

  9. #9
    So I have been trying to get this working with help from Zacchaeus on Discord. I found that clicking the "Use Mac driver instead of X11" worked for me.
    I have no idea what that means but it worked.

    Quick Note: The pop up window for settings is under the static Update window. It's a minor thing if you jump to another virtual desktop and come back the windows change place. Otherwise you cant access the pop-up window and the mac just beeps at you.
    Last edited by devinnight; January 6th, 2018 at 00:36.

  10. #10
    Logan-05's Avatar
    Join Date
    May 2016
    Toronto, Canada
    Another thanks, DDavidson. Likewise going crazy 'till I found this thread.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts

Log in

Log in