DICE PACKS BUNDLE
Page 1 of 2 12 Last
  1. #1

    Savage Worlds - Adventure Deck errors

    Everytime I try click on a card I get this error message?

    "Runtime Error: desktop: Unable to create window with invalid class (adventurecard_image : refimage.cards.ace@Adventure Deck)"
    "Runtime Error: desktop: Unable to create window with invalid class (adventurecard_image : refimage.cards.adrenalinesurge@Adventure Deck)"

    The deck is not showing in the toolbox, even though it is loaded?

    Any ideas? I have tried restarting FG with and without the .ext and updating but the cards are unusable?

    When I try and allocate a card I get.

    Script Error: [string "scripts/adventuredeck_lib.lua"]:40: attempt to index global 'Global' (a nil value)
    Script Error: [string "scripts/manager_characterlist.lua"]:4: attempt to index global 'CharacterSelectManager' (a nil value)
    Script Notice: [WARN] ChatManager.registerVersionMessage is deprecated function. No need to manually register extension versions anymore
    Script Error: [string "scripts/manager_adventuredeck.lua"]:43: attempt to index upvalue 'deck' (a nil value)


    Martin
    Last edited by Martin153; June 7th, 2017 at 12:21.

  2. #2
    Trenloe's Avatar
    Join Date
    May 2011
    Location
    Colorado, USA
    Posts
    33,676
    Please type /version in the chat window and post the results here.
    Private Messages: My inbox is forever filling up with PMs. Please don't send me PMs unless they are actually private/personal messages. General FG questions should be asked in the forums - don't be afraid, the FG community don't bite and you're giving everyone the chance to respond and learn!

  3. #3

  4. #4
    Trenloe's Avatar
    Join Date
    May 2011
    Location
    Colorado, USA
    Posts
    33,676
    The adventure deck should be version 1.6 for use with the Savage Worlds v4.4 ruleset.

    Check that you don't have an unzipped directory in <FG app data>\extensions called "AdventureDeck". If you don't re-run an FG update and check the versions again.
    Private Messages: My inbox is forever filling up with PMs. Please don't send me PMs unless they are actually private/personal messages. General FG questions should be asked in the forums - don't be afraid, the FG community don't bite and you're giving everyone the chance to respond and learn!

  5. #5
    I don't think anything has changed. I have 'Updated' a few times as well. Some of my 5e stuff updated earlier today but nothing in SW. Nothing unzipped in any directory's.

    Attachment 19271

    I can open the cards in the library, but can't do anything with them. Just get the error messages when I try.
    Last edited by Martin153; June 7th, 2017 at 16:19.

  6. #6
    Trenloe's Avatar
    Join Date
    May 2011
    Location
    Colorado, USA
    Posts
    33,676
    Go to <FG app data>\extensions delete AdventureDeck.ext and re-run an update.

    Make sure you have your FG username (and password) entered on the settings screen before doing the update. If you made any purchases on Steam, make sure you've linked your Steam account - button to do this on the settings screen.
    Private Messages: My inbox is forever filling up with PMs. Please don't send me PMs unless they are actually private/personal messages. General FG questions should be asked in the forums - don't be afraid, the FG community don't bite and you're giving everyone the chance to respond and learn!

  7. #7
    I removed it from <FG app data>\extensions and nothing updated. Adventure deck wasn't added. FG username etc has never changed. I do not have any purchases etc from steam.

    I must have purchased it a long time ago if that helps. It's no biggie as it wont stop me playing. I don't think I actually used them when they did work!
    Last edited by Martin153; June 7th, 2017 at 16:33.

  8. #8
    Trenloe's Avatar
    Join Date
    May 2011
    Location
    Colorado, USA
    Posts
    33,676
    Re-enter your "FG Store Login" in the Settings screen. Click the "Update" button and enter your password, click the "Login" button. On the Settings screen click the "OK" button. Then on the Updater screen click the "Update" button. Even if nothing's changed and you've done this before, please try it again.
    Private Messages: My inbox is forever filling up with PMs. Please don't send me PMs unless they are actually private/personal messages. General FG questions should be asked in the forums - don't be afraid, the FG community don't bite and you're giving everyone the chance to respond and learn!

  9. #9
    ;( Sorry Trenloe.. Tried and nothing updated .. Still getting the error messages.

    Please don't consider this urgent. Its a low priority for me but would like it working at some point. I purchased it when I purchased the original SW Guides and 50 Fathoms about 2 years ago...
    Last edited by Martin153; June 7th, 2017 at 16:46.

  10. #10
    Trenloe's Avatar
    Join Date
    May 2011
    Location
    Colorado, USA
    Posts
    33,676
    Other than a file or existing directory stopping the update on your computer, check your purchase history (Store -> Order History) and see if the purchase is attached to your user ID.

    When you removed the AdventureDeck.ext, and restarted FG, could you still see the Adventure Deck available to select in the Campaign start window?
    Last edited by Trenloe; June 7th, 2017 at 16:53.
    Private Messages: My inbox is forever filling up with PMs. Please don't send me PMs unless they are actually private/personal messages. General FG questions should be asked in the forums - don't be afraid, the FG community don't bite and you're giving everyone the chance to respond and learn!

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
5E Product Walkthrough Playlist

Log in

Log in