DICE PACKS BUNDLE
  1. #1

    Adventure deck, new card: Image not visible

    Hi all,

    I tried to add new cards to the adventure deck. Everything fine so far (card is available, it is put to the right set of cards, if it is drawn, the text (e.g. what effect the card has) is displayed, but the images are not there (empty space, you can`t see the card in the character sheet, you just get the name if you hover above it with the mouse).

    The image file is created, with the correct pixel range, adventuredeckconfig.lus is modified, graphics.xml-file is adapted, the pictures are loaded in the grpahics/cards/ - folder.

    The card is called "Ghostblade". In the adventuredeckconfig.lua, the "image="" " should be correct, as this refers to the "big picture" when you double-click on the card. Could be a problem with the XML-File, I have no idea.

    Any ideas are welcome, thanks for your efforts in advance...!

    __________________________________________________ __________________________________________________ __

    details of the files (card "Send in the Clones" put form reference, a standard, not-customied and working card):

    adventuredeckconfig.lua:

    ScifiCards = {
    ["SendintheClones"] = { name = "Send in the Clones", effect = "Play when your character is Incapacitated. The character dies immediately and an unharmed duplicate (or is it the original...) appears on his next initiative.", image = "refimage.cards.sendintheclones@Adventure Deck" },
    ["Ghostblade"] = { name = "Ghostblade", effect = "Play this card before the first round of a battle. For the duration of the battle, you can now use the Ghostblade, which does STR+2d6 etheral damage, which can also harm beings that are not vulnerable to normal weapons.", image = "" },
    }


    graphics.xml-file:

    <?xml version="1.0" encoding="iso-8859-1"?>
    <!-- -->
    <!-- To include new cards, first create the images as outlined in the graphics/cards/README.txt file, then create entries here -->
    <!-- -->
    <!-- Each card should have two lines, one for the full-sized card called CARDNAME (e.g. the name of the card), and the other -->
    <!-- should be CARDNAME-drag, for the draggable smaller-sized card -->
    <!-- -->

    <root version="2.9">
    <icon name="Ghostblade" file="graphics/cards/Ghostblade.jpg" />
    <icon name="Ghostblade-drag" file="graphics/cards/Ghostblade_drag.jpg" />
    </root>


    names of the files in the adventuredeckconfig/graphics/card - file:

    Ghostblade.jpg
    Ghostblade_drag.jpg

    __________________________________________________ ________________________________________________

  2. #2
    Trenloe's Avatar
    Join Date
    May 2011
    Location
    Colorado, USA
    Posts
    33,570
    Have you created the "AdventureDeckConfig" extension as a separate extension? As per page 9 of the "Adventure Deck Documentation.pdf" guide found in <FG App Data>\docs?
    Private Messages: My inbox is forever filling up with PMs. Please don't send me PMs unless they are actually private/personal messages. General FG questions should be asked in the forums - don't be afraid, the FG community don't bite and you're giving everyone the chance to respond and learn!

  3. #3
    Yes, in the folder "fantasy grounds/extensions", I have placed the folder "AdventureDeckConfig" with all data (folders "graphics" and "Scripts" with the data, etc., copied all extraced files).

  4. #4
    Trenloe's Avatar
    Join Date
    May 2011
    Location
    Colorado, USA
    Posts
    33,570
    Open the console before you start using cards by typing /console in the chat window. This might give you warnings about icons not being available. Then use some of the new cards and see if there are any warnings in the console.
    Private Messages: My inbox is forever filling up with PMs. Please don't send me PMs unless they are actually private/personal messages. General FG questions should be asked in the forums - don't be afraid, the FG community don't bite and you're giving everyone the chance to respond and learn!

  5. #5
    I opened the console, dragged a new card to the character sheet and played it from there to the chatbox. No warning appeared in the console. The text of the card has been displayed in the charsheet and in the chatbox, but no image in both cases. I also exchanged the image with a jpg created with paint (just 149x208 pixels, white background with a red dot), because I thought the jpg.file of the original picture could be corrupted. However, this didn`t help either.

    Strange...

  6. #6
    Trenloe's Avatar
    Join Date
    May 2011
    Location
    Colorado, USA
    Posts
    33,570
    Maybe post your extension so we can try?

    If you don't want to post publicly, PM me a download link.
    Private Messages: My inbox is forever filling up with PMs. Please don't send me PMs unless they are actually private/personal messages. General FG questions should be asked in the forums - don't be afraid, the FG community don't bite and you're giving everyone the chance to respond and learn!

  7. #7
    No problem, nothing to hide :-) There is just one additional card inside as a first test (Ghostblade)

    Thanks for your efforts. The files are attached. I had to rename the adventuredeckconfig.lua into adventuredeckconfig.txt for the upload.
    Last edited by CarstenB; May 10th, 2017 at 17:00.

  8. #8
    Argh. After the upload of the files, I found the mistake myself - as can be seen, the images are named Ghostblade.jpg.jpg. (didn`t realize as the file was just shown as ghostblade.jpg on the computer).

    After removing the second .jpg , it worked out fine.

    Stupid, sorry.

  9. #9
    Removed the uploads to spare the file space. Thanks again for your efforts, without uploading the files I think I would have looked for the mistake about forever :-)

  10. #10
    Trenloe's Avatar
    Join Date
    May 2011
    Location
    Colorado, USA
    Posts
    33,570
    Quote Originally Posted by CarstenB View Post
    Thanks again for your efforts, without uploading the files I think I would have looked for the mistake about forever :-)
    Haha, no worries. Glad you got it sorted out. :-)
    Private Messages: My inbox is forever filling up with PMs. Please don't send me PMs unless they are actually private/personal messages. General FG questions should be asked in the forums - don't be afraid, the FG community don't bite and you're giving everyone the chance to respond and learn!

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
FG Spreadshirt Swag

Log in

Log in