1. #1
    Trenloe's Avatar
    Join Date
    May 2011
    Location
    Denver, Colorado, USA (for a bit)
    Posts
    23,644

    v3.3.5 - Issues/Problems after updating. Random script errors, etc..

    If you are having issues with Fantasy Grounds v3.3.5, check the following:
    1. Are you running any extensions? (Check the whole "Extensions:" list on the "Load Campaign" screen). If so, see the "Extensions" section below.
    2. On the main Fantasy Grounds launch screen, check your version number in the top right corner. You should see "v3.3.5" (for the full/standard version), "v3.3.5 Ultimate" (for the ultimate version) or "v3.3.5 FREE" (for the free/demo version). If you don't see v3.3.5 ... then re-run your update. If you still don't see this then see "Wrong Fantasy Grounds version" below.
    3. In a campaign you are having issues with, check the ruleset versions - these will be displayed in the chat window after loading up the campaign. Any CoreRPG based rulesets (5E, 4E, 3.5E, PFRPG, C&C, Call of Cthulhu, etc.) will show the ruleset you're running plus the CoreRPG version - these should both be v3.3.5A - slightly confusing I know - FG v3.3.5A was a minor ruleset only update, v3.3.5 is the current application version. If they aren't then check "Wrong RuleSet version" below.


    Extensions
    This is the biggest cause of issues after updating Fantasy Grounds. The majority of extensions will need to be updated to work correctly with FG v3.3.5 - even if they "appear" to work OK they could be breaking FG functionality in the background. For *all* of the extensions you run go and check for updated versions and download and install the v3.3.5 updates.

    If an extension doesn't say it's v3.3.5 compatible assume it isn't! Disable this extension for now.

    If you have a bunch of extensions installed, and they are all v3.3.5 compatible, and you still have issues then check items #2 and #3 in the list above. If, after checking these, you still have problems then try to recreate the issue in a brand new campaign for the ruleset in question. If there are no issues in the brand new test campaign then the issue might be caused by an extension that is listed as compatible but might not actually be 100% compatible - disable the extensions and add them back one-at-a-time and test. If the issue occurs after adding in a specific extension, then there's a good chance it is being caused by that extension, or that extension clashing with another extension. Disable all extensions except this last identified problem extension - if the issue occurs, then turn the extension off; if the issue doesn't occur with the extension now turned off then it is probably the extension causing the issue. Post in the extension specific thread with details of the problem so the dev can look at the issue. Disable this extension for now.

    Wrong Fantasy Grounds Version
    You should see one of the following version numbers/flavours in the top right corner of the main FG launch screen: "v3.3.5" (for the full/standard version), "v3.3.5 Ultimate" (for the ultimate version) or "v3.3.5 FREE" (for the free/demo version). If you don't:
    1) Make sure your FG setting screen shows: Updates -> Mode: -> "Live". If mode is "Test" or "Dev" then change it to "live" and run an update.
    2) If the flavour (standard/full, ultimate, free) is incorrect then make sure you have your "License Key" entered correctly at the top of the FG setttings screen. Run an update after making sure the license key is correct - ensure there are no spaces before or after the key.
    3) In the "Fantasy Grounds Store Purchases" section of the settings window, make sure you have entered for FG website "User Name", pressed "Update", entered your password pressed "Login". You should see all of your purchases in the "Fantasy Grounds Store Purchases" section. Press "OK" to close the setting window and then press "Update" on the updater window.
    4) Don't install Fantasy Grounds twice. You can't have two installations cohabiting nicely on the same computer (they share the same registry settings). Uninstall/delete one of the installations (being careful not to delete your data directory) and then run FG (using the shortcut that points to the installation you are keeping), setup your license, username etc. and run an update.

    If, after all of this, you are seeing the wrong version number in the top right of the FG launcher, check that the startup shortcut you are using is pointing at the right FantasyGrounds.exe file. Open the FG settings window and look at the "General" -> "App Directory" setting. This will be pointing to a directory that should contain the FantasyGrounds.exe file. If this is a different directory to the startup shortcut you're using, then delete the shortcut and create a new one that links to FantasyGrounds.exe in the directory pointed to by the FG setting "General" -> "App Directory". A quick check is to open this directory and double-click on FantasyGrounds.exe to run the file - if it still shows the wrong version number then delete this file and run an update. Check that a new FantasyGrounds.exe file is downloaded, double-click on this to run.

    Wrong RuleSet version
    If both ruleset versions reported in the chat window after loading up a campaign are not v3.3.5A (including CoreRPG) then try the following:
    1) Make sure your FG setting screen shows: Updates -> Mode: -> "Live". If mode is "Test" or "Dev" then change it to "live" and run an update.
    2) On the main FG launch screen click the folder icon in the top right to open the <FG App Data> directory in file explorer. Navigate to the "rulesets" directory and look for directories called CoreRPG or the name of the ruleset you are loading. If these directories exist, they are unpacked old version of the ruleset and are causing issues. Delete them (or, if you really want to keep them rename them to something like <ruleset>_old) and then try loading your campaign again and look at the versions reported in the chat window.
    3) If you don't have any unpacked files in your FG \rulesets directory (step #2 immediately above) then delete the relevant .pak files in the FG \ruleset directory and run an update to download the latest files.

    Still got issues?
    If, after trying all of the above, you still have issues then please start a thread in the "House of Healing" forum with as much details of the issue as possible:
    1) ruleset being used.
    2) Screenshot of the issue.
    3) Steps to recreate.

    Etc..

    And - it has to be said again. Make sure you can recreate the issue *without* any extensions loaded!
    Last edited by Trenloe; June 11th, 2018 at 22:56. Reason: Updated for v3.3.5A

    FG Con 15 Fantasy Grounds Online RPG Convention - Nov. 8-10, 2019
    Register at www.fg-con.com for all the latest info.

    Private Messages: My inbox is forever filling up with PMs. Please don't send me PMs unless they are actually private/personal messages. General FG questions should be asked in the forums - don't be afraid, the FG community don't bite and you're giving everyone the chance to respond and learn!

  2. #2
    Trenloe's Avatar
    Join Date
    May 2011
    Location
    Denver, Colorado, USA (for a bit)
    Posts
    23,644
    Placeholder 1.

    FG Con 15 Fantasy Grounds Online RPG Convention - Nov. 8-10, 2019
    Register at www.fg-con.com for all the latest info.

    Private Messages: My inbox is forever filling up with PMs. Please don't send me PMs unless they are actually private/personal messages. General FG questions should be asked in the forums - don't be afraid, the FG community don't bite and you're giving everyone the chance to respond and learn!

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

Log in

Log in