Page 4 of 14 First ... 23456 ... Last
  1. #31
    damned's Avatar
    Join Date
    Mar 2011
    Location
    Australia
    Posts
    19,042
    Blog Entries
    1
    Oh yeah... back to the PC you go!

  2. #32
    I have this successfully running and installed on ARCH linux but I am having only one issue. When I zoom on the picture to zoom in or out, it just shrinks or enlarges it, it is quite frustrating but still workable. Is anyone else having this issue?

    Screenshot at 2016-03-14 12:53:00.png
    Last edited by servvs; March 14th, 2016 at 20:45.

  3. #33
    Quote Originally Posted by Blahness98 View Post
    Sorry for this, but does the /scaleui command add black bars to anyone else's FG window? I am running FG via crouton and trusty. The buttons and everything are still behind the black bars, but it just does not redraw properly. Reseting the ui scale to 100 removes the bars and places everything. Running out of ideas.
    Have your tried running it in a virtual desktop with wine at the preferred resolution and then scale the wine desktop window to fit your screen?

  4. #34
    Quote Originally Posted by Blahness98 View Post
    Sorry for this, but does the /scaleui command add black bars to anyone else's FG window? I am running FG via crouton and trusty. The buttons and everything are still behind the black bars, but it just does not redraw properly. Reseting the ui scale to 100 removes the bars and places everything. Running out of ideas.
    Yes, I also get black bars on Fedora 23 x86_64 when scaling less than 100%. Scaling more than 100% works just fine. I expect scaling up the UI for a large monitor is the more well tested change.

    50pct-scale.png

  5. #35
    Quote Originally Posted by servvs View Post
    I have this successfully running and installed on ARCH linux but I am having only one issue. When I zoom on the picture to zoom in or out, it just shrinks or enlarges it, it is quite frustrating but still workable. Is anyone else having this issue?

    Screenshot at 2016-03-14 12:53:00.png
    There is only one solution to fix this, change your UI scaling to 101%, this forces the rendering to a background buffer that is scaled. This fixes the window clipping issues.

    See my post here:
    https://www.fantasygrounds.com/forum...rge-map-images

  6. #36
    Galach's Avatar
    Join Date
    Jun 2013
    Location
    Curitiba (Brazil)
    Posts
    152
    Resurrecting an old thread...

    I just finished installing Fantasy Grounds on my new Linux box. FG installs, update and run flawlessly, except by the vertical clipping on the right part of window, exactly 25% of it.

    To solve this, I need to load a campaign or the character creation section, right click on FG window, select the “restore window” option and then “maximize window”.

    Aside from that, and as far as I tested it, it works perfectly: maps, layers, campaigns, modules, tokens, and I was even able to recover my backups – my former campaigns and characters are ok.

    I wasn't able to make a stress test yet, but animations and general response seems to be better than on Windows 10.

    Installation:
    Dell Inspiron 5457 laptop (i5, 8gb ram, amd radeon r7 m265 gpu, fglrx-update driver)
    Linux Mint 17.3 Cinnamon (based on Ubuntu 14.04 – my gpu does not have a compatible driver for 16.04 yet)
    Latest stable Wine Version (ver 1.8.3, clean wineprefix, winetricks and ms corefonts, windows 7).

    Fantasy Grounds installed and updated without any error message, and without the need of any change on folder path/structure.

    The initial clipping is annoying, but not a deal breaker. Tomorrow night I will ask all my players to log in a session to see how it works, but I am very optimistic.

    Screenshot from 2016-08-10 01:56:10.png Screenshot from 2016-08-10 01:57:03.png Screenshot from 2016-08-10 01:57:09.png Screenshot from 2016-08-10 01:57:24.png

  7. #37
    dulux-oz's Avatar
    Join Date
    Jan 2012
    Location
    Brisbane, Australia
    Posts
    4,034
    Blog Entries
    14
    Excellent - thankyou for the update/notification!
    Dulux-Oz

    √(-1) 2^3 Σ Π
    ...And it was Delicious!


    Alpha-Geek
    ICT Professional
    GMing Since 1982
    NSW, Australia, UTC +10
    LinkedIn Profile: www.linkedin.com/in/mjblack

    Read my FG Blog here.

    Watch our games on Twitch: www.twitch.tv/dulux_oz

    Support Ongoing Video, Ruleset & Extension Development: via PayPal (Send To: [email protected])

    YouTube Channel/Tutorial Playlists: www.youtube.com/c/duluxoz

  8. #38

    Join Date
    Dec 2014
    Location
    The great white North
    Posts
    5
    With the new version that cam out late 2016, I now have some issues when I'm the one running the game. Some of the ''modules'' or Framedef do not load properly. I have taken screen shots of what I see in the warning windows and how FG displays the icons.
    I use Linux / Ubuntu.
    Can you help me resolve these issues?

    FG Issues-fantasy.png

    FG-issues-Fantasy-01.png

    FG Issues.png

    FG-Issues-Sci-Fi-01.png

  9. #39
    It looks like some older extensions/themes are being loaded in your campaign. You can turn them on/off at the launch screen to see which one is causing the issue.

    The latest update will automatically update the associated DLC files on your machine, unless you have unpacked them into folders in the rulesets or extensions subdirectories under the FG data directory. (Use the folder button in upper right of launch screen to access FG data folder.)

    Regards,
    JPG

  10. #40
    skj310's Avatar
    Join Date
    Jun 2016
    Location
    Queensland, Australia
    Posts
    141
    Blog Entries
    4
    OS - linuxmint 18.1 (x64 system)
    FG - 3.2.3 (with a bunch of extensions that are optimised for 3.2.2 ... no ext running that is less than 3.2.2 compatible)
    wine is wine-staging and not the default wine you'd install with "sudo apt install wine"; but instead i'm running the staging versions: 2.1.0~ubuntu16.04.1

    I just thought I would post a thought with regard to the clipping that was mentioned above. I can think of 2 things related to that issue:
    1. clicking maximise in FG
    2. video card driver and non-primary monitor

    So let me see if i can add some clarity to where i'm coming from ...

    My 1st bullet I mentioned clicking the FG maximise button ...
    If FG opened on my primary monitor (which it ALWAYS does), and I clicked the FG maximise there, it worked as expected and maximised. BUT!!! If I did not keep the focus on the FG window, then things went awry. The FG window would disappear even though it was still running and i could see it in my task bar. I would have to use shortcut keys like <ALT>+<SPACEBAR> to get the FG window back and then i'd need to un-maximise it. It was a royal pain.

    If FG opened on my primary monitor (which it ALWAYS does), then i dragged it to my 2nd monitor 1920x1200 res, and I clicked maximise, then I saw the same clipping that was shown in the screenshots above.

    SOLUTION - DO NOT MAXIMISE, but instead resize the FG window to the size of your monitor. So the FG window did not have the "maximise" condition flag set, but still it was more or less fullscreen from my resizing the FG window to the extents of my 1920x1200 monitor. Or the primary monitor which is 1920x1080. In either case the trick to avoid clipping was to resize the FG window.

    In my 2nd bullet I mentioned video card driver. My laptop is a gaming laptop and therefore has a nvidia and intel chip. The intel chip is a powersaving chip and doesn't support an external monitor, so i've no comment on that. I keep the nvidia driver active and my monitor is connected via DP (display port). I had no end of problem with the nvidia-375 driver. Pain in the a$$ that version! Recently the nvidia-378 version was released and this one solved problems for me. With the 375 flavour, i had a hard time getting my 2nd monitor to work properly and this flavour saw my primary monitor (i.e. laptop screen) and the DP connected 1920x1200 monitor as just 1 large monitor of 3840x1080. I won't get into how to get around that problem as it isn't worth talking about since nvidia-375 with external monitors for linux is bjorked! Instead use the nvidia-378 driver and then things start to work properly and as I would expect for plug n play. Was there clipping with nvidia-375 ... no! I only mention it because of all the issues i had, and I would highly recommend moving to 378 if your h/w supports it (otherwise you'll need to try an earlier flavour - something i didn't actually do, so i've no suggestions about earlier drivers ... other than perhaps an earlier one will work properly and show both monitors as separate entities. Perhaps you are ok with just 1 large screen. In my situation I was not. I wasn't happy having a 1920x1200 monitor and only be able to use 1080 ... drove me mad it did!

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

Log in

Log in