Page 14 of 14 First ... 4121314
  1. #131
    After reinstalling FG the game game won't even start with Proton 4.2-9

  2. #132
    damned's Avatar
    Join Date
    Mar 2011
    Location
    Australia
    Posts
    18,865
    Blog Entries
    1
    The current Game Engine has no Linux client.
    The FGU version of the software - hopefully coming for Xmas - will have a native Linux client.
    Until then its not a possibility.

    MoreCore - Generic Ruleset
    --- Projects ---
    Extensions | Tutorials | MoreCore | MoreCore Themes | Call of Cthulhu | Maelstrom | FG Con

  3. #133
    Quote Originally Posted by damned View Post
    The current Game Engine has no Linux client.
    The FGU version of the software - hopefully coming for Xmas - will have a native Linux client.
    Until then its not a possibility.

    so that means, for anyone who bought the regular game and not the ultimate license won't be able to play from Linux natively?

  4. #134
    damned's Avatar
    Join Date
    Mar 2011
    Location
    Australia
    Posts
    18,865
    Blog Entries
    1
    No. The current Game Engine only has a native Windows client.
    Mac and Linux support is via a Wine skin/wrapper/other.

    The current Game Engine will likely become known as Fantasy Grounds Classic or FGC in the near future.
    The future game engine (which we are hoping might drop for Xmas) will likely be known as Fantasy Grounds Unity or FGU.
    The new game engine will have native Linux and Mac builds.

    At this point in time the game runs on Linux via an emulator.
    If you use the Steam install it will install a Wine wrapped instance of Fantasy Grounds.
    I dont know what version of Linux it was prepped on but there are hundreds of versions of Linux and the Wine wrapper will likely need some tuning to work on your version of Linux.

    There are some quite detailed posts about what settings others have used for various builds.
    Unfortunately you are probably going to need to read some of those and try something similar.

    MoreCore - Generic Ruleset
    --- Projects ---
    Extensions | Tutorials | MoreCore | MoreCore Themes | Call of Cthulhu | Maelstrom | FG Con

  5. #135
    thanks for the info. looking forward for the new engine.

  6. #136
    Used latest wine from Playonlinux, only deviation from OP and worked like a dream on popOS 19.04 =P

  7. #137
    Using Linux Mint 19.1 (Ubuntu based) this worked with wine 3 a few days ago, but after the latest update to the proprietary NVIDIA drivers, I get a weird error now. The upgrade manager still works fine, and updating to wine 4 doesn't fix it. Has anybody else seen this? I know there's the Unity version with native Linux build coming, but I'd love to know if I can use the classic until then.

    0009:fixme:win:EnumDisplayDevicesW ((null),0,0x33f924,0x00000000), stub!
    X Error of failed request: BadValue (integer parameter out of range for operation)
    Major opcode of failed request: 154 (GLX)
    Minor opcode of failed request: 3 (X_GLXCreateContext)
    Value in failed request: 0x0
    Serial number of failed request: 189
    Current serial number in output stream: 190

  8. #138
    Turns out this WAS related to the NVIDIA video drivers. Some of the older driver libraries didn't get removed by the newer ones.

    sudo apt list | grep nvidia | grep installed Gave me a list of packages, most of which had 430 (the lastest version number) but with a couple that ALSO had an earlier number. Specifically uninstalling those older dupes (AND RESTARTING!) worked for me.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

Log in

Log in