1. #1

    Fantasy Grounds Crashing using Proton on Linux (as of today)


    I've been using Fantasy Grounds on Arch Linux successfully for a few weeks now by using Proton through Steam. Last time I was using it successfully was 5 days ago. Today I went to try and launch my 5e campaign to start my prep for this Sunday, and no campaign will launch. It crashes on the loading screen.

    What I've tried:
    • Rebooting my computer
    • Launching a brand new 5e campaign
    • Looked for logs, but the only log that seems like it might be where useful information is stored (console.log) isn't showing anything other than a font warning.

    Am I missing some method of seeing debug/crash logs? At this point I'm not sure if it's an issue with Fantasy Grounds or something I've updated over the past week, but I'd love to be able to narrow it down.

    Thanks for any help!

    Edit: I've been wanting to try out Manjaro for gaming anyway, so I installed on another partition on the same computer. Fantasy Grounds worked perfectly again, right off the bat (along with other games I couldn't ever get working on Arch) so I'll just be using Manjaro for it I think.
    Last edited by elzzid; August 1st, 2019 at 17:44.

  2. #2
    I don't know if it's related, but I was trying the demo for the first time last week (using Wine directly instead of Steam and Proton) and after an update to the NVIDIA drivers the demo no longer runs. It will run the Fantasy Grounds Updater program, but whenever the actually application starts, it errors out with these details:

    0009:fixme:win:EnumDisplayDevicesW ((null),0,0x33f924,0x00000000), stub!
    X Error of failed request: BadValue (integer parameter out of range for operation)
    Major opcode of failed request: 154 (GLX)
    Minor opcode of failed request: 3 (X_GLXCreateContext)
    Value in failed request: 0x0
    Serial number of failed request: 189
    Current serial number in output stream: 190

    Edit with an update:

    Turns out this WAS related to the NVIDIA video drivers. Some of the older driver libraries didn't get removed by the newer ones.

    sudo apt list | grep nvidia | grep installed Gave me a list of packages, most of which had 430 (the lastest version number) but with a couple that ALSO had an earlier number. Specifically uninstalling those older dupes (AND RESTARTING!) worked for me.
    Last edited by frobnic8; August 1st, 2019 at 04:09.

  3. #3
    damned's Avatar
    Join Date
    Mar 2011
    Blog Entries
    What? You had to restart your *nix box?

  4. #4
    Quote Originally Posted by damned View Post
    What? You had to restart your *nix box?
    haha! Yeah, I probably could have just restarted the X window server, but I'm lazy.

  5. #5
    LordEntrails's Avatar
    Join Date
    May 2015
    GMT -7
    Blog Entries
    Quote Originally Posted by frobnic8 View Post
    haha! Yeah, I probably could have just restarted the X window server, but I'm lazy.
    I think you just lost your street cred. No 3000 days of uptime?

    Current Projects: Ultimate Undermountain (NYDUM)
    Community Contributions: Gemstones, 5E Quick Ref Decal, Adventure Module Creation, Dungeon Trinkets
    DMsGuild Content: Balance Disturbed (Adventure), Dungeon Room Descriptions
    FG Product Reviews: Virtual Scribe Reviews

  6. #6
    Running on an AMD video card, so I don't think it was related to NVIDIA drivers, but I forgot to mention that in the post, oops! Could possibly have still been video-driver related, but I decided to just try out Manjaro, which seems to work much better for gaming so far anyway. Being an Arch-derivation, I'm quite comfortable there. Probably not the best idea to try gaming on an ever-shifting platform eh?

    Thanks for the idea though! Maybe it'll help someone else down the road.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts

Log in

Log in