Page 4 of 8 First ... 23456 ... Last
  1. #31
    dr_venture's Avatar
    Join Date
    Apr 2009
    Location
    Yosemite, CA
    Posts
    1,126
    Quote Originally Posted by Andraax View Post
    Yes. I have confirmed that the change to ref_ability has broken C&C for 3.0.4 (as you also did).
    Thanks bud - I added a comment about this in the 3.0.4 dev thread.
    "A ship in harbor is safe, but that is not what ships are built for." - John Shedd
    "Why is it every time we need to get somewhere, I get waylaid by jackassery?" - Dr. Thaddeus Venture
    -- CA (Pacific time zone) --

  2. #32
    Where exactly are these errors occurring in the PHB? SF
    Aliens.... Go fig?

  3. #33
    dr_venture's Avatar
    Join Date
    Apr 2009
    Location
    Yosemite, CA
    Posts
    1,126
    While running FG 3.0.4, open the PHB, then open a class or race that has some linked abilities. Click on an ability, and an error message is displayed.
    "A ship in harbor is safe, but that is not what ships are built for." - John Shedd
    "Why is it every time we need to get somewhere, I get waylaid by jackassery?" - Dr. Thaddeus Venture
    -- CA (Pacific time zone) --

  4. #34
    It's an easy enough to fix (replacing "ability" with "ref_ability") and I've already "fixed" the PHB, and CKG. Modules previous to this didn't have abilities (remember we pushed for their inclusion), So these should be the only two modules affected, aside from the Crusaders Companion. If you use find and replace on the beginning chunk of the "ability" tag, you also won't change any words called "ability" in the main text. Oh, Cry Havoc and Release the Dogs of War. Cheers, SF
    Aliens.... Go fig?

  5. #35
    dr_venture's Avatar
    Join Date
    Apr 2009
    Location
    Yosemite, CA
    Posts
    1,126
    The fix is simple and I've already done it, but any modules that users have created that link to Abilities will be broken. Not sure what others are seeing, but *all* existing materials referencing the "abilities" window class will break... including all existing campaigns, as far as I can tell. I just tried it on a copy of my current active campaign, and none of the character abilities can be opened from a character sheet. I don't see any way around this other than coding for legacy windowclasses in the FG app.
    "A ship in harbor is safe, but that is not what ships are built for." - John Shedd
    "Why is it every time we need to get somewhere, I get waylaid by jackassery?" - Dr. Thaddeus Venture
    -- CA (Pacific time zone) --

  6. #36
    Quote Originally Posted by dr_venture View Post
    The fix is simple and I've already done it, but any modules that users have created that link to Abilities will be broken. Not sure what others are seeing, but *all* existing materials referencing the "abilities" window class will break... including all existing campaigns, as far as I can tell. I just tried it on a copy of my current active campaign, and none of the character abilities can be opened from a character sheet. I don't see any way around this other than coding for legacy windowclasses in the FG app.
    It is possible to delete skills and abilities, and re-add them from the new module? That worked for my campaign. And backwards compatibility (as we've seen) usually compounds errors. Comments?
    Aliens.... Go fig?

  7. #37
    dr_venture's Avatar
    Join Date
    Apr 2009
    Location
    Yosemite, CA
    Posts
    1,126
    The issue is totally up to Smiteworks, so discussion seems kind of pointless to me. Also, I'd prefer to keep this thread focused on the Crusader's Companion supplement, as opposed to the merits of backwards compatibility.
    "A ship in harbor is safe, but that is not what ships are built for." - John Shedd
    "Why is it every time we need to get somewhere, I get waylaid by jackassery?" - Dr. Thaddeus Venture
    -- CA (Pacific time zone) --

  8. #38
    damned's Avatar
    Join Date
    Mar 2011
    Location
    Australia
    Posts
    18,878
    Blog Entries
    1
    id be ok with players deleting and re-adding abilities.
    is 3.0.4 likely to go live between now and FG Con?

    MoreCore - Generic Ruleset
    --- Projects ---
    Extensions | Tutorials | MoreCore | MoreCore Themes | Call of Cthulhu | Maelstrom | FG Con

  9. #39
    This has been changed back, update FG.
    Ultimate License Holder - Anyone can play in my games, even using the free version of Fantasy Grounds.


  10. #40
    dr_venture's Avatar
    Join Date
    Apr 2009
    Location
    Yosemite, CA
    Posts
    1,126
    Quote Originally Posted by dberkompas View Post
    This has been changed back, update FG.
    Ah - thanks for the update!
    "A ship in harbor is safe, but that is not what ships are built for." - John Shedd
    "Why is it every time we need to get somewhere, I get waylaid by jackassery?" - Dr. Thaddeus Venture
    -- CA (Pacific time zone) --

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

Log in

Log in